Old 03-16-2018, 01:06 PM   #1
Link0126
Human being with feelings
 
Link0126's Avatar
 
Join Date: Jul 2010
Posts: 1,264
Default Plugins stealing focus

I'm trying to use the shortcuts shown in this video to open and close FX on the track under the mouse cursor. The problem I'm having is the plugins once open don't pass the shortcut to reaper so I can't close the FX window with the keyboard shortcut. I get like a beep sound and nothing happens. I have to click back on the main window for the shortcut to work. So it kind of defeats the purpose. This seems to be happening with both third party and stock plugins.

On the latest OSX and reaper.


Video:
https://youtu.be/jS6ltFgYQPo?t=5m39s
Link0126 is offline   Reply With Quote
Old 03-16-2018, 01:42 PM   #2
Stella645
Human being with feelings
 
Join Date: Sep 2008
Location: UK
Posts: 1,872
Default

https://forums.cockos.com/showthread.php?p=1427192

Not that promising....seems to be an ongoing problem.
Stella645 is offline   Reply With Quote
Old 03-16-2018, 01:55 PM   #3
Link0126
Human being with feelings
 
Link0126's Avatar
 
Join Date: Jul 2010
Posts: 1,264
Default

Quote:
Originally Posted by Stella645 View Post
https://forums.cockos.com/showthread.php?p=1427192

Not that promising....seems to be an ongoing problem.
Hmmm... Very odd. I just went and checked the date on the video I posted. It was just made on March 2 of this year. It seems to be working in the video... There must be a way... Very confusing.
Link0126 is offline   Reply With Quote
Old 03-16-2018, 02:23 PM   #4
Stella645
Human being with feelings
 
Join Date: Sep 2008
Location: UK
Posts: 1,872
Default

Did you try the modifier Ctrl or Alt in the shortcut that seemed to help someone get it working in that thread.

I might give it a try here and can at least let you know if it's same for me.
Stella645 is offline   Reply With Quote
Old 03-16-2018, 02:28 PM   #5
solger
Human being with feelings
 
solger's Avatar
 
Join Date: Mar 2013
Posts: 4,725
Default

Did you already try to enable Options > Ignore FX Chain keyboard shortcuts (send to main window) in the FX chain window?
At least this seems to get it working here when using the 'Ctrl + 1' shortcut like in the video ...

Last edited by solger; 03-16-2018 at 02:37 PM.
solger is offline   Reply With Quote
Old 03-16-2018, 02:36 PM   #6
Stella645
Human being with feelings
 
Join Date: Sep 2008
Location: UK
Posts: 1,872
Default

It appears that with the option Solger mentions it actually works with any shortcut.
Without that option it still works if you use Ctrl or Alt modifier in the shortcut (as Kenny did in the video)
Stella645 is offline   Reply With Quote
Old 03-16-2018, 02:48 PM   #7
Link0126
Human being with feelings
 
Link0126's Avatar
 
Join Date: Jul 2010
Posts: 1,264
Default

Quote:
Originally Posted by Stella645 View Post
It appears that with the option Solger mentions it actually works with any shortcut.
Without that option it still works if you use Ctrl or Alt modifier in the shortcut (as Kenny did in the video)
The weird thing was for it didn't work even with Ctrl or Alt before. Of course now it works with anything so it's all good.
Link0126 is offline   Reply With Quote
Old 03-16-2018, 02:44 PM   #8
Link0126
Human being with feelings
 
Link0126's Avatar
 
Join Date: Jul 2010
Posts: 1,264
Default

Quote:
Originally Posted by solger View Post
Did you already try to enable Options > Ignore FX Chain keyboard shortcuts (send to main window) in the FX chain window?
At least this seems to get it working here when using the 'Ctrl + 1' shortcut like in the video ...
ahhhh...yes. That's the trick.

I searched extensively through the preferences and even the FX chain window but the tricky part is on mac of course, the menu tool bar is separate from the window so I was looking all in the FX chain window but missed that the upper tool bar changes.

Thanks a lot!
Link0126 is offline   Reply With Quote
Old 03-16-2018, 03:22 PM   #9
vanhaze
Human being with feelings
 
vanhaze's Avatar
 
Join Date: Jul 2012
Location: Netherlands
Posts: 5,009
Default

Quote:
Originally Posted by solger View Post
Did you already try to enable Options > Ignore FX Chain keyboard shortcuts (send to main window) in the FX chain window?
I am problaby blind: i can't find this option ..
Can someone take my hand and take me to it, in a detailed explained way plz ?

Many thanks in advance !
__________________
Reaper - OSX (always latest version)
OSX Catalina (always latest version)
My Reaper Tips&Tricks: https://www.youtube.com/user/vanhaze2000/playlists
vanhaze is offline   Reply With Quote
Old 03-16-2018, 03:31 PM   #10
Edgemeal
Human being with feelings
 
Edgemeal's Avatar
 
Join Date: Apr 2016
Location: ASU`ogacihC
Posts: 1,912
Default

This?..
Edgemeal is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:57 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.