Old 11-23-2019, 12:23 PM   #41
ramses
Human being with feelings
 
Join Date: Jul 2009
Posts: 643
Default

"Unfortunately I don't think the "Recolor project" feature will be useful, since it just randomly changes track colors. Many users (like me) use specific colors for specific instruments in all our projects. "

I am one of these users, I'm sure there are thousands out there. I agree.
ramses is offline   Reply With Quote
Old 11-23-2019, 02:12 PM   #42
TobyAM
Human being with feelings
 
Join Date: Feb 2017
Location: Hollywood, CA
Posts: 57
Default

Quote:
Originally Posted by ramses View Post
"Unfortunately I don't think the "Recolor project" feature will be useful, since it just randomly changes track colors. Many users (like me) use specific colors for specific instruments in all our projects. "

I am one of these users, I'm sure there are thousands out there. I agree.
I am the opposite user who doesn't care about specific colors, but wants some gradient across tracks for another layer of intelligibility. I use lots of folders and use a similar action to "rainbow-ize" my tracks, and then set all children to the parent folder colors. Makes things really tidy looking. I will definitely use this feature.
TobyAM is offline   Reply With Quote
Old 11-23-2019, 02:24 PM   #43
carbon
Human being with feelings
 
carbon's Avatar
 
Join Date: Feb 2008
Location: Eesti
Posts: 2,413
Default MIDI editor brighter notes

This has maybe been already discussed, but have you considered using just the borders to indicate selected note state?
This can give notes with clearer colours in their unselected state. Otherwise they might seem muted.

If already been through that, then ignore.

__________________
KasparTORN

Last edited by carbon; 11-23-2019 at 02:30 PM.
carbon is offline   Reply With Quote
Old 11-23-2019, 02:55 PM   #44
White Tie
Pixel Pusher
 
White Tie's Avatar
 
Join Date: Mar 2007
Location: Blighty
Posts: 2,815
Default

Quote:
Originally Posted by juliansader View Post
I realize I am far too late to discuss this, but still... I don't think the "Recolor project" feature will be useful, since it just randomly changes track colors. Many users (like me) use specific colors for specific instruments in all our projects.

"Tracks which share a colour will be given the same new color" (NB: colour vs color) does not help much, since different instruments in the same family are often colored slightly differently, but may end up with widely divergent colors after re-coloring.
Thanks for the typo spot! And by, typo, I of course mean "pfft, bloody foreigners"

There are already a load of colour palette scripts out there, perhaps there's one that does what you want already? As a beginner programmer I can testify to them being an easy way into scripting so I'm sure someone could do one for you. The recolor function is there as a way of trying out the palettes without having to go into click frenzy mode, but there are also some users who seem to love it. I find it quite fun.

Please do note that it does set an undo, so there's no downside!

Quote:
Originally Posted by spk77 View Post
Calling this function (on mouse button release) would set the focus back from the script window to last focused element - TCP, arrange view or last selected envelope:
Thanks loads! This is all a bit beyond me, but I'll run it past the boss man

Quote:
Originally Posted by fladd View Post
For me the font in the theme script is so tiny that it cannot be read. I don't know why that is, or how that happened, but is there a way to make the font readable again?
That's very, horribly broken in many ways. Eeek. Specs please?

Quote:
Originally Posted by Janne83 View Post
attempt to get length of a nil value
Thanks! Could you grab the error line number next time it happens please? And can you just double check you are definitely on the latest version of the scrip please?

Quote:
Originally Posted by kavula View Post
Just to report, playback rate knob looks fine now.
Script is also loading as it should.
Thanks.
Splendid, thanks for letting me know.

Quote:
Originally Posted by Ericson View Post
Yes the master track in the tcp set at 200% and the script window at same size.
My two monitors are set to 150% DPI in Windows.
At 150% you get the 100% draw of the script window (it doesn't have a 150% size like the theme does). It actually changes up at >150. I'll change it so that 149 is the swapover and we'll see if anyone complains... all things being equal, I think "this thing is unnecessarily filling my screen" is a more bearable situation than "this is too small to use."

Quote:
Originally Posted by Xasman View Post
Pan knob missing from default track layout on Linux native 6.0 (in both rc1 & rc2):
OK, what you are seeing here is the big new thing. Its a bold move, but I've made it very, very easy for the user to change with a layout swap or using the adjuster script. Allow me to make the case:

Reaper can be taxing for visual searching (and this is also intimidating to new users) because it has an enormous number of controls if you have the mixer open, because you're seeing everything twice. The workflow approach would be to say that if you are using the mixer AND the track panels, you may often be doing the same thing on them, but you're doing so in different workflow modes. Other DAWs enforce those modes by never putting some controls on their track panel; this is the Reaper equivalent. If you're using def6, layout A, and you haven't used the theme adjuster script, and the mixer is visible ...so, the hour zero context... it only shows the pan and route controls on the mixer, not both. Because if you were to make a generalization (definitely not one size fits all...) that's where they are most useful.

I'm tidying elements from the interface based on workflow observations. The kind of thing almost all software does and, some argue, Reaper should do more of. But I've Reaper'd it by making it completely reversible. Hopefully this will all be a lot more 'ah, nice!' rather than 'wuh, WTF?' once Kenny has done a video on it

Quote:
Originally Posted by bFooz View Post
RC2 score colors: better. They are now generally on the dark side a touch. Maybe something like this would do: (just some lightness adjusted)
Okay, will do, thanks.

Quote:
Originally Posted by foxAsteria View Post
Button buildup on short master:
Hmm, its not supposed to be able to do that. Can you reliably replicate it, and if so let me know how? Thanks.
__________________
The House of White Tie
White Tie is offline   Reply With Quote
Old 11-23-2019, 02:59 PM   #45
White Tie
Pixel Pusher
 
White Tie's Avatar
 
Join Date: Mar 2007
Location: Blighty
Posts: 2,815
Default

Quote:
Originally Posted by carbon View Post
This has maybe been already discussed, but have you considered using just the borders to indicate selected note state?
This can give notes with clearer colours in their unselected state. Otherwise they might seem muted.
You're absolutely right, but the majority of feedback I get it that users are more interested in a super clear selected state than in colour fidelity. I'm not comfortable with the degree to which I'm losing colour definition on selected notes (its sometimes too bright to tell) but I'm going where I'm led on this one.
__________________
The House of White Tie
White Tie is offline   Reply With Quote
Old 11-23-2019, 03:03 PM   #46
Edgemeal
Human being with feelings
 
Edgemeal's Avatar
 
Join Date: Apr 2016
Location: ASU`ogacihC
Posts: 1,637
Default

Quote:
Originally Posted by foxAsteria View Post
Button buildup on short master:
See same thing here on Windows 10 , RC2, no DPI changes, floating mixer window,
Notice when at smallest height the Master label/text near the bottom is changing also!

Last edited by Edgemeal; 11-23-2019 at 03:26 PM.
Edgemeal is offline   Reply With Quote
Old 11-23-2019, 03:07 PM   #47
Janne83
Human being with feelings
 
Join Date: May 2010
Location: Earth
Posts: 1,833
Default

Quote:
Originally Posted by White Tie View Post

Thanks! Could you grab the error line number next time it happens please? And can you just double check you are definitely on the latest version of the scrip please?
Im using the latest script that came with rc2 (thet gost installed in Cockos folder). Theres no number after the error.heres a screen :



recoloring executes normally but after that this wondow appears.

Regards J
__________________
Win10, R 64bit
Janne83 is offline   Reply With Quote
Old 11-23-2019, 03:42 PM   #48
White Tie
Pixel Pusher
 
White Tie's Avatar
 
Join Date: Mar 2007
Location: Blighty
Posts: 2,815
Default

Quote:
Originally Posted by Edgemeal View Post
See same thing here on Windows 10 , RC2, no DPI changes, floating mixer window,
Notice when at smallest height the Master label/text near the bottom is changing also!
Floating mixer window! That was the crucial detail I was missing in order to replicate, thanks very much. I'm on it.

Quote:
Originally Posted by Janne83 View Post
Im using the latest script that came with rc2 (thet gost installed in Cockos folder). Theres no number after the error.heres a screen :
Hmm, baffled. I'll look into it, thanks for letting me know.

Quote:
Originally Posted by Edgemeal View Post
I had changed it and it lost my setting, for like 3rd time now, WTF?
Can I ask that you do some detective work with your reaper-themeconfig.ini file please? Do you see it changing numbers when you change settings? Do those numbers get erased/changed when you restart Reaper?
__________________
The House of White Tie
White Tie is offline   Reply With Quote
Old 11-23-2019, 03:44 PM   #49
Edgemeal
Human being with feelings
 
Edgemeal's Avatar
 
Join Date: Apr 2016
Location: ASU`ogacihC
Posts: 1,637
Default

Quote:
Originally Posted by White Tie View Post

Can I ask that you do some detective work with your reaper-themeconfig.ini file please? Do you see it changing numbers when you change settings? Do those numbers get erased/changed when you restart Reaper?
Post deleted for now, I was trying other versions so maybe something got crossed up, if happens again I'll try and figure what causing it and report back. Thanks!
Edgemeal is offline   Reply With Quote
Old 11-23-2019, 04:41 PM   #50
foxAsteria
Human being with feelings
 
foxAsteria's Avatar
 
Join Date: Dec 2009
Location: Oblivion
Posts: 7,426
Default

Quote:
Originally Posted by White Tie View Post
Hmm, its not supposed to be able to do that. Can you reliably replicate it, and if so let me know how? Thanks.
I tried a portable install and the only time it didn't do it was the very first time I tried it after install. If it's docked or floating or in a separate window it's doing that. Also, when docked at the bottom, resizing the window puts the lower elements completely offscreen. I'm testing on a Win10 laptop with 1280x800 max res if that makes a difference.
__________________
Myyy Wyyyrd Music
foxAsteria is offline   Reply With Quote
Old 11-24-2019, 12:38 AM   #51
creal
Human being with feelings
 
Join Date: Jan 2010
Posts: 2,195
Default Blurry icons and MIDI editor not still as wide as possible

Hello,

I just tested the brand new 6.0rc3. I have two problems with the theme:

1) All the icons are blurry :



2) The MIDI editor does not still display in full screen (see the bottom space):



Note that I'm running Reaper x64 on Windows 10 Prox64 with a 125% display resolution.
Attached Images
File Type: png blurry icons.PNG (38.1 KB, 51 views)
creal is offline   Reply With Quote
Old 11-24-2019, 12:56 AM   #52
SmajjL
Human being with feelings
 
SmajjL's Avatar
 
Join Date: Nov 2013
Location: Sweden
Posts: 2,215
Default

Make sure to try aware+ignore that is in preferences>general>advanced UI/system tweaks.
Looks like pressing (reset to defaults) does nothing in there? hmm

And in Appearance you have option not to scale above/below and sometimes depending on the font choice, fast text rendering (rebell mood) might be a preferred preference? you're the boss.
__________________
:)

Last edited by SmajjL; 11-24-2019 at 01:02 AM.
SmajjL is offline   Reply With Quote
Old 11-24-2019, 01:51 AM   #53
creal
Human being with feelings
 
Join Date: Jan 2010
Posts: 2,195
Default

Quote:
Originally Posted by SmajjL View Post
Make sure to try aware+ignore that is in preferences>general>advanced UI/system tweaks.
Looks like pressing (reset to defaults) does nothing in there? hmm
Thanks, this fixed the first problem. In fact, it switched to a 100% screen res. But how can I do if I want to preserve the 125% zoom (or try 110% for example) without getting icons blurry, please?

And how to deal with the second problem? It's something here since a long time. I thought it might be the time to fix it.
creal is offline   Reply With Quote
Old 11-24-2019, 02:27 AM   #54
SmajjL
Human being with feelings
 
SmajjL's Avatar
 
Join Date: Nov 2013
Location: Sweden
Posts: 2,215
Default

Hmm, I don't usually go full with the editor, but it looks ok here on rc3, I can't get what your screenshot shows atm, hmm.
Tried setting REAPER also at fullscreen, nope, still looks ok.
Running Windows10 at 125%, this minute.

This is why we have pre-made 100%/150%/200% options for this theme at least, in view/screenset/layouts.
Preferences Advanced UI have scale UI option, never tried it though and if you ask me, all sorts of scaleing is asking/begging for blur specially if going from 100% to 110-125%.

You can always have a look in the stash maby someone have made a theme a tad bigger.
Maby something like https://stash.reaper.fm/theme/906/RADOVOX.zip, hmm.


And your midi editor screenshot is not Default6, same problem with D6?
__________________
:)

Last edited by SmajjL; 11-24-2019 at 02:38 AM.
SmajjL is offline   Reply With Quote
Old 11-24-2019, 02:42 AM   #55
creal
Human being with feelings
 
Join Date: Jan 2010
Posts: 2,195
Default

Quote:
Originally Posted by SmajjL View Post
Hmm, I don't usually go full with the editor, but it looks ok here on rc3, I can't get what your screenshot shows atm, hmm.
Tried setting REAPER also at fullscreen, nope, still looks ok.
Running Windows10 at 125%, this minute.
Thanks for your message. I wanted to show that the window of the MIDI editor does not fullfill the bottom of the screen (see the yellow arrow in my screenshot). It seems like it stopped exactly when the Windows task bar should begin. However, the arrange view is fully displayed.

Just try to expand the MIDI editor window to the bottom. You will face to an "invisible wall" that prevents you to fullfill the screen. If not, can you send me a screenshot that reflects the good behaviour you seem to have on your computer, please?

PS : I always run Reaper in full screen so the problem comes from elsewhere.
creal is offline   Reply With Quote
Old 11-24-2019, 02:48 AM   #56
Xasman
Human being with feelings
 
Xasman's Avatar
 
Join Date: Jun 2009
Posts: 290
Default

Quote:
Originally Posted by White Tie View Post
OK, what you are seeing here is the big new thing. Its a bold move, but I've made it very, very easy for the user to change with a layout swap or using the adjuster script. Allow me to make the case:

Reaper can be taxing for visual searching (and this is also intimidating to new users) because it has an enormous number of controls if you have the mixer open, because you're seeing everything twice. The workflow approach would be to say that if you are using the mixer AND the track panels, you may often be doing the same thing on them, but you're doing so in different workflow modes. Other DAWs enforce those modes by never putting some controls on their track panel; this is the Reaper equivalent. If you're using def6, layout A, and you haven't used the theme adjuster script, and the mixer is visible ...so, the hour zero context... it only shows the pan and route controls on the mixer, not both. Because if you were to make a generalization (definitely not one size fits all...) that's where they are most useful.

I'm tidying elements from the interface based on workflow observations. The kind of thing almost all software does and, some argue, Reaper should do more of. But I've Reaper'd it by making it completely reversible. Hopefully this will all be a lot more 'ah, nice!' rather than 'wuh, WTF?' once Kenny has done a video on it
Ah, nice (already)! Thanks for the explanation - got it...very nifty indeed!
Xasman is offline   Reply With Quote
Old 11-24-2019, 02:53 AM   #57
SmajjL
Human being with feelings
 
SmajjL's Avatar
 
Join Date: Nov 2013
Location: Sweden
Posts: 2,215
Default

Can you switch to Default6 theme REAPER6 rc3 please, and see if you still have this problem so we are using the same stuff?
You are using a custom theme on your screenshot that I don't have and to make sure it is not the theme you are using that is the cause of this, and, this thread is Reaper V6 Default Theme - RC1, WT will destroy me if I go bug talk using another theme.
__________________
:)
SmajjL is offline   Reply With Quote
Old 11-24-2019, 02:56 AM   #58
creal
Human being with feelings
 
Join Date: Jan 2010
Posts: 2,195
Default

Quote:
Originally Posted by SmajjL View Post
This is why we have pre-made 100%/150%/200% options for this theme at least, in view/screenset/layouts.
Preferences Advanced UI have scale UI option, never tried it though and if you ask me, all sorts of scaleing is asking/begging for blur specially if going from 100% to 110-125%.
Thanks, all of these options are helpful
creal is offline   Reply With Quote
Old 11-24-2019, 03:06 AM   #59
creal
Human being with feelings
 
Join Date: Jan 2010
Posts: 2,195
Default

Quote:
Originally Posted by SmajjL View Post
Can you switch to Default6 theme REAPER6 rc3 please, and see if you still have this problem so we are using the same stuff?
You are using a custom theme on your screenshot that I don't have and to make sure it is not the theme you are using that is the cause of this, and, this thread is Reaper V6 Default Theme - RC1, WT will destroy me if I go bug talk using another theme.
Sorry, I not told you that in the meantime I switched to the default theme and that the behaviour is the same.

Another problem: the icons of the main toolbar don't go to the line when resizing the TCP. Normally, the icons should stack (one above one) in order to all being visible, and not be cropped if I remember correctly.

Also, I don't understand why the master track of the TCP has no border (ie. no separation is made between the master track and the main toolbar) but this is not so important.
creal is offline   Reply With Quote
Old 11-24-2019, 03:12 AM   #60
bFooz
Human being with feelings
 
bFooz's Avatar
 
Join Date: Jul 2010
Location: Slovakia
Posts: 1,214
Default

I have noticed that after RC1 some of my toolbar icons went from white to gray. For example these latter two, while the first two icons are ok.

__________________
Donations | Mixing & Mastering Services
bFooz is offline   Reply With Quote
Old 11-24-2019, 03:25 AM   #61
mlprod
Human being with feelings
 
Join Date: Jul 2015
Location: Stockholm, Sweden
Posts: 802
Default

Bugs:

- Envelope indent doesnt not work when dragging a track into a folder. You have to re-show the envelope to get the indent.

- Again, the scaling in the transport is messing up the selection time boxes. The more elements added the more chance it gets cramped. Though, there are space left so I guess it should work.
Attached Images
File Type: png Capture.PNG (35.4 KB, 80 views)
File Type: png Capture1.PNG (36.4 KB, 63 views)
__________________
Magnus Lindberg Productions - VRTKL Audio - Redmount Studios
magnuslindberg.com
mlprod is offline   Reply With Quote
Old 11-24-2019, 03:33 AM   #62
SmajjL
Human being with feelings
 
SmajjL's Avatar
 
Join Date: Nov 2013
Location: Sweden
Posts: 2,215
Default

Quote:
Originally Posted by creal View Post
Another problem: the icons of the main toolbar don't go to the line when resizing the TCP. Normally, the icons should stack (one above one) in order to all being visible, and not be cropped if I remember correctly.

Also, I don't understand why the master track of the TCP has no border (ie. no separation is made between the master track and the main toolbar) but this is not so important.
Yeah-no, the toolbar don't have the power to push down the TCP automagically, if you just minimize drag to the left no, but if you help it first and drag down to make room/space and then to the left, the toolbars will sort itself up to "the grid" so yeah, smells like intended behaviour, the user should adapt, teamplay kinda thing.

The TCP master does look kinda sad & forgotten in un-selected state because it is same color as the BG yeah, you could always go to the theme tweaker and change the main window/transport BG a tad up or down.
The image of that thing is tcp_mainbg.png if you wanna GIMP it or something.
--
Even added midi notes and your settings, still can't do it with an almost default REAPER6..*whine*..
Can you, with a new portable Default6? popular question but cool we have a portable for this stuff, so easy quick to try.
__________________
:)

Last edited by SmajjL; 11-24-2019 at 04:23 AM.
SmajjL is offline   Reply With Quote
Old 11-24-2019, 04:34 AM   #63
White Tie
Pixel Pusher
 
White Tie's Avatar
 
Join Date: Mar 2007
Location: Blighty
Posts: 2,815
Default

Quote:
Originally Posted by creal View Post
I just tested the brand new 6.0rc3.

2) The MIDI editor does not still display in full screen (see the bottom space):
This thread is for testing the V6 default theme; that's a different theme altogether Please note that you will need to be patient with other theme makers to update their themes for Reaper's new HiDPI functionality that is preparing for launch as we speak.

I'm not sure what's going on with your midi editor, but its not a theme thing so its beyond my capability to help you with, sorry. Maybe a windows taskbar thing?

Quote:
Originally Posted by bFooz View Post
I have noticed that after RC1 some of my toolbar icons went from white to gray. For example these latter two, while the first two icons are ok.
That is, I assume, because you had overwritten the default fallback icons instead of the replacement icons being included in a theme. Theme makers tend to instruct users to do this so that their icons appear in the icon selector - which is a good reason, but is due to the icon selector not looking inside themes, which it really should.

What this means is when I updated the default icons, it overwrote the icons you had overwritten. This is working how its supposed to, themes aren't supposed to overwrite Reaper's fallback content, but its just never happened before, so I can see how it could come as a surprise. Sorry.

Quote:
Originally Posted by mlprod View Post
Bugs:

- Envelope indent doesnt not work when dragging a track into a folder. You have to re-show the envelope to get the indent.

- Again, the scaling in the transport is messing up the selection time boxes. The more elements added the more chance it gets cramped. Though, there are space left so I guess it should work.
That envelope thing sounds like a Reaper redraw error. Could I ask that you make a licecap of it and post it in the main thread please?

Regarding the transport selection text - Ah, at last we have it! OSX, right? Its translating to the wrong text size I'll get the fix in, thanks.
__________________
The House of White Tie
White Tie is offline   Reply With Quote
Old 11-24-2019, 04:38 AM   #64
fladd
Human being with feelings
 
fladd's Avatar
 
Join Date: May 2006
Posts: 969
Default

Quote:
Originally Posted by fladd View Post
For me the font in the theme script is so tiny that it cannot be read. I don't know why that is, or how that happened, but is there a way to make the font readable again?

Anyone?
__________________
www.fladd.de/sound
fladd is offline   Reply With Quote
Old 11-24-2019, 04:53 AM   #65
SmajjL
Human being with feelings
 
SmajjL's Avatar
 
Join Date: Nov 2013
Location: Sweden
Posts: 2,215
Default

fladd: Nope, all looks good here on rc3, yours is way off, agreed.
You can try removing your toolbar and load it again, make a new one and point it to scripts/cockos/please work.lua

--
Windows10 @ 125%
__________________
:)

Last edited by SmajjL; 11-24-2019 at 05:06 AM.
SmajjL is offline   Reply With Quote
Old 11-24-2019, 05:43 AM   #66
Dafarkias
Human being with feelings
 
Dafarkias's Avatar
 
Join Date: Feb 2019
Location: England
Posts: 461
Default

I've invested a lot of time in tweaking my REAPER 5 theme to perform how I like, so I'm probably not going to be switching to the default 6 theme for a little while... btw I'm using WT's Imperial theme and it is just... spot on.

That being said, I just download the v6rc3 and was messing around with the theme script and the TCP and MCP.

Holy cow!
Dafarkias is offline   Reply With Quote
Old 11-24-2019, 08:10 AM   #67
mccrabney
Human being with feelings
 
mccrabney's Avatar
 
Join Date: Aug 2015
Location: Dundle, Louisiana
Posts: 2,206
Default

the theme adjuster script opens in a window that's larger than my screen, vertically.
1366x768
__________________
° using REAPER as host/arranger/sequencer to write instrumental beat music.
° striving for a loop-based, controller-centric midi recording/editing workflow.
° colored tracks/items: optionally respect "selected track/item" theme color
mccrabney is offline   Reply With Quote
Old 11-24-2019, 08:14 AM   #68
mccrabney
Human being with feelings
 
mccrabney's Avatar
 
Join Date: Aug 2015
Location: Dundle, Louisiana
Posts: 2,206
Default

also, mousewheel movements tick the various buttons and "hide" entries as if they were mouseclicks...
__________________
° using REAPER as host/arranger/sequencer to write instrumental beat music.
° striving for a loop-based, controller-centric midi recording/editing workflow.
° colored tracks/items: optionally respect "selected track/item" theme color
mccrabney is offline   Reply With Quote
Old 11-24-2019, 10:08 AM   #69
creal
Human being with feelings
 
Join Date: Jan 2010
Posts: 2,195
Default

Quote:
Originally Posted by White Tie View Post
This thread is for testing the V6 default theme; that's a different theme altogether Please note that you will need to be patient with other theme makers to update their themes for Reaper's new HiDPI functionality that is preparing for launch as we speak.

I'm not sure what's going on with your midi editor, but its not a theme thing so its beyond my capability to help you with, sorry. Maybe a windows taskbar thing?
Hello,

All my remarks worth for the v6 theme even if my screenshots are taken from a 3rd-party theme.

You're right. When the Windows taskbar is hidden, the MIDI editor tooks all the vertical space screen, as intended. In the opposite, the MIDI editor is "blocked" by a transparent Windows taskbar, as if Reaper could not be "above" it. This strange behaviour happens only with Reaper. All my other music apps (for example: Ableton Live, Akai MPC, Traktor, Sibelius) or just other apps (for example: Vegas Pro, Guitar Pro) are their fullscreen fine with floating windows. I guess it's the same for all Windows users.

But since it always happened, it's not related to the V6 theme especially so I can move the problem to another thread.
creal is offline   Reply With Quote
Old 11-24-2019, 10:22 AM   #70
creal
Human being with feelings
 
Join Date: Jan 2010
Posts: 2,195
Default

Quote:
Originally Posted by SmajjL View Post
Yeah-no, the toolbar don't have the power to push down the TCP automagically, if you just minimize drag to the left no, but if you help it first and drag down to make room/space and then to the left, the toolbars will sort itself up to "the grid" so yeah, smells like intended behaviour, the user should adapt, teamplay kinda thing.
Thanks for the clarification

Quote:
Originally Posted by SmajjL View Post
The TCP master does look kinda sad & forgotten in un-selected state because it is same color as the BG yeah, you could always go to the theme tweaker and change the main window/transport BG a tad up or down.
The image of that thing is tcp_mainbg.png if you wanna GIMP it or something.
Okay, that's fine.

Quote:
Originally Posted by SmajjL View Post
Even added midi notes and your settings, still can't do it with an almost default REAPER6..*whine*..
Can you, with a new portable Default6? popular question but cool we have a portable for this stuff, so easy quick to try.
Yes, I tried (and continue to stick with for this thread) the v6rc3 portable version of Reaper and the Windows taskbar thing remains. Concerning the icons, they are also blurry when scale is > 1.0 (but it's only noticeable from 1.2). But I guess it's normal since the icons are designed by 30*30 pixels.
creal is offline   Reply With Quote
Old 11-24-2019, 10:37 AM   #71
foxAsteria
Human being with feelings
 
foxAsteria's Avatar
 
Join Date: Dec 2009
Location: Oblivion
Posts: 7,426
Default

Quote:
Originally Posted by White Tie View Post
Hmm, its not supposed to be able to do that. Can you reliably replicate it, and if so let me know how? Thanks.
It seems to be related to the "show fx parameters/inserts" mixer options. If I disable both, it goes away, but either one enabled makes the buttons overlap.
__________________
Myyy Wyyyrd Music
foxAsteria is offline   Reply With Quote
Old 11-24-2019, 11:19 AM   #72
kavula
Human being with feelings
 
Join Date: Mar 2017
Posts: 12
Default

Edit:installed rc3, deleted themeconfig. Works fine.


Script doesn't seem to remember settings. When I reopen Reaper it all goes back to as it was originally.
However, in portable install it's all good.

themeconfig - Numbers stay the same before and after changes are made, and Reaper reopened:

[Default_6.0_unpacked]
param19=146
param22=100
param79=2
param78=2
param1=1
param60=0
param61=0
param63=0
param2=1
param12=0
param4=3
param55=6
param69=4
param54=1



portable themeconfig:
[Default_6.0]
param19=25
param22=100
param21=4
param23=1
param77=1
param2=1
param1=1

Last edited by kavula; 11-24-2019 at 12:09 PM. Reason: fixed
kavula is offline   Reply With Quote
Old 11-24-2019, 11:48 AM   #73
Jason Brian Merrill
Human being with feelings
 
Jason Brian Merrill's Avatar
 
Join Date: Jun 2006
Location: Northeastern PA, USA
Posts: 20,966
Default

is there a way to see what version of script we are on? I am not sure if I have the most updated version. Maybe a separate download?
__________________
Beliefs do not require respect. People do.
Jason Brian Merrill is offline   Reply With Quote
Old 11-24-2019, 12:17 PM   #74
Jason Brian Merrill
Human being with feelings
 
Jason Brian Merrill's Avatar
 
Join Date: Jun 2006
Location: Northeastern PA, USA
Posts: 20,966
Default

ok actually I think I got it
__________________
Beliefs do not require respect. People do.
Jason Brian Merrill is offline   Reply With Quote
Old 11-24-2019, 01:25 PM   #75
D Rocks
Human being with feelings
 
Join Date: Dec 2017
Location: Quebec, Canada
Posts: 547
Default

1. Is it wanted that when you click on a mixer track, it expands its size and show the db meter only for the selected track?

2. Is it normal that clicking on a fader area of a mixer track can instantly change the fader position on selection ?
__________________
Alex | www.drocksrecords.com | Thanks for REAPER
D Rocks is offline   Reply With Quote
Old 11-24-2019, 06:39 PM   #76
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 9,377
Default

Quote:
Originally Posted by D Rocks View Post
1. Is it wanted that when you click on a mixer track, it expands its size and show the db meter only for the selected track?

2. Is it normal that clicking on a fader area of a mixer track can instantly change the fader position on selection ?
I'm wondering this too.

edit:
Still happens for me in rc4.
https://i.imgur.com/ousyGkH.gif

Last edited by nofish; 11-25-2019 at 07:47 AM.
nofish is offline   Reply With Quote
Old 11-25-2019, 08:10 AM   #77
hwhalen
Human being with feelings
 
hwhalen's Avatar
 
Join Date: Jan 2010
Location: Canada
Posts: 943
Default Advanced Scaling Settings on Win 10

I don't seem to be able to scale(down) the Theme script window
when the scale setting is at 200%. Is this possible? This
might prove to be a problem for some users.

The 'Compact docker when small and single tab' option doesn't
close the dock window selection panel completely when at 200%
scaling. It does at 100%.

As for the 50% and 75% DPI scale sizes, they appear to be the same.
Are these meant to be relative to the scale size?

There does not appear to be a %50 or 75% size for the MCP master mixer panel.

Will these aspects of the theme remain as is or can they be expected to
change/improve over time?
__________________
My Music
Noise From My Head
On The Links
hwhalen is offline   Reply With Quote
Old 11-25-2019, 09:00 AM   #78
White Tie
Pixel Pusher
 
White Tie's Avatar
 
Join Date: Mar 2007
Location: Blighty
Posts: 2,815
Default

Quote:
Originally Posted by Janne83 View Post
recoloring executes normally but after that this wondow appears.
OK, I've now had this happen to me, once, but I haven't been able to replicate it. Has RC4 fixed it for you?

Quote:
Originally Posted by fladd View Post
Anyone?
Apparently not. I don't know what to suggest, is there anything unusual about your system? Are you using and screen scaling/rescaling settings or functions?

Quote:
Originally Posted by mccrabney View Post
the theme adjuster script opens in a window that's larger than my screen, vertically.
1366x768
I do treat 1366x768 as my bare minimum these days, though I do look forward to it not being a thing sooner rather than later I've made it so that, though you don't get all of the window, all of the functional bits do fit in, so its still 100% useable, I hope that's a fair compromise. Turn off the help button (top left) to shrink the borders if you like.

Quote:
Originally Posted by mccrabney View Post
also, mousewheel movements tick the various buttons and "hide" entries as if they were mouseclicks...
Oh lordy, that's embarrassing I'm definitely not going to be able to fix that quickly so ...could you just ...er.... not do that please?

Quote:
Originally Posted by creal View Post
Concerning the icons, they are also blurry when scale is > 1.0 (but it's only noticeable from 1.2). But I guess it's normal since the icons are designed by 30*30 pixels.
Yes. You are using a theme that doesn't support the new HiDPI functionality yet. Which is fair, its not even on general release yet. Patience, we're nearly there!

Quote:
Originally Posted by foxAsteria View Post
It seems to be related to the "show fx parameters/inserts" mixer options. If I disable both, it goes away, but either one enabled makes the buttons overlap.
Thanks, I have the fix for this now.

Quote:
Originally Posted by D Rocks View Post
1. Is it wanted that when you click on a mixer track, it expands its size and show the db meter only for the selected track?
Only if you have set it to do that in the script, or if you are using layout C.

Quote:
Originally Posted by D Rocks View Post
Is it normal that clicking on a fader area of a mixer track can instantly change the fader position on selection ?
Yes, that's how Reaper works.

Quote:
Originally Posted by hwhalen View Post
I don't seem to be able to scale(down) the Theme script window when the scale setting is at 200%. Is this possible?
No, it picks its size (100% or 200%) based on your screen resolution.

Quote:
Originally Posted by hwhalen View Post
The 'Compact docker when small and single tab' option doesn't
close the dock window selection panel completely when at 200%
scaling. It does at 100%.
I'm not entirely sure what you mean, but Reaper's docking/sizing stuff does seem to need some attention for HiDPI.

Quote:
Originally Posted by hwhalen View Post
As for the 50% and 75% DPI scale sizes, they appear to be the same. Are these meant to be relative to the scale size?
Exactly, the only sizes that actually exist are 100/150/200. 50/75 are there so that if you are using a HiDPI screen, you can still access the smaller sizes. If you're on a 100% screen, things can only get bigger. Does that make sense?

Quote:
Originally Posted by hwhalen View Post
There does not appear to be a %50 or 75% size for the MCP master mixer panel.
Ooops, that's a particularly silly omission and an easy fix. Thanks!
__________________
The House of White Tie
White Tie is offline   Reply With Quote
Old 11-25-2019, 09:00 AM   #79
bFooz
Human being with feelings
 
bFooz's Avatar
 
Join Date: Jul 2010
Location: Slovakia
Posts: 1,214
Default

If there is any room for a change in the velocity colour map:

I orient myself in velocity by minimum, middle and maximum. All the rest is in between. That brings a 3-color gradient idea, something like this:



in use:


The blue is a dark cyan so to prevent too low saturation area going to the yellow.

The difference between the current colour map is that the current one treats each color by changing its hue and keeping its saturation at max, thus making each color an individual in a sense. The presented gradient treats the in-between colors as being a passing colors between the three main colors and also reduces the hue spread.
__________________
Donations | Mixing & Mastering Services
bFooz is offline   Reply With Quote
Old 11-25-2019, 09:09 AM   #80
Jason Brian Merrill
Human being with feelings
 
Jason Brian Merrill's Avatar
 
Join Date: Jun 2006
Location: Northeastern PA, USA
Posts: 20,966
Default

can the midi notes be made anymore 3d, and highlight when you're over them? Kinda like FLstudio

also, is my master track messed up or is this the new look? Just feels awkward w the slider all the way at the bottom
__________________
Beliefs do not require respect. People do.
Jason Brian Merrill is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:06 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.