Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 04-18-2018, 04:11 AM   #1
RCJacH
Human being with feelings
 
Join Date: Apr 2016
Location: Beijing, China
Posts: 164
Default Audio glitches when MIDI (and inlane) editor is open...again (SOLVED)

v5.79 Official Release, probably had similar behavior in previous versions as well.
When any MIDI editor is open while playing, the audio glitches and lags as if it's low on cpu resources. As soon MIDI editor is closed, the audio engine plays back all of the lagged parts in a sped up way.

CPU usage around 57% during playback without opening MIDI editor; 93% with MIDI editor opened.

i7-5820k.
RCJacH is offline   Reply With Quote
Old 04-18-2018, 08:50 AM   #2
cfillion
Human being with feelings
 
cfillion's Avatar
 
Join Date: May 2015
Location: Québec, Canada
Posts: 3,007
Default

Enable "Allow on tracks with open MIDI Editors" in Preferences > Audio > Buffering.
cfillion is offline   Reply With Quote
Old 04-18-2018, 02:01 PM   #3
RCJacH
Human being with feelings
 
Join Date: Apr 2016
Location: Beijing, China
Posts: 164
Default

Thank you, works like a charm.
What does it actually do though?
RCJacH is offline   Reply With Quote
Old 04-18-2018, 02:08 PM   #4
cfillion
Human being with feelings
 
cfillion's Avatar
 
Join Date: May 2015
Location: Québec, Canada
Posts: 3,007
Default

Anticipative processing renders effects a bit ahead of time (how much ahead is configurable – by default it's 200ms). So instead of having to compute everything in real-time, the CPU has much more time to process the effects. Audio glitches happen when the CPU can't fill the whole buffer in time.
cfillion is offline   Reply With Quote
Old 01-16-2020, 07:42 PM   #5
maxcomposer
Human being with feelings
 
Join Date: Jan 2020
Location: Canada
Posts: 2
Default

YES. Thanks so much, solve my problem.
maxcomposer is offline   Reply With Quote
Old 01-25-2020, 03:18 PM   #6
Philip Lee
Human being with feelings
 
Philip Lee's Avatar
 
Join Date: Jan 2009
Location: West Sacramento, CA
Posts: 36
Default

I was very happy to read this just now, worked for me too.
Philip Lee is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:31 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.