Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 01-25-2020, 11:38 AM   #1
Thomas Aron Booker
Human being with feelings
 
Join Date: Aug 2016
Posts: 1
Default [6.03] Duplicate midi events when recording midi overdub after deleting a note

When recording midi in overdub mode over an existing midi item, there are duplicate midi events (notes on/off) after deleting a note from the midi item.

I noticed this after hearing increased volume and weird phasing issues when monitoring while recording virtual instruments. (Never experienced this in years of using version 5.)

Steps to reproduce:

1. Create a new project.
2. Add a new track and add ReaControlMIDI fx to view midi events.
3. Set the track input to "All MIDI Inputs -> All Channels" and record mode to "MIDI overdub".
4. Create a new midi item by Ctrl-dragging.
5. Record some midi over the new item and observe the log in ReaControlMIDI. (At this stage, everything works correctly: one note one/off event per key press/release).
6. Open the midi item and delete a note.
7. Repeat step 5. Now, each key press/release generates two note on/off events.

In a saved project, closing and reopening the project resets the behaviour back to normal. So does gluing the midi item, which I guess can be used as a temporary workaround. As soon as a note is deleted though, the behaviour returns.

Anyone else experienced this or able to reproduce it?

Last edited by Thomas Aron Booker; 01-25-2020 at 02:46 PM.
Thomas Aron Booker is offline   Reply With Quote
Old 02-01-2020, 03:03 PM   #2
merlino
Human being with feelings
 
Join Date: May 2016
Location: Belgium
Posts: 106
Default

Yes I have the same issue,

anytime when I record some vst's and then overdub them I get a very very weird buzzing sound/phase issue. Don't know how to call it. I hope they fix this soon because overdubbing is my producing style =(.

I must say the phasing issue is gone when playing back my recordings.. It only is hearable while literally pressing my keys on my controller.
merlino is offline   Reply With Quote
Old 02-08-2020, 02:44 PM   #3
averystemmler
Human being with feelings
 
Join Date: Dec 2019
Posts: 5
Default

I've also experienced this, reproducible via Thomas's method. I'm currently on v6.02. I've noticed that undoing a midi recording also triggers this behavior.

There seems to be a correlation between this and the record monitoring controls. Before this bug is triggered, record monitoring set to "OFF" will result in MIDI input being recorded silently, as expected. After this bug is triggered, record monitoring set to "OFF" will result in audio playback from MIDI input as though it were set to "ON", an record monitoring set to "ON" will double the midi input as Thomas described.

The "Monitor track media when recording" option seems to have no effect on this behavior.
averystemmler is offline   Reply With Quote
Old 02-08-2020, 06:55 PM   #4
tusitala
Human being with feelings
 
tusitala's Avatar
 
Join Date: Apr 2010
Location: London (UK)
Posts: 378
Default

Same here, and I also noticed the creation of a very very long and sustained note.
__________________
MacOS 10.15.3
Mac Pro 6-Core - 64GB ram
UA Apollo Twin
tusitala is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:21 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.