Old 03-29-2020, 06:35 PM   #7761
tdc
Human being with feelings
 
Join Date: Oct 2019
Location: Sydney
Posts: 445
Default EuCon - Send reset

Is there a way to get CSI to send out an "update all" or reset command to the connected surfaces to ensure they are showing the correct values? At present there are cases where the surface faders are at -inf. and reaper's faders are at unity.
tdc is offline   Reply With Quote
Old 03-29-2020, 07:39 PM   #7762
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,425
Default

Quote:
Originally Posted by tdc View Post
Is there a way to get CSI to send out an "update all" or reset command to the connected surfaces to ensure they are showing the correct values? At present there are cases where the surface faders are at -inf. and reaper's faders are at unity.
Are you using the latest CSI and Eucon builds? I literally just commented earlier today how that issue seems to have been resolved.
Funkybot is online now   Reply With Quote
Old 03-29-2020, 10:01 PM   #7763
tdc
Human being with feelings
 
Join Date: Oct 2019
Location: Sydney
Posts: 445
Default

Quote:
Originally Posted by Funkybot View Post
Are you using the latest CSI and Eucon builds? I literally just commented earlier today how that issue seems to have been resolved.
Hi Funkybot, EuCon for sure, CSI was two days ago - where can i see the version number with CSI? The .dylib's and the CSI Edit page don't appear to show it?

I shall grab the Stash now and see how we go.
tdc is offline   Reply With Quote
Old 03-29-2020, 10:07 PM   #7764
mschnell
Human being with feelings
 
mschnell's Avatar
 
Join Date: Jun 2013
Location: Krefeld, Germany
Posts: 9,551
Default

Quote:
Originally Posted by tdc View Post
isn't it worth considering splitting up discussions into sub-threads.
IMHO, CSI well deserves it's own subform,
There we also could discuss Beta testing issues in dedicated individual threads. Those are completely lost in this combined "development"/"how to" thread.
-Michael

Last edited by mschnell; 03-30-2020 at 07:33 AM.
mschnell is offline   Reply With Quote
Old 03-29-2020, 10:34 PM   #7765
tdc
Human being with feelings
 
Join Date: Oct 2019
Location: Sydney
Posts: 445
Default

Quote:
Originally Posted by mschnell View Post
IMHO, CSI well deserves it's own subform,
Thhere we also could discuss Beta testing issues in dedicated individual threads. Those are completely lost in this combined "development"/"how to" thread.
-Michael
Its a testament to Geoff and others!
tdc is offline   Reply With Quote
Old 03-29-2020, 10:36 PM   #7766
kram0
Human being with feelings
 
Join Date: Mar 2015
Posts: 38
Default

Quote:
Originally Posted by kram0 View Post
I'm trying to get the MCP to follow my Trackbank changes.

I thought that adding a command to select track 1 would do the trick but "TrackUniqueSelect" doesn't seem to work outside of my "Channel|" Zone.

Is there a way to explicitly select track 1 of the current track bank?
Is there another (better) way of doing this?
*bump*?

Thanks for your great work, Geoff!

I've started playing with your latest release.
Just want to confirm it still has the same issue for me where I need to OK the "Control Surface Integrator" window before the control surface will interact with Reaper.
Interesting note- Any commands I send from the control surface seem to be queued up so that as soon as I click the OK button all the action rush through in Reaper.
kram0 is offline   Reply With Quote
Old 03-29-2020, 11:19 PM   #7767
tdc
Human being with feelings
 
Join Date: Oct 2019
Location: Sydney
Posts: 445
Default

I am experiencing an issue when a channel is in automation mode READ, the EuCon Surface channel doesn't return to its designated level if you touch the and move the fader. Touching and moving the fader on the Mixer in Reaper behaves as expected.
tdc is offline   Reply With Quote
Old 03-30-2020, 12:11 AM   #7768
WaveTrans
Human being with feelings
 
Join Date: Aug 2019
Posts: 190
Default

Quote:
Originally Posted by audio2u View Post
Wavetrans,
Thanks for the input!
Sadly, I have done exactly as you describe, but whatever surfaces I configure in the right hand panel DO NOT remain. I click OK (which returns me to the Prefs/Control Surfaces window, and then immediately click on the CSI surface I've just created, and Edit, and when the CSI settings window opens, there's nothing in the right hand panel. The settings just will not persist, and I don't understand why.
I'm on Windows 10 Home 64 bit.
Did you try to double click your page entry?

Usually this is required to make the surfaces of a page visible.

As soon as you see the surfaces, you can edit them.

What I mean is:
- Open preferences
- Control surfaces
- Mark/add control surface integrator
- Open CSI window by clicking Edit with marked control surface integrator
- double click page entry (left side)
- the surfaces should appear (right side window)
- mark surface you want to edit
- click edit

Some say this may be an runtime repository issue, but the runtime issue had other
indications on my system, namely CSI was not visible in the pull down list of control surfaces
__________________
CSI files for the Icon Nano Vers. 2.0: https://stash.reaper.fm/v/38686/CSI_IconNano_2_0.zip
CSI FX.zones for the Icon Nano: https://stash.reaper.fm/v/38685/CSI_FX_zones.zip

Last edited by WaveTrans; 03-30-2020 at 12:36 AM.
WaveTrans is offline   Reply With Quote
Old 03-30-2020, 03:18 AM   #7769
audio2u
Human being with feelings
 
audio2u's Avatar
 
Join Date: Dec 2010
Location: Sydney
Posts: 162
Default

Quote:
Originally Posted by WaveTrans View Post
Did you try to double click your page entry?
....
What I mean is:
- Open preferences
- Control surfaces
- Mark/add control surface integrator
- Open CSI window by clicking Edit with marked control surface integrator
- double click page entry (left side)
- the surfaces should appear (right side window)
- mark surface you want to edit
- click edit
Yep, done all that. But I don't see the list of surfaces on the right hand side when I edit the PAGE entry.
If I add a surface manually on the right hand side, the moment I leave the CSI settings window, those settings are lost.
I just tried manually creating a new PAGE, rather than using the default one (called HomePage).
Again, I manually created a SURFACE to go with it.
Exited the window.
Came straight back into the CSI settings window, and my custom PAGE has gone, replaced by HomePage, and any manually created SURFACES on the right hand side are gone as well. The right hand side column is blank, not even showing the SURFACES which exist in my C:\Users\Bruce\AppData\Roaming\REAPER\CSI\Surfaces \Midi folder. There's 14 .mst files there. If I understand it correctly, they SHOULD be showing up on the right hand side column of the CSI Settings window.
__________________
Cheers,
Bruce.
audio2u is offline   Reply With Quote
Old 03-30-2020, 06:37 AM   #7770
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,104
Default

Quote:
Originally Posted by audio2u View Post
Yep, done all that. But I don't see the list of surfaces on the right hand side when I edit the PAGE entry.
If I add a surface manually on the right hand side, the moment I leave the CSI settings window, those settings are lost.
I just tried manually creating a new PAGE, rather than using the default one (called HomePage).
Again, I manually created a SURFACE to go with it.
Exited the window.
Came straight back into the CSI settings window, and my custom PAGE has gone, replaced by HomePage, and any manually created SURFACES on the right hand side are gone as well. The right hand side column is blank, not even showing the SURFACES which exist in my C:\Users\Bruce\AppData\Roaming\REAPER\CSI\Surfaces \Midi folder. There's 14 .mst files there. If I understand it correctly, they SHOULD be showing up on the right hand side column of the CSI Settings window.
No, they shouldn't show up in the right most list -- that is the custom list of surfaces you have defined for this Page.

Other Pages can have completely different definitions, have a look at Conceptual Overview on the wiki -- link is below.

Once you have defined the Surface(s) for the Page you must press OK on all of the dialogs for the changes to be saved.

The list of Surfaces to which you refer (14) appear in the Surface Template dropdown in the Add Midi Surface Dialog.
__________________
Beta software https://stash.reaper.fm/v/38349/CSI%20beta.zip Donate GeoffWaddington.ca
Installation / documentation / source https://github.com/GeoffAWaddington/...ntegrator/wiki

Last edited by Geoff Waddington; 03-30-2020 at 07:17 AM.
Geoff Waddington is offline   Reply With Quote
Old 03-30-2020, 06:38 AM   #7771
WaveTrans
Human being with feelings
 
Join Date: Aug 2019
Posts: 190
Default

Quote:
Originally Posted by audio2u View Post
Yep, done all that. But I don't see the list of surfaces on the right hand side when I edit the PAGE entry.
If I add a surface manually on the right hand side, the moment I leave the CSI settings window, those settings are lost.
I just tried manually creating a new PAGE, rather than using the default one (called HomePage).
Again, I manually created a SURFACE to go with it.
Exited the window.
Came straight back into the CSI settings window, and my custom PAGE has gone, replaced by HomePage, and any manually created SURFACES on the right hand side are gone as well. The right hand side column is blank, not even showing the SURFACES which exist in my C:\Users\Bruce\AppData\Roaming\REAPER\CSI\Surfaces \Midi folder. There's 14 .mst files there. If I understand it correctly, they SHOULD be showing up on the right hand side column of the CSI Settings window.
-Just to be clear about this:
If you double click (the re-appearing) HomePage (or any page created by you) the right hand side window remains empty?

-If you can not erase the HomePage file and none of your changes are saved, there may be some read/write rights issue underneath.

Have you tried to do all this when logged in as administrator?

-Another cause may be the repository issue. You have to have the Visual C++ 2019 runtime repository installed. The link is in the wiki, I think step 5 of the installation.
__________________
CSI files for the Icon Nano Vers. 2.0: https://stash.reaper.fm/v/38686/CSI_IconNano_2_0.zip
CSI FX.zones for the Icon Nano: https://stash.reaper.fm/v/38685/CSI_FX_zones.zip
WaveTrans is offline   Reply With Quote
Old 03-30-2020, 06:40 AM   #7772
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,104
Default

Folks have posted a few bugs, mostly to do with Initialization, thanks, that stuff is next up on the list.

Also, folks are suggesting sub-threads, I totally get that, but am resisting for now -- once we get the basics of the hardware sorted there will be little change, the focus will be on Zones, which, by design, are universal
__________________
Beta software https://stash.reaper.fm/v/38349/CSI%20beta.zip Donate GeoffWaddington.ca
Installation / documentation / source https://github.com/GeoffAWaddington/...ntegrator/wiki
Geoff Waddington is offline   Reply With Quote
Old 03-30-2020, 07:22 AM   #7773
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,425
Default

Geoff, question regarding the Wiki (just looking for some guidance/thoughts here - not just limited to Geoff if others have opinions): around page 187 of this thread we landed on a nice solution for Folders that involved using existing Reaper actions and just setting up CSI to follow the MCP. Should we document this in the Wiki? If so, where? It's not really CSI specific since it relies on Reaper actions, but it may be helpful for people to see working examples of using these actions for folders. Should I create a Folder page and just show some examples? Maybe put it in a Tips section? Not bother at all since this is all handled via native Reaper actions? Thoughts?
Funkybot is online now   Reply With Quote
Old 03-30-2020, 10:33 AM   #7774
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,104
Default

Quote:
Originally Posted by Funkybot View Post
Geoff, question regarding the Wiki (just looking for some guidance/thoughts here - not just limited to Geoff if others have opinions): around page 187 of this thread we landed on a nice solution for Folders that involved using existing Reaper actions and just setting up CSI to follow the MCP. Should we document this in the Wiki? If so, where? It's not really CSI specific since it relies on Reaper actions, but it may be helpful for people to see working examples of using these actions for folders. Should I create a Folder page and just show some examples? Maybe put it in a Tips section? Not bother at all since this is all handled via native Reaper actions? Thoughts?
As soon as I read your VCA page, I went through exactly what you did

I think there should be a Folder Page, since it is so close to VCAs, it deserves the same treatment.

Just my 2c
__________________
Beta software https://stash.reaper.fm/v/38349/CSI%20beta.zip Donate GeoffWaddington.ca
Installation / documentation / source https://github.com/GeoffAWaddington/...ntegrator/wiki
Geoff Waddington is offline   Reply With Quote
Old 03-30-2020, 11:14 AM   #7775
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,425
Default

Quote:
Originally Posted by Geoff Waddington View Post
As soon as I read your VCA page, I went through exactly what you did

I think there should be a Folder Page, since it is so close to VCAs, it deserves the same treatment.
Yeah, I was thinking we need something. I'll try to get on it later today (maybe tomorrow) with some examples.
Funkybot is online now   Reply With Quote
Old 03-30-2020, 01:18 PM   #7776
Mike@Ossarium
Human being with feelings
 
Mike@Ossarium's Avatar
 
Join Date: Nov 2012
Location: Munich, Germany
Posts: 82
Default Behringer X-Touch & X-Touch Extender

Hi,

i posted my config files for the Behringer X-Touch & X-Touch Extender here:

https://forum.cockos.com/showthread.php?t=233564

https://stash.reaper.fm/38709/CSI_Be...tender_V01.zip

Feel free to use and let me know what you think.

Cheers, Mike
__________________
Reaper Version: 6.08 with CSI and SWS / Audio Interface: Behringer FCA1616 + ADA8000
Band: Ossarium / Last Project: http://ossarium.bandcamp.com/ (Recorded and Mixed with Reaper)
Mike@Ossarium is offline   Reply With Quote
Old 03-30-2020, 01:30 PM   #7777
audio2u
Human being with feelings
 
audio2u's Avatar
 
Join Date: Dec 2010
Location: Sydney
Posts: 162
Default

Quote:
Originally Posted by Geoff Waddington View Post
No, they shouldn't show up in the right most list -- that is the custom list of surfaces you have defined for this Page.
Gotcha!
Quote:
Originally Posted by Geoff Waddington View Post
Other Pages can have completely different definitions, have a look at Conceptual Overview on the wiki -- link is below.
Yep, done that.
Quote:
Originally Posted by Geoff Waddington View Post
Once you have defined the Surface(s) for the Page you must press OK on all of the dialogs for the changes to be saved.
And that.
Quote:
Originally Posted by Geoff Waddington View Post
The list of Surfaces to which you refer (14) appear in the Surface Template dropdown in the Add Midi Surface Dialog.
Right.

Quote:
Originally Posted by WaveTrans
-Just to be clear about this:
If you double click (the re-appearing) HomePage (or any page created by you) the right hand side window remains empty?
Correct.

Quote:
Originally Posted by WaveTrans
-If you can not erase the HomePage file and none of your changes are saved, there may be some read/write rights issue underneath.
That's what I'm suspecting. F***ing windoze.

Quote:
Originally Posted by WaveTrans
Have you tried to do all this when logged in as administrator?
I ran Reaper "as administrator" (via shift-click on app shortcut), and THAT allowed my manually-created PAGE to remain after exiting/re-entering the CSI Settings window.... but again, any manually-created SURFACES will not persist.

Quote:
Originally Posted by WaveTrans
-Another cause may be the repository issue. You have to have the Visual C++ 2019 runtime repository installed. The link is in the wiki, I think step 5 of the installation.
Nope. Done that. No difference.
__________________
Cheers,
Bruce.
audio2u is offline   Reply With Quote
Old 03-30-2020, 03:51 PM   #7778
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,104
Default

Quote:
Originally Posted by Mike@Ossarium View Post
Hi,

i posted my config files for the Behringer X-Touch & X-Touch Extender here:

https://forum.cockos.com/showthread.php?t=233564

https://stash.reaper.fm/38709/CSI_Be...tender_V01.zip

Feel free to use and let me know what you think.

Cheers, Mike
Thanks, much appreciated !!
__________________
Beta software https://stash.reaper.fm/v/38349/CSI%20beta.zip Donate GeoffWaddington.ca
Installation / documentation / source https://github.com/GeoffAWaddington/...ntegrator/wiki
Geoff Waddington is offline   Reply With Quote
Old 03-30-2020, 03:52 PM   #7779
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,104
Default

Quote:
Originally Posted by audio2u View Post
I ran Reaper "as administrator" (via shift-click on app shortcut), and THAT allowed my manually-created PAGE to remain after exiting/re-entering the CSI Settings window.... but again, any manually-created SURFACES will not persist.
Can you (as administrator) change the rights/permissons of the CSI folder (for all users) to fix this ?
__________________
Beta software https://stash.reaper.fm/v/38349/CSI%20beta.zip Donate GeoffWaddington.ca
Installation / documentation / source https://github.com/GeoffAWaddington/...ntegrator/wiki
Geoff Waddington is offline   Reply With Quote
Old 03-30-2020, 04:03 PM   #7780
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,425
Default

Here's a Wiki page on folders. This one was trickier to explain than I thought it would be. Feedback/edits always welcome.

https://github.com/malcolmgroves/rea...i/wiki/Folders
Funkybot is online now   Reply With Quote
Old 03-30-2020, 04:31 PM   #7781
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,104
Default

Quote:
Originally Posted by Funkybot View Post
Here's a Wiki page on folders. This one was trickier to explain than I thought it would be. Feedback/edits always welcome.

https://github.com/malcolmgroves/rea...i/wiki/Folders
Looking good !!

Thanks, as usual.
__________________
Beta software https://stash.reaper.fm/v/38349/CSI%20beta.zip Donate GeoffWaddington.ca
Installation / documentation / source https://github.com/GeoffAWaddington/...ntegrator/wiki
Geoff Waddington is offline   Reply With Quote
Old 03-30-2020, 08:33 PM   #7782
tdc
Human being with feelings
 
Join Date: Oct 2019
Location: Sydney
Posts: 445
Default

EuCon Related:

When closing and opening a new project, as has been reported, EuCon has a tendency to crash. I reboot EuCon and the Surface returns to a state that looks like CSI has control of it, however no channels appear on the surface. Using the CSI Edit Mode, i can see that EuCon messages are appearing in the main Edit Window as well as the Console.

Any thoughts on how to refresh CSI to return to functioning state with channels on the surface.
tdc is offline   Reply With Quote
Old 03-30-2020, 08:53 PM   #7783
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,425
Default

Quote:
Originally Posted by tdc View Post
EuCon Related:

When closing and opening a new project, as has been reported, EuCon has a tendency to crash. I reboot EuCon and the Surface returns to a state that looks like CSI has control of it, however no channels appear on the surface. Using the CSI Edit Mode, i can see that EuCon messages are appearing in the main Edit Window as well as the Console.

Any thoughts on how to refresh CSI to return to functioning state with channels on the surface.
You can try a few things:

1. Right-click the EuControl entry in the System Tray and select the "Restart EUCON Applications" menu item. That usually works here.

If that doesn't do it:

2. There's a Reaper action for "Reset All Control Surfaces," try that.

3. You can also try opening the CSI preferences and clicking OK, which forces a refresh.

Usually #1 does it.

You can also try closing Reaper and opening the project directly from File Explorer.

Hopefully some of these stray EuCon issues got ironed out in one of the next few builds, but there's been so much progress in just the last few months with a lot more on Geoff's to-do list so I'm sure it'll come in due time.
Funkybot is online now   Reply With Quote
Old 03-30-2020, 08:54 PM   #7784
tdc
Human being with feelings
 
Join Date: Oct 2019
Location: Sydney
Posts: 445
Default

Question relating to setting how surfaces are delegated channels.

I have a iPad with a 8ch surface in Lemur and an Avid S3, and I can't see why ch 1-8 are being sent to the iPad and ch 9 onwards are sent to the S3?

I would like to build some setups where the iPad augments, and other times mirrors the S3.

Thanks
tdc is offline   Reply With Quote
Old 03-30-2020, 09:29 PM   #7785
tdc
Human being with feelings
 
Join Date: Oct 2019
Location: Sydney
Posts: 445
Default

Quote:
Originally Posted by Funkybot View Post
1. Right-click the EuControl entry in the System Tray and select the "Restart EUCON Applications" menu item. That usually works here.
Hi Funkybot, thanks for these suggestions. I have been using EuCon since its inception in the beta stages at Euphonix, so "Restart EUCON" is a sadly all to familiar action. ;-)

I wasn't aware of the Reaper Action "Restart All Control Surfaces" shall give that a go next time.

Quote:
Originally Posted by Funkybot View Post
Hopefully some of these stray EuCon issues got ironed out in one of the next few builds, but there's been so much progress in just the last few months with a lot more on Geoff's to-do list so I'm sure it'll come in due time.
Great news! I am super excited at this. Since my last time trying CSI out, it feels like its come a long way. It looks well on track to provide many more audio folks with a pro level alternative for facilities where a control surface is important.

UPDATE - 5 Hours Later...
Just found your amazing work with the MFT! Downloaded your files and it works a treat. Such fantastic work and manual Mr Funky. I shall digest the files and learn the methods. [Sometimes this CSI feels like I am in a Dan Brown novel.]

All seems to be working like I think it should, except for the FX Mapping. I have checked the names and they match. It seems that when I press the top Left bank button, nothing changes. ? Where does the code for this toggling reside - CSI files or the MFT editor?

Last edited by tdc; 03-31-2020 at 04:40 AM.
tdc is offline   Reply With Quote
Old 03-30-2020, 09:32 PM   #7786
tdc
Human being with feelings
 
Join Date: Oct 2019
Location: Sydney
Posts: 445
Default

@FunkyBot. Just noticed that you're also using a Midi Fighter Twister in your setup? Noticed you created a new page on the Wiki for RGB LED control. Am about to start adding it into my setup. I have used it for a few years and find it an amazing and simple way to make plugins / synths tactile. CSI will make great use of it I suspect. Way too much fun!!
tdc is offline   Reply With Quote
Old 03-31-2020, 12:59 AM   #7787
tdc
Human being with feelings
 
Join Date: Oct 2019
Location: Sydney
Posts: 445
Default

Sheesh - most of you folks must be on the other side of the earth, as I can only imagine youre all asleep, allowing me rack up multiple questions in a row.

Question relating to control states being left hanging when a track is deleted. I am noticing that VU Meter values are not set to 0.0 went a track is deleted, leaving meters stuck at their value at the point the track was deleted. Is there a method I can call to stop this?
tdc is offline   Reply With Quote
Old 03-31-2020, 03:18 AM   #7788
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,104
Default

Quote:
Originally Posted by tdc View Post
Question relating to setting how surfaces are delegated channels.

I have a iPad with a 8ch surface in Lemur and an Avid S3, and I can't see why ch 1-8 are being sent to the iPad and ch 9 onwards are sent to the S3?
CSI just automatically hands out channel assignments based on the order of the surfaces in the right hand list on the config panel.

Looks like the OSC device comes first in the list in your case.


Quote:
Originally Posted by tdc View Post
I would like to build some setups where the iPad augments, and other times mirrors the S3.
You will want to use Pages for that job.

Pages allow for COMPLETELY different setups, available via NextPage and GoPage (like GoZone) .

Have a look at the wiki, Conceptual Overview, you can have completely different .mst/.ost/.zon setups.
__________________
Beta software https://stash.reaper.fm/v/38349/CSI%20beta.zip Donate GeoffWaddington.ca
Installation / documentation / source https://github.com/GeoffAWaddington/...ntegrator/wiki
Geoff Waddington is offline   Reply With Quote
Old 03-31-2020, 03:18 AM   #7789
UNdark
Human being with feelings
 
Join Date: Jan 2017
Posts: 44
Default

Quote:
Originally Posted by UNdark View Post
HI - not posted for a while as this issue continued and I can't get to the bottom of it. Loads of other features i have addedto my zon but the jog wheel is too important to me so had to go back to the internal MCU setup that comes with reaper for now. (jog wheel works)
Ideally, could anyone post the correct command list to get the jog wheel working please? I tried copying Mixmonkey's original - this did once work before.. but no more.

I have the most recent upload of the csi (working using mcu mst) and not modified anything - i'd like to go from there then i can add all my other stuff i've done to my zon files.

Macbook pro - os el capitan - reaper 5.99 (some contextual toolbars that are fine in 5 don't work for me in 6 yet - issue reported)

THe things i have been able to program have been brilliant and can't wait to load it up with all my other commands - many thanks !
UNdark
*bump*

Hi mixmonkey / anyone - do you have a working version of the MCU jog wheel mst and zon please?
UNdark is offline   Reply With Quote
Old 03-31-2020, 03:20 AM   #7790
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,104
Default

Quote:
Originally Posted by tdc View Post
Sheesh - most of you folks must be on the other side of the earth, as I can only imagine youre all asleep, allowing me rack up multiple questions in a row.

Question relating to control states being left hanging when a track is deleted. I am noticing that VU Meter values are not set to 0.0 went a track is deleted, leaving meters stuck at their value at the point the track was deleted. Is there a method I can call to stop this?
More of that initialization stuff that's currently being worked on
__________________
Beta software https://stash.reaper.fm/v/38349/CSI%20beta.zip Donate GeoffWaddington.ca
Installation / documentation / source https://github.com/GeoffAWaddington/...ntegrator/wiki
Geoff Waddington is offline   Reply With Quote
Old 03-31-2020, 03:34 AM   #7791
tdc
Human being with feelings
 
Join Date: Oct 2019
Location: Sydney
Posts: 445
Default

Quote:
Originally Posted by Geoff Waddington View Post
More of that initialization stuff that's currently being worked on
Thanks Geoff.
tdc is offline   Reply With Quote
Old 03-31-2020, 03:37 AM   #7792
tdc
Human being with feelings
 
Join Date: Oct 2019
Location: Sydney
Posts: 445
Default

Quote:
Originally Posted by Geoff Waddington View Post
CSI just automatically hands out channel assignments based on the order of the surfaces in the right hand list on the config panel.
Thanks for that - that makes sense now you say it. We should add that to the Wiki.

Quote:
Originally Posted by Geoff Waddington View Post
Have a look at the wiki, Conceptual Overview, you can have completely different .mst/.ost/.zon setups.
I have read that page again and can't see how to configure the new Page to make both the iPad and the S3 Console have all channels?
tdc is offline   Reply With Quote
Old 03-31-2020, 03:39 AM   #7793
tdc
Human being with feelings
 
Join Date: Oct 2019
Location: Sydney
Posts: 445
Default

Quote:
Originally Posted by UNdark View Post
*bump*
Hi mixmonkey / anyone - do you have a working version of the MCU jog wheel mst and zon please?
Hey UNDark, sorry I don't have an answer for you but am keen to learn the same also.
tdc is offline   Reply With Quote
Old 03-31-2020, 03:41 AM   #7794
audio2u
Human being with feelings
 
audio2u's Avatar
 
Join Date: Dec 2010
Location: Sydney
Posts: 162
Default

Quote:
Originally Posted by Geoff Waddington View Post
Can you (as administrator) change the rights/permissons of the CSI folder (for all users) to fix this ?
Geoff,
I went to the properties of the CSI folder, and tried:

1. Changing OWNER to my user account, but also
2. Changing OWNER to Administrators (the group which my user account belongs to anyway, so makes step #1 kinda redundant!).

Neither has improved my system's ability to retain SURFACE setup info.
__________________
Cheers,
Bruce.
audio2u is offline   Reply With Quote
Old 03-31-2020, 04:12 AM   #7795
tdc
Human being with feelings
 
Join Date: Oct 2019
Location: Sydney
Posts: 445
Default

Quote:
Originally Posted by audio2u View Post
Geoff,Neither has improved my system's ability to retain SURFACE setup info.
Hey Bruce - sorry to hear of your trials. Emerging tech is always challenging. As a fellow Sydney-sider, I would be happy to chat locally if you wished, phone or Skype/facetime.

I am also a new Reaper/CSI fan so can't promise anything cutting edge, but a problem shared is a problem *something* can never recall how that saying goes.
tdc is offline   Reply With Quote
Old 03-31-2020, 04:27 AM   #7796
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,503
Default

Quote:
Originally Posted by UNdark View Post
*bump*

Hi mixmonkey / anyone - do you have a working version of the MCU jog wheel mst and zon please?
Code:
Widget JogWheelRotaryCW
	Press b0 3c 01
WidgetEnd

Widget JogWheelRotaryCCW
	Press b0 3c 41
WidgetEnd
Code:
JogWheelRotaryCW                    Reaper "40647"      //Move cursor right to grid division
JogWheelRotaryCCW                   Reaper "40646"      //Move cursor left to grid division
MixMonkey is offline   Reply With Quote
Old 03-31-2020, 04:30 AM   #7797
UNdark
Human being with feelings
 
Join Date: Jan 2017
Posts: 44
Default

Quote:
Originally Posted by MixMonkey View Post
Code:
Widget JogWheelRotaryCW
	Press b0 3c 01
WidgetEnd

Widget JogWheelRotaryCCW
	Press b0 3c 41
WidgetEnd
Code:
JogWheelRotaryCW                    Reaper "40647"      //Move cursor right to grid division
JogWheelRotaryCCW                   Reaper "40646"      //Move cursor left to grid division
Great, thanks - lost without that function !
UNdark is offline   Reply With Quote
Old 03-31-2020, 05:05 AM   #7798
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,503
Default

Quote:
Originally Posted by UNdark View Post
Great, thanks - lost without that function !
MixMonkey is offline   Reply With Quote
Old 03-31-2020, 05:48 AM   #7799
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,104
Default

Quote:
Originally Posted by tdc View Post
Thanks for that - that makes sense now you say it. We should add that to the Wiki.
Agree.

Quote:
Originally Posted by tdc View Post
I have read that page again and can't see how to configure the new Page to make both the iPad and the S3 Console have all channels?
Oops, thought that feature was implemented, just checked, it's not yet.

It's on the list though
__________________
Beta software https://stash.reaper.fm/v/38349/CSI%20beta.zip Donate GeoffWaddington.ca
Installation / documentation / source https://github.com/GeoffAWaddington/...ntegrator/wiki
Geoff Waddington is offline   Reply With Quote
Old 03-31-2020, 05:49 AM   #7800
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,104
Default

Quote:
Originally Posted by audio2u View Post
Geoff,
I went to the properties of the CSI folder, and tried:

1. Changing OWNER to my user account, but also
2. Changing OWNER to Administrators (the group which my user account belongs to anyway, so makes step #1 kinda redundant!).

Neither has improved my system's ability to retain SURFACE setup info.
Please post the contents of your CSI.ini file.
__________________
Beta software https://stash.reaper.fm/v/38349/CSI%20beta.zip Donate GeoffWaddington.ca
Installation / documentation / source https://github.com/GeoffAWaddington/...ntegrator/wiki
Geoff Waddington is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:49 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.