Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Color Themes and Icon Sets

Reply
 
Thread Tools Display Modes
Old 09-18-2018, 01:17 AM   #41
andyp24
Human being with feelings
 
Join Date: Mar 2016
Posts: 681
Default

What am I doing wrong?

Your screenshots are vibrant and colourful - TCP shows track colour, Items show item/track colour with black waveforms....

Mine's pretty much a sea of dull grey....?

How can I make it look more like yours?

Thanks
Andy
Attached Images
File Type: png Screen Shot 2018-09-18 at 09.16.01.png (51.6 KB, 343 views)
andyp24 is offline   Reply With Quote
Old 09-18-2018, 04:35 AM   #42
Softsynth
Human being with feelings
 
Softsynth's Avatar
 
Join Date: Jun 2015
Posts: 5,455
Default

Mouse right click on track>middle of list - track colour.


Reaper preferences>Appearance>Peaks & Waveforms - choose what you want in custom colours.
Softsynth is offline   Reply With Quote
Old 09-18-2018, 05:28 AM   #43
andyp24
Human being with feelings
 
Join Date: Mar 2016
Posts: 681
Default

Thanks SoftSynth

Obviously, I knew how to set the track colour, but have now tweaked the Appearances Preference to give me what I want on items :-)

That solves half the problem....

The other half I figured out from your advice - tinting the Track Panels themselves to show the chosen colour (Appearances/Track Control Panels/Tint track panel backgrounds)

Many thanks for your advice. Liking the nice clean and brightly coloured look of this now, and will give it a go for a week or two to see if I'll adopt it permanently.

Cheers
andyp24 is offline   Reply With Quote
Old 09-18-2018, 06:01 AM   #44
andyp24
Human being with feelings
 
Join Date: Mar 2016
Posts: 681
Default

Is there an easy way of making the cursor stand out a little better against the dark grey background of the Playlist?

Just a little difficult to see where it is sometimes...
andyp24 is offline   Reply With Quote
Old 09-18-2018, 06:49 AM   #45
Softsynth
Human being with feelings
 
Softsynth's Avatar
 
Join Date: Jun 2015
Posts: 5,455
Default

Quote:
Originally Posted by andyp24 View Post
Is there an easy way of making the cursor stand out a little better against the dark grey background of the Playlist?

Just a little difficult to see where it is sometimes...
Never had that problem. Maybe screen calibration will help?

Other than that:
https://www.reaper.fm/sdk/cursors/cursors.php
Softsynth is offline   Reply With Quote
Old 09-18-2018, 07:12 AM   #46
andyp24
Human being with feelings
 
Join Date: Mar 2016
Posts: 681
Default

Thanks. When it's a pointer shape it's fine, but when it turns to the i-Beam shape it's a little subtle.

This may be a Mac-specific issue perhaps?

Making the cursor a bit bigger helps.

I wonder how easy it would be to mod the theme just to lighten the grey background to the Playlist a touch....?

Andy
andyp24 is offline   Reply With Quote
Old 09-18-2018, 08:08 AM   #47
andyp24
Human being with feelings
 
Join Date: Mar 2016
Posts: 681
Default

I just tried to see if I can tweak it in the inbuilt Theme Tweaker, but didn't really know what I was doing. I changed the colour for the Empty Arrange View Area to another one, but it didn't make any difference.....

OK, found the element I need now.... :-)
andyp24 is offline   Reply With Quote
Old 09-18-2018, 11:33 AM   #48
lalo
Human being with feelings
 
Join Date: Jun 2006
Posts: 119
Default

Thanks @cubic13
Where can i find the rtconfig.txt file?

Quote:
Originally Posted by cubic13 View Post
Hi, lalo

I actually dimmed a little the color of the track names themselves : see post #19 for more details. Maybe you could try the solution in it.

Beside this, I have tested a black font : for a reason, it seems to fit well in the mixer but not in the tcp, IMO.
__________________
alfonso "lalo" santimone
www.soundcloud.com/alfonsosantimone
www.elgallorojorecords.com
lalo is offline   Reply With Quote
Old 09-18-2018, 10:50 PM   #49
cubic13
Human being with feelings
 
cubic13's Avatar
 
Join Date: Dec 2013
Location: Near Serre-Ponšon lake, french Alps
Posts: 831
Default

@Softsynth :
Thanks for the help while I wasn't there...


@andyp24 :
Basically, the two screenshots have been done with the following settings in the Preferences>Appearance>Track Control Panels pane :

- The first one (colored tcp panel backgrounds) with Set track label background to custom track colors unticked and Tint track panel backgrounds ticked.
- The second one with the opposite settings.

Concerning the background color, the Empty arrange view area setting isn't sufficient. You have to tweak also these :
- Track background (odd tracks)
- Track background (even tracks)
- Track divider line (odd tracks)
- Track divider line (even tracks)
- Envelope lane divider line (odd tracks)
- Envelope lane divider line (even tracks)
which are something near the third of the settings list.

HTWH...


@lalo :
To make the change, do this :

1) Make a copy of the CRado.ReaperThemeZip file and put it somewhere safe, which means outside of the \ColorThemes subfolder.
2) Change its extension to get Crado.zip and unzip it. You should now have both a CRado folder and a CRado.ReaperTheme file.
3) The rtconfig.txt file is in the CRado folder : open it with a raw text editor, such as NotePad++.
4) change the line #51 from this...

set tcp.label.color [210 210 210]

to this :

set tcp.label.color [255 255 255]

... which was the original setting.

6) Save the edited rtconfig.txt.
7) Select BOTH the CRado folder and Crado.ReaperTheme file and zip them together.
8) Change the .zip extension of the archive file obtained to .ReaperThemeZip, copy it and put it back in replacement of the existing one in the \ColorThemes subfolder of your Reaper installation.

HTWH...
__________________
DAW : i7-870|P7P55D-E|16 Gb|2 HDD 1 Tb|W7Pro SP1(64)|RME Fireface UCX + Behringer ADA8200
Soft : Reaper(64)|Cubase 5-6.5(64)|Emulator X3 & several other VSTis (2 bridged)...
Gear : VMK-188+|MPD32|ME30P|Korg 05R/W|Roland D110|Yamaha TX802|Pre-MIDI stuff...
cubic13 is offline   Reply With Quote
Old 09-19-2018, 04:01 AM   #50
andyp24
Human being with feelings
 
Join Date: Mar 2016
Posts: 681
Default

Thanks Cubic

I've made a few small changes that I prefer for clarity, but overall I really like this theme.

One thing I've noticed that I'd like to tweak - the playrate slider on the Transport bar is a nice grey/blue, and then when set to non-standard rate it changes to a subtle orange. I'd like to make the non-standard colour much more vibrant as a reminder to me that it's active, so I don't render with it set to the wrong rate after quick-checking through a file (as I sometimes do!).

I unpacked the theme, but could only find one png for the playspeed, which is the blue one. I can't see how it turns orange. Can you help me please?

Cheers
Andy
andyp24 is offline   Reply With Quote
Old 09-19-2018, 05:53 AM   #51
cubic13
Human being with feelings
 
cubic13's Avatar
 
Join Date: Dec 2013
Location: Near Serre-Ponšon lake, french Alps
Posts: 831
Default

Hi again, Andy

The "orange" color is not from a graphic file : it's a setting in the Theme development/tweaker window, project playrate control when not 1.0, which is near the quarter of the settings list.

I actually let it as it was initially, but indeed, maybe I should change it...
__________________
DAW : i7-870|P7P55D-E|16 Gb|2 HDD 1 Tb|W7Pro SP1(64)|RME Fireface UCX + Behringer ADA8200
Soft : Reaper(64)|Cubase 5-6.5(64)|Emulator X3 & several other VSTis (2 bridged)...
Gear : VMK-188+|MPD32|ME30P|Korg 05R/W|Roland D110|Yamaha TX802|Pre-MIDI stuff...
cubic13 is offline   Reply With Quote
Old 09-19-2018, 05:55 AM   #52
andyp24
Human being with feelings
 
Join Date: Mar 2016
Posts: 681
Default

Brilliant, thanks - I'll take a look :-)

Yes, found it - it's now a ghastly shade of bright purple which is much harder to forget about!!!!

Cheers
Andy
andyp24 is offline   Reply With Quote
Old 09-28-2018, 07:10 AM   #53
andyp24
Human being with feelings
 
Join Date: Mar 2016
Posts: 681
Default

I think the answer is probably "no" but is it possible in this theme to have the mixer channels fully tinted according to the track colour, rather than just a little coloured block at the bottom?

Cheers
Andy
andyp24 is offline   Reply With Quote
Old 09-28-2018, 07:14 AM   #54
hopi
Human being with feelings
 
hopi's Avatar
 
Join Date: Oct 2008
Location: Right Hear
Posts: 14,942
Default

I for one, fully support Andy's req for fully colored panels.... at least as an option, since I too find that sort of visual clue important...

not a deal breaker but it would be nice %^)
__________________
...should be fixed for the next build... http://tinyurl.com/cr7o7yl
https://soundcloud.com/hopikiva/angel-rain
hopi is offline   Reply With Quote
Old 10-01-2018, 08:31 AM   #55
andyp24
Human being with feelings
 
Join Date: Mar 2016
Posts: 681
Default

Hi - a couple of other questions please...

With the TCP panels fully tinted (via the Preferences option) I have two small problems:

1) Sometimes the Track name is not visible (eg for a bright yellow track, the white text is not readable)

2) The FX on/off button appears to be transparent, unlike all the ones around it, which are a nice grey. The FX on/off button shows the colour of the track, which makes it look a little out of place.

Is it possible (for me?) to correct these minor things?

Thanks
Andy
andyp24 is offline   Reply With Quote
Old 10-01-2018, 12:06 PM   #56
cubic13
Human being with feelings
 
cubic13's Avatar
 
Join Date: Dec 2013
Location: Near Serre-Ponšon lake, french Alps
Posts: 831
Default

Hi again, Andy...

1) It doesn't happen here, and I have tested it with both RGB 255/255/128 and 255/255/0 values as track colors. The labels are still easily readable. Actually, I have dimmed the tcp panels exactly for this : to let the tcp labels readable in all cases. Could you post here a screenshot that shows the issue ?

2) I have let the tcp.fxbyp control as it was in the RADO V4 theme. I have thought about changing it to match the other controls appearance but finally decided against it, as for me, it clearly shows that this control is actually a switch for the one directly at its right. Guess that Nick Moritz did it this way exactly for the same reason. So, I'm rather inclined to let it as it is, to be honest...

Beside this, and to answer at your previous post, I am wondering about tinting the mcp panels again. I don't like the kaleidoscopic wiew of the mixer when all the panels area are tinted, as it was in RADO V4, and this is why I made them almost fully opaque. So, maybe I should allow their tinting again, but this would mean to reshape no less than 60 (yes, sixty...) mcp panels, considering all the layouts available. So, I'm hesitating doing this to get something that I wanted to get rid of at first.

Additionaly, I was about to upload an update including, among several things, an added folder which is including alternate mcp_bgsel.png files matching hopi request (post #33). I probably would have to work on them again also to match your own. I'm rather lost about what to do, actually...
__________________
DAW : i7-870|P7P55D-E|16 Gb|2 HDD 1 Tb|W7Pro SP1(64)|RME Fireface UCX + Behringer ADA8200
Soft : Reaper(64)|Cubase 5-6.5(64)|Emulator X3 & several other VSTis (2 bridged)...
Gear : VMK-188+|MPD32|ME30P|Korg 05R/W|Roland D110|Yamaha TX802|Pre-MIDI stuff...
cubic13 is offline   Reply With Quote
Old 10-01-2018, 02:36 PM   #57
andyp24
Human being with feelings
 
Join Date: Mar 2016
Posts: 681
Default

Hi Cubic

Thanks for the reply. I'll try to post a screenshot tomorrow.

With regard to the other issues, it's your theme so where it's just a matter of personal preference (e.g. fully tinted mixer panels, FX button opacity etc) I'm perfectly happy for you to go with whatever your preference is. If there are options for me to tweak things, great (as I have done with some element colours etc). But where there aren't options, I certainly don't expect anyone to put in loads of work just to suit me!!

I find this theme (with a few small tweaks) very easy on the eye and clear to work with, so I'm very grateful for your work on it.

Cheers
Andy
andyp24 is offline   Reply With Quote
Old 10-02-2018, 09:34 AM   #58
andyp24
Human being with feelings
 
Join Date: Mar 2016
Posts: 681
Default

Hi Cubic

Here's the screenshot of the top corner of the playlist showing that when the track colour is a bright yellow, the text of the track name is pretty much unreadable....

FWIW if I could edit the theme to make the Track Name box a constant opaque colour (probably the same grey as the rest of the theme) with white text, I'd be happy with that. If it's easy for me to do, please let me know.

Cheers
Andy
Attached Images
File Type: jpeg CRADO screenshot.jpeg (38.3 KB, 141 views)
andyp24 is offline   Reply With Quote
Old 10-02-2018, 09:36 AM   #59
lalo
Human being with feelings
 
Join Date: Jun 2006
Posts: 119
Default

One little thingie i miss from the "classic" Rado is the Stereo Width horizontal fader in the tracks Mixer view
__________________
alfonso "lalo" santimone
www.soundcloud.com/alfonsosantimone
www.elgallorojorecords.com
lalo is offline   Reply With Quote
Old 10-02-2018, 12:37 PM   #60
cubic13
Human being with feelings
 
cubic13's Avatar
 
Join Date: Dec 2013
Location: Near Serre-Ponšon lake, french Alps
Posts: 831
Default

@andyp24
My bad... Indeed, when the Set track label background to custom track colors option is activated, the tcp label becomes difficult to read, with a bright yellow track color. So, I'm going to delay the 1.30 update to fix this, until I find a solution. Stay tuned...

@lalo
Sorry, but I don't get where is the issue : the stereo width is displayed as expected here, when either 'Stereo pan' or 'Dual pan' modes are set. Could you post a screenshot that shows the issue ? Thanks...
__________________
DAW : i7-870|P7P55D-E|16 Gb|2 HDD 1 Tb|W7Pro SP1(64)|RME Fireface UCX + Behringer ADA8200
Soft : Reaper(64)|Cubase 5-6.5(64)|Emulator X3 & several other VSTis (2 bridged)...
Gear : VMK-188+|MPD32|ME30P|Korg 05R/W|Roland D110|Yamaha TX802|Pre-MIDI stuff...
cubic13 is offline   Reply With Quote
Old 10-03-2018, 06:49 AM   #61
lalo
Human being with feelings
 
Join Date: Jun 2006
Posts: 119
Default

Quote:
Originally Posted by cubic13 View Post
@lalo
Sorry, but I don't get where is the issue : the stereo width is displayed as expected here, when either 'Stereo pan' or 'Dual pan' modes are set. Could you post a screenshot that shows the issue ? Thanks...
here they are
Attached Images
File Type: jpg Rado - V4.JPG (26.4 KB, 140 views)
File Type: jpg CRado.JPG (26.9 KB, 151 views)
__________________
alfonso "lalo" santimone
www.soundcloud.com/alfonsosantimone
www.elgallorojorecords.com
lalo is offline   Reply With Quote
Old 10-03-2018, 09:08 AM   #62
cubic13
Human being with feelings
 
cubic13's Avatar
 
Join Date: Dec 2013
Location: Near Serre-Ponšon lake, french Alps
Posts: 831
Default

Hi, lalo

Are you sure that, for these tracks, the pan/width mode is set as either 'Dual pan' or 'Stereo pan' ? Because the mcp.width control appears only in these cases. I did this purposely to avoid its display if the tracks are not set as so.

Additionaly, you can choose between normal and 'Different sliders' layouts for the mcp.width control for default, large, narrow and legacy dispositions to allow the display of the original triangle shaped thumb.

HTWH...
__________________
DAW : i7-870|P7P55D-E|16 Gb|2 HDD 1 Tb|W7Pro SP1(64)|RME Fireface UCX + Behringer ADA8200
Soft : Reaper(64)|Cubase 5-6.5(64)|Emulator X3 & several other VSTis (2 bridged)...
Gear : VMK-188+|MPD32|ME30P|Korg 05R/W|Roland D110|Yamaha TX802|Pre-MIDI stuff...
cubic13 is offline   Reply With Quote
Old 10-07-2018, 06:25 AM   #63
_Stevie_
Human being with feelings
 
_Stevie_'s Avatar
 
Join Date: Oct 2017
Posts: 2,639
Default

Is there a way to put the time signature-field next to the tempo field?
It would make more sense there, IMO.
__________________
My Reascripts forum thread | My Reascripts on GitHub | Stephan R÷mer - film composer
If you wish to donate for my scripts: please consider an organization like: animal shelter, doctors without borders, UNICEF, etc...
_Stevie_ is offline   Reply With Quote
Old 10-07-2018, 07:56 AM   #64
cubic13
Human being with feelings
 
cubic13's Avatar
 
Join Date: Dec 2013
Location: Near Serre-Ponšon lake, french Alps
Posts: 831
Default v 1.30 is in the stash...

@_Stevie_

Could be, yes, but I have kept that way until now for three reasons. First, it's how it was setted in the RADO V4 theme. Second, changing its position would lead me to, at least partially, rewrite the transport bar management. And third, I'm not sure that the time signature field is that much tied to the tempo one : IMO, there are two different things. I'll consider this, though, for maybe an added update.


Beside this, I thought that I was almost done with the previous 1.20 version. Obviously, I was wrong... So, in this one :

1) I changed my mind concerning the mcp panels coloring : so, I put back the original tinting scheme for them, to follow both andyp24 and hopi requests (post #53 & 54).
2) I increased a little more the brightness of the tcp labels while changing a little their background appearance, this, to make them readable in all cases (andyp24 request, post #55).
3) Following hopi request (post #33), I added in the zip file a folder which contains all the necessary tcp/mcp_bgsel.png files to allow the appearance of a highlighted border for selected tracks, instead of a brighter background. An AltSelectedPanels_Instructions.pdf file is included in it to explain how to use its content.
4) I have straighten up the mcp 'Legacy' layouts for a more uniform appearance of them, especially the default one, which has now mcp.volume and mcp.meters controls with the same dimension as the other ones. I also did the same thing for the 'Legacy Alt' ones.
5) I recentered the position of the extended area controls in the 'Legacy Max' layouts.
6) In the transport bar, I fixed the appearance of the 'global' envelope modes, which were rather ugly, in my view.
7) Still in the transport bar, I increased the width of the transport.bpm.edit control to allow a more confortable view of its value when 5 digits are displayed. I also adjusted a little more the whole transport bar behavior when undocked, especially for the 'Compact' layout.
8) I changed the item controls appearance to avoid the horrible full white background of them, which were appearing in some cases.
9) Several more adjustments have been made, concerning the mcp.master track or colors used in the theme development/tweaker windows, among others. Actually, I lost track of all the changes done...

Hope this one be useful for some...
__________________
DAW : i7-870|P7P55D-E|16 Gb|2 HDD 1 Tb|W7Pro SP1(64)|RME Fireface UCX + Behringer ADA8200
Soft : Reaper(64)|Cubase 5-6.5(64)|Emulator X3 & several other VSTis (2 bridged)...
Gear : VMK-188+|MPD32|ME30P|Korg 05R/W|Roland D110|Yamaha TX802|Pre-MIDI stuff...
cubic13 is offline   Reply With Quote
Old 10-07-2018, 08:10 AM   #65
_Stevie_
Human being with feelings
 
_Stevie_'s Avatar
 
Join Date: Oct 2017
Posts: 2,639
Default

Thanks for explaining! Makes sense, now. I just wanted to ask for the reasons behind it.

In film scoring we are using a lot of signature and tempo changes, that's why I mentioned it.
__________________
My Reascripts forum thread | My Reascripts on GitHub | Stephan R÷mer - film composer
If you wish to donate for my scripts: please consider an organization like: animal shelter, doctors without borders, UNICEF, etc...
_Stevie_ is offline   Reply With Quote
Old 10-08-2018, 07:37 AM   #66
hopi
Human being with feelings
 
hopi's Avatar
 
Join Date: Oct 2008
Location: Right Hear
Posts: 14,942
Default

Cubic ...you are the most excellent, clear and complete person of all time... thanks so much for all you do... off to get the update
__________________
...should be fixed for the next build... http://tinyurl.com/cr7o7yl
https://soundcloud.com/hopikiva/angel-rain
hopi is offline   Reply With Quote
Old 10-09-2018, 03:53 AM   #67
tzzsmk
Human being with feelings
 
Join Date: Oct 2016
Location: Prague
Posts: 93
Default

hi, for some reason I am not able to color tint the mixer panel tracks, any idea what needs to be configured in preferences? thx in advance
EDIT: nevermind, seems to be fixed with latest zip file on stash
__________________
High Sierra i7-5820K @4.3GHz, ASUS X99-S, 32GB DDR4, GTX980Ti Classified, 850 EVO 500GB, HDSPe AIO, Faderport, Seaboard RISE49, Eris E8, K240 MKII, U2713HM, MacBook Pro 13 Mid-2012 (i7, 16GB, 840 EVO 500GB, 1TB), Fireface UFX, Octamic D & II, DT-770 M, SE215-K

Last edited by tzzsmk; 10-09-2018 at 04:01 AM.
tzzsmk is offline   Reply With Quote
Old 12-12-2018, 03:37 AM   #68
cubic13
Human being with feelings
 
cubic13's Avatar
 
Join Date: Dec 2013
Location: Near Serre-Ponšon lake, french Alps
Posts: 831
Default v 1.50 is in the stash...

An added update. In this one :

1) A partial rewrite of the tcp management, changing the priority of some controls (in example, tcp.env over tcp.phase), especially when panels are only one row high.
2) An optimization of the envcp panels behavior.
3) A full rewrite of the two transport layouts, which allow the centering of all the controls whenever possible.
4) The addition of more than 40 toolbar icons with 4 alternate toolbars in which they are used.
5) Added graphical changes (selected tcp panels, envcp backgrounds, some theme tweaker colours...).

@users of previous versions : beside the theme itself, the content of the AltSelectedPanels folder root has also slightly changed.
__________________
DAW : i7-870|P7P55D-E|16 Gb|2 HDD 1 Tb|W7Pro SP1(64)|RME Fireface UCX + Behringer ADA8200
Soft : Reaper(64)|Cubase 5-6.5(64)|Emulator X3 & several other VSTis (2 bridged)...
Gear : VMK-188+|MPD32|ME30P|Korg 05R/W|Roland D110|Yamaha TX802|Pre-MIDI stuff...
cubic13 is offline   Reply With Quote
Old 01-07-2019, 03:13 AM   #69
MCV
Human being with feelings
 
Join Date: Mar 2009
Posts: 65
Default

Thanks for all the work cubic13! Excellent theme!

One thing I've found: there's no record button for "automatic record-arm when track selected", which is something I use all the time for my hardware synths. That is: a shade in the record button when the track is NOT selected, so you know that by selecting the track it'll be record-armed.

Other than that I just changed a few of the colors, for instance to have different background shades for odd and even tracks in the TCP background. I've been using the old RADO version of this theme up until now, but this one is so much better. Thanks!
MCV is offline   Reply With Quote
Old 01-09-2019, 01:03 AM   #70
cubic13
Human being with feelings
 
cubic13's Avatar
 
Join Date: Dec 2013
Location: Near Serre-Ponšon lake, french Alps
Posts: 831
Default

Hi, MCV and thanks for your comments...

Actually, there is an "automatic record-arm..." state for the record buttons, as in the original theme. All the states of this control are defined like following (record off / automatic record-arm / record on) :



... and it works for all the different layouts defined, here, excepting the 'folders', 'freezed' and 'separators' ones. This is by design, as I don't think that something should be directly recorded on either or these kind of tracks.

Could you post a screenshot showing the issue ? Thanks in advance.
__________________
DAW : i7-870|P7P55D-E|16 Gb|2 HDD 1 Tb|W7Pro SP1(64)|RME Fireface UCX + Behringer ADA8200
Soft : Reaper(64)|Cubase 5-6.5(64)|Emulator X3 & several other VSTis (2 bridged)...
Gear : VMK-188+|MPD32|ME30P|Korg 05R/W|Roland D110|Yamaha TX802|Pre-MIDI stuff...
cubic13 is offline   Reply With Quote
Old 01-09-2019, 03:13 AM   #71
MCV
Human being with feelings
 
Join Date: Mar 2009
Posts: 65
Default

Hi cubic13, thanks for your reply!

You're right, there is a difference, I realize now! So I'm thinking it's just not visually striking enough of a difference for me to see without paying close attention.

I'll try to change it to a different color myself! Will let you know.

Thanks!
MCV is offline   Reply With Quote
Old 01-09-2019, 04:48 PM   #72
MCV
Human being with feelings
 
Join Date: Mar 2009
Posts: 65
Default

I tried, but I haven't been able to do it. I'm no designer!
MCV is offline   Reply With Quote
Old 01-12-2019, 01:16 AM   #73
cubic13
Human being with feelings
 
cubic13's Avatar
 
Join Date: Dec 2013
Location: Near Serre-Ponšon lake, french Alps
Posts: 831
Default

The files involved are the following :

mcp_recarm_auto.png
mcp_recarm_auto_on.png
track_recarm_auto.png
track_recarm_auto_on.png


...without forgetting the instances of these that are also present in the different layouts subfolders. Basically, each file has three views of the involved control : the main one on the left, visible when no interaction occurs, the one in the middle that appears when the user hover the mouse cursor above it, and the one on the right, appearing when the control is clicked.

From which, you need an image editor (such as Paint.NET, Gimp, photoshop... - I use the former for 95% of my work, as I'm so at ease with it) which is able to edit PNG files and their transparency layer. The procedure is the following :

1) Make a copy of the CRado.ReaperThemeZip file in a safe place (outside the \ColorThemes subfolder of your Reaper installation).
2) Change its extension to .zip and unzip it : you should get both a CRado.ReaperTheme file and a CRado folder which contains the files listed above.
3) Edit the different instances of these files as wanted, with your image editor.
4) Rezip again BOTH CRado.ReaperTheme file and CRado folder together and change the resulting archive extension to .ReaperThemeZip.
5) Replace the existing theme with this new version in the \ColorThemes subfolder of your Reaper installation.

HTWH... If not, let me know with a screenshot the exact tint you would like for the "automatic record-arm" state of the record button.
__________________
DAW : i7-870|P7P55D-E|16 Gb|2 HDD 1 Tb|W7Pro SP1(64)|RME Fireface UCX + Behringer ADA8200
Soft : Reaper(64)|Cubase 5-6.5(64)|Emulator X3 & several other VSTis (2 bridged)...
Gear : VMK-188+|MPD32|ME30P|Korg 05R/W|Roland D110|Yamaha TX802|Pre-MIDI stuff...
cubic13 is offline   Reply With Quote
Old 01-14-2019, 05:41 AM   #74
blackiyto
Human being with feelings
 
Join Date: Jan 2019
Posts: 4
Default

there is an "automatic record-arm..." state for the record buttons?
Tutuapp 9apps Showbox

Last edited by blackiyto; 01-24-2019 at 02:12 PM.
blackiyto is offline   Reply With Quote
Old 01-15-2019, 10:58 AM   #75
dupont
Human being with feelings
 
dupont's Avatar
 
Join Date: Nov 2007
Location: France
Posts: 559
Default

good theme but I miss Reaper 5 minimal tcp where the volume is a knob instead of a slider.
Usefull for small screen and when the tracks are minimized.
Also is it possible to avoid the idents for tcp inside a folders ?
dupont is offline   Reply With Quote
Old 01-16-2019, 12:36 AM   #76
cubic13
Human being with feelings
 
cubic13's Avatar
 
Join Date: Dec 2013
Location: Near Serre-Ponšon lake, french Alps
Posts: 831
Default

Quote:
Originally Posted by dupont View Post
good theme but I miss Reaper 5 minimal tcp where the volume is a knob instead of a slider.
Usefull for small screen and when the tracks are minimized.
Also is it possible to avoid the idents for tcp inside a folders ?
Hmmm... I have kept the volume controls as they were working on the original theme. I just got rid of the 'endless stretching' behavior which for me was horrible. Beside this, I just reshaped a little the knob - when the tcp panel is narrowed, either horizontally or vertically - making it smaller. I'm not sure that I want to change this, but maybe I could add layouts with only knobs as volume controls, but it's going to take me a while...

Concerning the 'idents', I guess that you are talking about the indentation for the controls alignment that should have been kept between a track folder and its children, as in the original RADO theme. If so, I'll take a look to see what I can quickly do about it, as I'm working on other themes presently.

Stay tuned...

----------------------------------
Update after having looked further...

1) Concerning the indentation, I see again why I aligned vertically all the tcp controls, folders or not :
- First, it was to allow the display of BOTH the tcp.foldercomp (the control that allow the predefined vertical redimensioning of a folder children tracks) and the tcp.trackidx (the track index) controls in a folder track.
- Second, it was to prevent the too early truncation of the tcp label when a track was in a folder.
I don't know how to keep these two fixes along with a reimplementation of a controls indentation for a folder track. So, it will stay as it is, at least for now, as I still think that it's better than what was in the original theme.

2) About the knobs as volume controls, I might take a closer look at it in a while, but I'm afraid that there is no easy way to implement them, as there are already ten layouts that would need a duplication and a partial rewrite : too much hassle for a very tiny gain, as the volume controls are already displayed as knobs when the tcp panel is narrowed either horizontally or vertically.

Sorry not being able to help more...
__________________
DAW : i7-870|P7P55D-E|16 Gb|2 HDD 1 Tb|W7Pro SP1(64)|RME Fireface UCX + Behringer ADA8200
Soft : Reaper(64)|Cubase 5-6.5(64)|Emulator X3 & several other VSTis (2 bridged)...
Gear : VMK-188+|MPD32|ME30P|Korg 05R/W|Roland D110|Yamaha TX802|Pre-MIDI stuff...

Last edited by cubic13; 01-16-2019 at 01:49 AM.
cubic13 is offline   Reply With Quote
Old 01-16-2019, 03:08 AM   #77
dupont
Human being with feelings
 
dupont's Avatar
 
Join Date: Nov 2007
Location: France
Posts: 559
Default

@Cubic13

As you can sse on the pictures, with Crado theme TCP must be stretched far more than reaper 5 theme until I can see the volume knobs.

https://drive.google.com/open?id=1_g...MylV8Pf1iAFSh8
https://drive.google.com/open?id=1kB...q_Mp22dhEipjgd

Thank anyway for your reply.
dupont is offline   Reply With Quote
Old 01-19-2019, 12:35 AM   #78
sightlessness
Human being with feelings
 
sightlessness's Avatar
 
Join Date: Mar 2010
Posts: 907
Default

Cubic13 you rock man. I got my fave themes plus other ones that I didn't like too much
(including some of yours, sorry, gets better afterwards in my comments, is just some elements didn't convince me at Full HD but... keep on reading below :P).

And guess what?

EyssinaAM, omg, looks STELLAR on my 55" Oled 4k TV (I am telling this everywhere,
but it's not with the intention of strutting around, but to state the circumstance
I am testing this).

Have Windows scaling at 250%, and no scaling within Reaper. Omg, lots of real estate,
and now your theme, speacially the MCP, looks amazing!

Some of your other themes look great, and others' themes' too. Logic one by you
looks great too. Bad thing is now I have lots of choices, lol.

I used to love Cubase and this theme rocks (I would work a little bit more on the TCP),
still, just letting you know, and thanking you.

Have a great life.
__________________
I want to live PEACEFULLY PLEASE WORLD "LEADERS" GET THIS DONE/LET IT BE FOR GOOD AND MAKE HISTORYYYYYYY! Thanks.
sightlessness is offline   Reply With Quote
Old 01-19-2019, 12:44 AM   #79
cubic13
Human being with feelings
 
cubic13's Avatar
 
Join Date: Dec 2013
Location: Near Serre-Ponšon lake, french Alps
Posts: 831
Default

@dupont
Ok, so it's more about the placement of the volume control than its shape. I first thought that you wanted a knob for the volume control in all cases.

I'll see what I can do about this, the problem is that placing the volume knob near the track label means either changing the pan/width knobs placement or reducing the label width - and I know some users need a rather wide label control for complex/orchestral project tracks naming.

If I find something acceptable, I'll upload an update in few weeks.
__________________
DAW : i7-870|P7P55D-E|16 Gb|2 HDD 1 Tb|W7Pro SP1(64)|RME Fireface UCX + Behringer ADA8200
Soft : Reaper(64)|Cubase 5-6.5(64)|Emulator X3 & several other VSTis (2 bridged)...
Gear : VMK-188+|MPD32|ME30P|Korg 05R/W|Roland D110|Yamaha TX802|Pre-MIDI stuff...
cubic13 is offline   Reply With Quote
Old 01-19-2019, 12:48 AM   #80
cubic13
Human being with feelings
 
cubic13's Avatar
 
Join Date: Dec 2013
Location: Near Serre-Ponšon lake, french Alps
Posts: 831
Default

@sightlessness
Thanks a lot for your feedback...

And guess what ? When I was answering few days ago @dupont about my present theming work, I was actually talking about the CubicPack content. So stay tuned, as I'm planning an update for it in the weeks to come.

Thanks again...
__________________
DAW : i7-870|P7P55D-E|16 Gb|2 HDD 1 Tb|W7Pro SP1(64)|RME Fireface UCX + Behringer ADA8200
Soft : Reaper(64)|Cubase 5-6.5(64)|Emulator X3 & several other VSTis (2 bridged)...
Gear : VMK-188+|MPD32|ME30P|Korg 05R/W|Roland D110|Yamaha TX802|Pre-MIDI stuff...
cubic13 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:58 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.