Old 01-14-2019, 03:59 AM   #1
dodika
Human being with feelings
 
Join Date: Jan 2019
Posts: 3
Default VST3 Scan Problem

Hi everyone,

I'm new to the forum, so I apologize if I'm posting in the wrong place...never used a forum before, haha.

I have recently run into an issue on Reaper and wondered if someone could help me out.
I've searched the forum for an answer, but I couldn't seem to find a thread on this particular issue.

I've managed to mess up Reaper on two different computers in the exact same way, so I must be doing something wrong (or right, depending on how you look at it). I use EastWest Play 6 for most of my projects. I also use CCleaner to speed up my system (I've read that's a bit outdated, but it works for me).
As far as I can tell, this is what happened both times: I used CCleaner before using Reaper. Then I loaded Reaper, started a project and loaded instruments into Play. Then out of nowhere, I get the 'Your PC has run into a problem' blue screen.

When I restart, Reaper works fine, all my other VSTs work fine, except for Play. Reaper doesn't want to load it and tells me there's something wrong with the VST files. This is true for both Play VSTi and VST3.

Now here's the weird part. If I just re-scan/clear cache for the VSTs, Reaper runs into the same problem. However, if I mess around a bit with the VST compatibility check boxes underneath (doesn't seem to matter which one, which is even weirder) and exit preferences, load preferences again and THEN re-scan/clear cache, Play is suddenly working and I can load everything just fine.

When I exit Reaper, and load it again, I have to go through this process again for Play to work.

I'm not an expert at computers, so I won't hazard a guess as to what's gone wrong, but it seems to me that both Reaper and Play work fine, but there must be some bug in the system that's causing them not to communicate properly. Could my use of CCleaner be the problem? Or is it a weird memory problem?

Is there any way to fix this?

Thanks in advance!
D
dodika is offline   Reply With Quote
Old 01-14-2019, 05:43 AM   #2
DarkStar
Human being with feelings
 
DarkStar's Avatar
 
Join Date: May 2006
Location: Surrey, UK
Posts: 17,791
Default

Duplicate thread; continued over here:
https://forum.cockos.com/showthread.php?t=215994
__________________
DarkStar ... interesting, if true. . . . Inspired by ...
DarkStar is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:51 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.