Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for Linux

Reply
 
Thread Tools Display Modes
Old 07-09-2020, 10:01 PM   #1
paulbee
Human being with feelings
 
Join Date: Jul 2020
Posts: 7
Default How to get Reaper to see MIDI events from an M-Audio Audiophile USB box

I have a Midipro midi keyboard controller connected to a mobo USB port on my Ubuntu 20.04 machine via an old M-Audio audiophile USB box. This hardware setup works fine with various standalone softsynths, and I can see midi events as expected with aseqdump. But when I select and enable the device in Reaper (v6.12c), even though Reaper sees it as hw:USBtm, and also knows whether it's turned off or on, it's either ignoring or not receiving any of the midi events from this input. Or actually it must be receiving *something* because when I hit a key on the midi keyboard, a small white square appears in the VU meter -- but it doesn't trigger any sound. (The virtual keyboard also produces the same white square when I hit a virtual key, but it also produces the expected note.)

For reference, the virtual keyboard works fine. (Is there perhaps a way of routing the physical hardware midi events into Reaper through the virtual keyboard?...)

I'm also getting 'good' across the board from all the realTimeConfigQuickScan tests.

Can anyone tell me what I might be missing or doing wrong? Or maybe if there's a workaround?

Last edited by paulbee; 07-09-2020 at 10:34 PM.
paulbee is offline   Reply With Quote
Old 07-09-2020, 11:00 PM   #2
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 4,690
Default

If both look like midi data is coming in, could the midi channel be in play?
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 07-09-2020, 11:30 PM   #3
paulbee
Human being with feelings
 
Join Date: Jul 2020
Posts: 7
Default

Quote:
Originally Posted by Glennbo View Post
If both look like midi data is coming in, could the midi channel be in play?

Thanks for the suggestion. So, I have a TyrellN6 track set to: all midi inputs, all midi channels, which I think should mean that all channels should work, right? In any case, what I find is, I can switch to different channels on the virtual keyboard, and they all work. Conversely, whichever different channel I switch to on the minipro keyboard, I don't seem to get anything out of any of them.

In another update, the white square in the VU meter is no longer appearing in response to hardware input. I'm not sure what I did to disable it -- or to make it appear in the first place either :-( Sorry, I'm very new to this Reaper software and I'm kinda lost...
paulbee is offline   Reply With Quote
Old 07-10-2020, 05:09 AM   #4
DarkStar
Human being with feelings
 
DarkStar's Avatar
 
Join Date: May 2006
Location: Surrey, UK
Posts: 18,530
Default

The white (or coloured, depending on the theme) indicated incoming MIDI. If you have not disabled it, then no square = no MIDI received.

Look at Preferences / Appearance / Track Control Panels "Show MIDI outpu7 activity ..." ("Output from where I do not know, is that a typo?).

Also check the list in the User Guide, at 3.41.
__________________
DarkStar ... interesting, if true. . . . Inspired by ...
DarkStar is online now   Reply With Quote
Old 07-10-2020, 07:08 AM   #5
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 4,690
Default

Might be worth looking in "Options|Preferences|Midi Devices" to verify your midi device shows up there and is flagged as enabled.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 07-10-2020, 07:54 AM   #6
paulbee
Human being with feelings
 
Join Date: Jul 2020
Posts: 7
Default

Thanks guys.

Yup, the 'show midi output activity' box is checked. And everything on the 3.41 checklist is fine too as far as I can tell.

The midi device is showing up on the midi devices popup, and it's enabled.

What I have found though is that if I power up the keyboard and M-audio box, then start reaper and then aconnect 28 128 (where 28 is the midi keyboard irq and 128 is 'virtual rawmidi', which in fact is evidently reaper), then the midi keyboard works! Ie it sends midi data to the appropriate track just like it ought to.

So I guess that's my workaround unless anyone has anything better? I have to say though that something must be very wrong if this is the only way I can get reaper to listen to the midipro/M-audio input! (fwiw if I do a midi reset or retry, the hardware keyboard is immediately lost, and I have to do another aconnect 28 128 to get it working again. This method also appears to completely bypass Reaper's midi dialog settings; hw:USBtm can be enabled or disabled and it makes no difference, the aconnect trick still works -- although ironically, if hw:USBtm *is* enabled I get an error that says the hardware is missing -- ironic because this kludge seems to be the only way I can get reaper to actually respond to it!)

Last edited by paulbee; 07-10-2020 at 08:00 AM.
paulbee is offline   Reply With Quote
Old 07-10-2020, 09:49 AM   #7
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 4,690
Default

Quote:
Originally Posted by paulbee View Post
What I have found though is that if I power up the keyboard and M-audio box, then start reaper and then aconnect 28 128 (where 28 is the midi keyboard irq and 128 is 'virtual rawmidi', which in fact is evidently reaper), then the midi keyboard works! Ie it sends midi data to the appropriate track just like it ought to.
All audio and midi interfaces need to be powered up before REAPER gets launched. I use a Behringer UMC1820 audio interface and my MidiMan Keystation 61 midi keyboard is plugged into it with a standard 5-pin midi cable.

If I start REAPER and the UMC1820 isn't on, I get a big warning message that the audio device isn't working. I can power it up, and get audio working by re-selecting my audio device, but midi will never be seen correctly doing it that way, so I always make sure the UMC1820 is powered up before starting REAPER.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 07-13-2020, 02:51 AM   #8
paulbee
Human being with feelings
 
Join Date: Jul 2020
Posts: 7
Default

Thanks Glennbo!

What I've found is that the order of starting doesn't seem to matter when I use aconnect. All that matters is that both reaper and the midi keyboard need to be running/switched on when I use the aconnect command.

Anyway, I've now moved on to the next issue -- how to get reaper to work with VSTs... I couldn't get anywhere at all with LinVST or airwave, so I've been trying Carla -- which I've managed to get it working as a standalone, and Reaper can see it too, but unfortunately, when I load carla in reaper, I just get to see a bank of sliders instead of the expected carla GUI. So I'm kind of stuck once again. Anyway, I'll start a separate thread.
paulbee is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:22 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.