Old 02-26-2012, 03:05 PM   #1
Ohmu
Human being with feelings
 
Join Date: Feb 2012
Posts: 3
Default MIDI output offset problem? v4.15 OSX 10.5 PPC

Hello, new user here so apologies in advance..

I'm running Reaper version 4.15 on OSX Leopard on a G5 PPC with an Mbox2 interface.

I'm encountering a problem when I try to offset a MIDI output to a negative figure. If I leave the offset as 0ms or increase it to +10ms or +20ms it works as expected with the midi being sent from the MIDI out port of my mbox2 being slightly delayed versus the rest of the tracks within reaper. But when I change the offset to a negative number (e.g -4ms) I get nothing at all. By that I mean nothing from the MIDI output, as if it is muted. When i set it back to 0 or a positive value the MIDI appears again.

Could someone tell me - Am I using this feature incorrectly or is this a bug?

I'm trying to compensate from the slight audio latency I get when using an external midi device, in this case it's a pc running Emu Emulator X3.

thanks in advance,

Al
Ohmu is offline   Reply With Quote
Old 02-26-2012, 04:39 PM   #2
Ollie
Super Moderator (no feelings)
 
Ollie's Avatar
 
Join Date: Dec 2007
Location: On or near a dike
Posts: 9,739
Default

Welcome to the forum!

Alas REAPER can't send MIDI before audio, but if you increase the audio buffers/latency ('block size' in REAPER, Preferences->Audio->Device) to delay the audio by the amount you need to compensate, this should give you the needed "wiggle room" in the negative range of the MIDI output offset box.
Ollie is offline   Reply With Quote
Old 02-27-2012, 05:50 AM   #3
Ohmu
Human being with feelings
 
Join Date: Feb 2012
Posts: 3
Default

thanks for your reply!

I'm wondering if it will add extra problems like adding more monitoring delay for any vsti's running in reaper? I'll give this a try tonight.
Ohmu is offline   Reply With Quote
Old 02-27-2012, 09:37 AM   #4
Ollie
Super Moderator (no feelings)
 
Ollie's Avatar
 
Join Date: Dec 2007
Location: On or near a dike
Posts: 9,739
Default

More latency will introduce monitoring delay for plug-ins/instruments hosted in REAPER when you play them live.
Ollie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:08 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.