Old 10-07-2019, 04:03 AM   #1
Stirner
Human being with feelings
 
Join Date: Oct 2019
Posts: 16
Default Crashes with 96kHz sample rate?

What can be the reason that Reaper crashes when switching the project's sample rate to 96 kHz?
I can reproduce it even with a new empty project. If I change the sample rate on my soundcard's settings it doesn't crash. But reloading this project crashes again.
My soundcard is Focusrite Scarlet 2i2 (2nd Gen).
If soundcard is set at 48kHz - switching sample rate in Reaper -> crash.
Soundcard set at 96kHz - switching sample rate from 48kHz to 96kHz -> no crash.
Soundcard set at 96kHz - loading a 96kHz project -> crash.

It seems that Reaper can downgrade the sample rate without problems, but upgrade leads to a crash.

I have the newest drivers installed and in Cubase I can switch the project's sample rate without any problems.
Stirner is offline   Reply With Quote
Old 10-07-2019, 08:36 AM   #2
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 8,386
Default

You have the option in Reaper to control your connected audio interface from the Reaper control panel (Reaper Preferences/Audio/Device page) or another app like your OS audio control panel or a 3rd party control panel app.

Using the DAW control panel is always the first choice. (Other DAW apps only give you this option.) You can disable control of sample rate and block size from Reaper by unticking the boxes next to them on the Audio/Device page and use your OS control panel or a 3rd party control panel. Try this only if the interface doesn't play nice with Reaper.

If you are using multiple audio interfaces together (like a pci soundcard interface + a USB interface) you need to make an aggregate device configuration with your OS audio control panel app and select that as your interface in the DAW app. You also need to run multiple digital devices from the same sample rate clock. This is especially touchy with HD sample rates.

Any of that shine a light on anything?
serr is online now   Reply With Quote
Old 10-07-2019, 08:59 AM   #3
Stirner
Human being with feelings
 
Join Date: Oct 2019
Posts: 16
Default

Yep, that helped.
Preferences/Audio/Device -> ASIO configuration - Focusrite settings - set to 96kHz. Uncheck "Request sample rate" to enable "soundcard default audio rate is used"-setting. And uncheck "Allow projects to override device sample rate". Project saving and loading works without crashes.
This means though, that the sample rate cannot be set independently per project in Reaper, but is always overriden by soundcard settings. Not optimal but it seems to work.
Thank you for the advice.
Stirner is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:50 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.