Old 07-27-2014, 03:36 PM   #1
lomby82
Human being with feelings
 
Join Date: Jul 2014
Posts: 6
Default 96k recording help!

Hi There,
I'm new on this forum and hope you can help me. I am trying to record (via madi) 130ch at 96k, but we have glitches when we playback. Tried on new macbook pro on thunderbolt drive and an iMac with SSD drives. Both good up to around 100ch, but can't go more then that. Anybody could suggest what I need to have it bullet proof?
Thanks
lomby82 is offline   Reply With Quote
Old 07-28-2014, 02:24 AM   #2
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: Berlin
Posts: 10,547
Default

You should try posting this with as much detail of your setup as possible, in the OSX forum section.

That way a lot of OSX users will see it.

The other place to start with for greatest exposure is the General forum section.

Be sure to include which audio interface you're using, version of OSX, drivers, Reaper and what latency your interface is set to while recording and playing.

130 channels is a lot of data to get from the drives. One immediate tip I can offer is to increase the MEDIA BUFFER SIZE in the preferences of Reaper. Preferences / Audio section / Buffering . That might do it.

You could also increase the BLOCK size of your core audio driver for the audio interface you're using. Not sure where that is all handled on OSX versions though. I use Windows. I'd visit the Project Settings and then check the actual driver settings in the system preferences sound-part of OSX.
__________________
Dialogue/FX Editor & Re-Recording Mixer
(Video)Using Latch Preview
"My ego comes pre-shrunk" - Randy Thom
airon is offline   Reply With Quote
Old 07-28-2014, 06:23 AM   #3
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 8,825
Default

The issue isn't likely the data transfer abilities from your drives. That's actually not the weak point for this. (Obviously this is not trivial either but it sounds like you have this part well covered.)

Anything over 100 tracks at high def sample rates and Reaper gets heavy audio threads and has a little trouble getting out of the way of itself. (Or so this is starting to appear to me. Other DAW's have this issue as well BTW.)

For playback (or even recording where real-time live sound monitoring is not needed), increase the disc buffer size to 1024 or even 2048 to give Reaper some room to work. Preferences/Audio/Device -> Request block size. Check the box and enter the number.

See this post for more: http://forum.cockos.com/showpost.php...5&postcount=40
serr is online now   Reply With Quote
Old 07-28-2014, 06:23 AM   #4
TimOBrien
Human being with feelings
 
Join Date: Jun 2007
Posts: 2,301
Default

At 96k and 130+ tracks, you're probably going to have to split playback onto 2 drives.

There's only so much data a drive can stream.

Not uncommon among orchestrators who work with hundreds of tracks to have to do that.
__________________
iMac i5quad/12gbRAM/1Tb Glyph drive/1Tb samples drive > Motu828mkII ---- Still run my GatewayM520 2.8ghz XP laptop. Video editing, 3D work and audio with zero problems.
TimOBrien is offline   Reply With Quote
Old 07-28-2014, 07:09 AM   #5
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 8,825
Default

Quote:
Originally Posted by TimOBrien View Post
At 96k and 130+ tracks, you're probably going to have to split playback onto 2 drives.

There's only so much data a drive can stream.

Not uncommon among orchestrators who work with hundreds of tracks to have to do that.
Isn't 100 tracks of 24/96 about 28MB/s?
The SSD would have a read speed around 500MB/s
The SATA bus is 6GB/s

Obviously there's still the access time for each file to consider. How does the math work on that part?
serr is online now   Reply With Quote
Old 07-28-2014, 09:04 AM   #6
lomby82
Human being with feelings
 
Join Date: Jul 2014
Posts: 6
Default

Guys first of all thank you to take your time on this thread.

My Mac:

Mac Pro
Processor: 3.2 Ghz Quad Core
Memory: 24 GB 1066 MHz DDR3 ECC

Madi out of a live mixing desk going into 2x Waves Digigrid MGB.

I installed 2x SSD drives and split the recorded channels into two different drives but NO luck.

I tried to go to Audio/Buffering and change Media buffer size from 1200 to 6000 and Media Buffer size from 200 to 1048 but not luck.

Did not changed it into "device" page yet. Will do as soon as I can.

Hope this is more clear now...
lomby82 is offline   Reply With Quote
Old 07-28-2014, 11:05 AM   #7
TimOBrien
Human being with feelings
 
Join Date: Jun 2007
Posts: 2,301
Default

Quote:
Originally Posted by serr View Post
Isn't 100 tracks of 24/96 about 28MB/s?
Actually 3mb/s PER TRACK, so more like 10x that....

It's a LOT of data moving there.
__________________
iMac i5quad/12gbRAM/1Tb Glyph drive/1Tb samples drive > Motu828mkII ---- Still run my GatewayM520 2.8ghz XP laptop. Video editing, 3D work and audio with zero problems.
TimOBrien is offline   Reply With Quote
Old 07-28-2014, 01:17 PM   #8
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 8,825
Default

Quote:
Originally Posted by TimOBrien View Post
Actually 3mb/s PER TRACK, so more like 10x that....

It's a LOT of data moving there.
24 bits (3 bytes) X 96k/s X 100 (tracks) = 28.1MB/s

Yes?
serr is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:23 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.