Old 12-19-2019, 09:13 AM   #41
b0se
Human being with feelings
 
b0se's Avatar
 
Join Date: Jan 2019
Location: UK
Posts: 890
Default

Transport finished...



Very happy with that. Kept it colourless as to work with other icons or people's own theme colour changes.

Time to see if I can push the loop button to the end.

P.S. Phelix - realised why it's GBY - I was used to that from Mordi's (then my) Fusion mod :¬) I'll keep it for now, more important things to finish first.
b0se is offline   Reply With Quote
Old 12-19-2019, 09:22 AM   #42
synkrotron
Human being with feelings
 
synkrotron's Avatar
 
Join Date: May 2015
Location: Warrington, UK
Posts: 1,122
Default

Excellent
__________________
Bandcamp // YouTube // SoundCloud
synkrotron is offline   Reply With Quote
Old 12-19-2019, 09:49 AM   #43
b0se
Human being with feelings
 
b0se's Avatar
 
Join Date: Jan 2019
Location: UK
Posts: 890
Default

Much better!



Mono button, then sends/FX list...
b0se is offline   Reply With Quote
Old 12-19-2019, 09:55 AM   #44
Alez156
Human being with feelings
 
Alez156's Avatar
 
Join Date: Jun 2015
Location: Venezuela
Posts: 82
Default

YOU ARE SO AWESOMEEEEE B0SE. I check out this thread a lot to check your progress <3
__________________
OSX 10.14.6 MacBook Pro (Retina, 15-inch, Mid 2014)
-
🔴 Daily REAPER Tips on Instagram
Alez156 is offline   Reply With Quote
Old 12-19-2019, 12:27 PM   #45
Gavinchan
Human being with feelings
 
Join Date: Mar 2013
Posts: 70
Default

Slick!
Gavinchan is offline   Reply With Quote
Old 12-19-2019, 01:34 PM   #46
b0se
Human being with feelings
 
b0se's Avatar
 
Join Date: Jan 2019
Location: UK
Posts: 890
Default

FX/Send lists done. FX inserts and sends are different functions, so I've used different designs for each (always found it odd that FX/send lists used the same design):



Circular for sends since that's the V6 design (that I love) for showing the dB value (along with background). Mono button in the style of env/automation:



Getting close now, just some finishing touches.

@White Tie or other experienced themers - I'm designing this using the 'extracted' approach (rtheme and IMG DIR live in the ColorThemes DIR for quick editing); nothing I change (fonts) via the theme editor work. Is that normal? Do they only work if using a *.reaperThemeZip?
b0se is offline   Reply With Quote
Old 12-19-2019, 02:22 PM   #47
lucas_LCS
Human being with feelings
 
Join Date: Dec 2015
Posts: 1,081
Default

Excellent work, b0se.
looking forward to finished theme.

Quote:
Originally Posted by b0se
nothing I change (fonts) via the theme editor work. Is that normal? Do they only work if using a *.reaperThemeZip?
changes in the tweaker should work with the unpacked theme.
Changes will be lost on the next refresh unless they're saved.
If you cannot get the fonts to change at all, there maybe something (script?) overriding your changes
Hopefully White Tie or someone can provide a clue as to what the cause may be. changing.

::

Last edited by lucas_LCS; 01-04-2020 at 07:58 PM. Reason: typo
lucas_LCS is online now   Reply With Quote
Old 12-19-2019, 03:07 PM   #48
nait
Human being with feelings
 
nait's Avatar
 
Join Date: Jun 2018
Location: Edmonton, AB, Canada
Posts: 711
Default

Hey b0se, I have no idea what will be involved for me to make this work in 1080p, but thank you for your offer to send the PSD. Whenever you're done, I'll definitely give that a go. I definitely know my way around Photoshop well, but not sure if there will be a lot of work in the theme to get that going with different sized images. Any idea? (I mean, yes or no as to whether it will require a lot of code changing, in your opinion).


Also, this thing is looking better and better. I love your art style. Very simple looking, in a way, but also quite sharp and pro. Exactly what I'd like to see.

Also, I think lucas_LCS is exactly right on your issue, sounds like you forgot to save your theme. You MUST save the theme manually after adjustments in the theme tweaker. And packed or unpacked won't make a diff.
__________________
My Rig (also serves as my gaming PC): Asus Z270A Prime Mobo, i7-6700k, 32GB RAM, Samsung 960 Evo 500gb NVMe, Crucial 1TB NVMe, NVidia GTX 1070, Focusrite Scarlett 2i2, Nektar Impact LX25+ MIDI Controller Keyboard.
nait is offline   Reply With Quote
Old 12-19-2019, 03:49 PM   #49
Xaviez
Human being with feelings
 
Join Date: May 2016
Posts: 43
Default

Wow thats one gorgeous looking theme! Hope to see a 1080p version release! Great work @b0se
Xaviez is offline   Reply With Quote
Old 12-19-2019, 04:22 PM   #50
SmajjL
Human being with feelings
 
SmajjL's Avatar
 
Join Date: Nov 2013
Location: Sweden
Posts: 2,230
Default

Think Bespoke pans was a clever design indea of using the thin lines, and just happens.. to be a theme by WT

Looks nice dude!

Lots of ideas here and many is free beer.
https://www.g200kg.com/en/webknobman/gallery.php
__________________
:)

Last edited by SmajjL; 12-19-2019 at 04:28 PM.
SmajjL is offline   Reply With Quote
Old 12-19-2019, 06:19 PM   #51
Delucci
Human being with feelings
 
Join Date: May 2017
Posts: 186
Default

Wow, this is getting pretty cool!
Delucci is online now   Reply With Quote
Old 12-20-2019, 12:12 AM   #52
+NRG
Human being with feelings
 
+NRG's Avatar
 
Join Date: Aug 2014
Posts: 655
Default

Excellent work!
__________________
“Where words fail, music speaks”
+NRG is offline   Reply With Quote
Old 12-20-2019, 02:09 AM   #53
b0se
Human being with feelings
 
b0se's Avatar
 
Join Date: Jan 2019
Location: UK
Posts: 890
Default

Quote:
Originally Posted by White Tie View Post
I'm afraid not. It Scales the length but not the width; this is just one of the things that hasn't been got to yet.

There are very sensible practical arguments for using the code pointers in the default theme, but I would suggest there are very few arguments for anyone else using them. Use a bitmap stack and never look back
Hey man. Encountered a bug - any font changes I make via the theme tweaker are instantly overridden. Changing the timeline font for example, I see it change for a split second when I press OK to close font window, but it reverts straight back.

Not sure if it's related, but there is also no font listed when I double click to open/change:



I notice in rtconfig it says the WALTER fonts are Calibri. I don't have that installed as I'm on OSX, that's a Windows creation if I recall correctly.

Edit: some fonts work (very few), and if they do, I still can't change the size or weight. Always big, always bold.

Any ideas?

Back to the theme - fixed a bug and tweaked the FX/sends slightly:



I'll make some MIDI changes while waiting to see what the problem is with the fonts.
b0se is offline   Reply With Quote
Old 12-20-2019, 02:16 AM   #54
b0se
Human being with feelings
 
b0se's Avatar
 
Join Date: Jan 2019
Location: UK
Posts: 890
Default

Quote:
Originally Posted by lucas_LCS View Post
Excellent work, b0se.
looking forward to finished theme.


changes in thweaker should work with the unpacked theme.
Changes will be lost on the next refresh unless they're saved.
If you cannot get the fonts to change at all, there maybe something (script?) overriding your changes
Hopefully White Tie or someone can provide a clue as to what the cause may be. changing.

::
Thanks Lucas. It's most certainly a bug. Happening with the default V6 theme also.

Quote:
Originally Posted by nait View Post
Hey b0se, I have no idea what will be involved for me to make this work in 1080p, but thank you for your offer to send the PSD. Whenever you're done, I'll definitely give that a go. I definitely know my way around Photoshop well, but not sure if there will be a lot of work in the theme to get that going with different sized images. Any idea? (I mean, yes or no as to whether it will require a lot of code changing, in your opinion).

Also, this thing is looking better and better. I love your art style. Very simple looking, in a way, but also quite sharp and pro. Exactly what I'd like to see.
Cheers Nait :¬)

1080p (Scale 1x) version - no code changes necessary! It's just a matter of resizing the images by 50%. The only 'tricky' bit is making sure the stretch markers (yellow and fuscia pink 1px lines) are correct, they won't downscale properly.

You may need to adjust layer styles to accommodate, i.e. shadow depth, stroke width etc as they're set for 2x scale. Still, it would be much faster than designing a theme from scratch!

Quote:
Originally Posted by Xaviez View Post
Wow thats one gorgeous looking theme! Hope to see a 1080p version release! Great work @b0se
Quote:
Originally Posted by Delucci View Post
Wow, this is getting pretty cool!
Quote:
Originally Posted by +NRG View Post
Excellent work!
Thank you!
b0se is offline   Reply With Quote
Old 12-20-2019, 03:02 AM   #55
b0se
Human being with feelings
 
b0se's Avatar
 
Join Date: Jan 2019
Location: UK
Posts: 890
Default

More FX list tweaks. Looking sweet now!



Kinda like V6's default font colour for bypassed plugins - getting used to it. Might make it grey for the official release though so people can colour it how they want.
b0se is offline   Reply With Quote
Old 12-20-2019, 03:48 AM   #56
PhelixK
Human being with feelings
 
PhelixK's Avatar
 
Join Date: Mar 2019
Posts: 237
Default

@b0se, what font/label area are you trying to change?

In concern of font usage/drawing, the whole scenario is somewhat a mystery to me as well. Some fonts display as expected, other seem impossible to control.

and yes,
– in the case of v6 default, obviously it is designed to be used with the Calibri font, as defined within rtconfig.
– additionally some font styling and colors can be user-defined with theme tweaker, but not all apparently.
– furthermore certain rules for coloring and transparency are defined inside rt, eg. Pan labels.

For your information I have Calibri installed here on mac, but still I’m unable to change certain styles and definitions, so having the correct font isn’t necessary a solution.

Users that do not have the actual font installed on their system, will have a fall-back font displayed. In case of def.6, the fall-back is typically Helvetica or Arial, depending on platform and nearest family available.

Here’s an example of three different typefaces present in Def.6 and Helvetica that many users see as fall-back substitution:




On another note,
I have tried really hard to find out how to change the font used in the MCP VU meter peak readout, but still no luck. I believe there’s a problem since the peak readout is cropped in def.6 (def.5 doesn’t have it), and I notice this cropping is also present in your mock-up here:



The cropping can be avoided by changing label width and margins in, but unfortunately when I tried this myself, it pushes the narrow and extended view in mcp.

So,
If you, or someone have a solution how to redefine the vu meter font, or perhaps a better way of resizing the peak readout area, I would be very grateful since I’m a total theme-rookie myself. I’m not trying to pick on your fine work b0se, and sorry if this is too much OT and not in your concern ツ

.
Attached Images
File Type: png typefaces.png (40.6 KB, 843 views)
File Type: jpg cropped-peak-readout.jpg (8.5 KB, 839 views)
PhelixK is offline   Reply With Quote
Old 12-20-2019, 04:22 AM   #57
b0se
Human being with feelings
 
b0se's Avatar
 
Join Date: Jan 2019
Location: UK
Posts: 890
Default

Quote:
Originally Posted by PhelixK View Post
@b0se, what font/label area are you trying to change?

In concern of font usage/drawing, the whole scenario is somewhat a mystery to me as well. Some fonts display as expected, other seem impossible to control.

and yes,
– in the case of v6 default, obviously it is designed to be used with the Calibri font, as defined within rtconfig.
– additionally some font styling and colors can be user-defined with theme tweaker, but not all apparently.
– furthermore certain rules for coloring and transparency are defined inside rt, eg. Pan labels.

For your information I have Calibri installed here on mac, but still I’m unable to change certain styles and definitions, so having the correct font isn’t necessary a solution.

Users that do not have the actual font installed on their system, will have a fall-back font displayed. In case of def.6, the fall-back is typically Helvetica or Arial, depending on platform and nearest family available.

Here’s an example of three different typefaces present in Def.6 and Helvetica that many users see as fall-back substitution:




On another note,
I have tried really hard to find out how to change the font used in the MCP VU meter peak readout, but still no luck. I believe there’s a problem since the peak readout is cropped in def.6 (def.5 doesn’t have it), and I notice this cropping is also present in your mock-up here:



The cropping can be avoided by changing label width and margins in, but unfortunately when I tried this myself, it pushes the narrow and extended view in mcp.

So,
If you, or someone have a solution how to redefine the vu meter font, or perhaps a better way of resizing the peak readout area, I would be very grateful since I’m a total theme-rookie myself. I’m not trying to pick on your fine work b0se, and sorry if this is too much OT and not in your concern ツ

.
I want all the fonts to be Fira Sans :¬) Damn fine, and free:

https://www.fontsquirrel.com/fonts/fira-sans

At the very least, track names, inserts and transport. Check out how good this font looks for the time:



Can't get it to work. Frustrating!

I hope @White Tie is able to help, it's way above my technical understanding of Reaper themes. Same for the VU meter clipping bug.
b0se is offline   Reply With Quote
Old 12-20-2019, 04:39 AM   #58
b0se
Human being with feelings
 
b0se's Avatar
 
Join Date: Jan 2019
Location: UK
Posts: 890
Default

Code:
[REAPER]
ui_img=Smooth_6
tl_font=F3FFFFFF00000000000000000000000090010000000000000302012243616C6962726900742053616E73205365726966000000000000000000000000A1
mi_font=F5FFFFFF00000000000000000000000090010000000000000302012243616C6962726900742053616E73205365726966000000000000000000000000A3
lb_font=F5FFFFFF00000000000000000000000090010000000000000302012243616C6962726900742053616E73205365726966000000000000000000000000A3
lb_font2=F3FFFFFF00000000000000000000000090010000000000000302012243616C696272690020446C67000000000000000000000000000000000000000096
trans_font=F3FFFFFF00000000000000000000000090010000000000000302012243616C69627269004C696768740000000000000000000000000000000000000057
user_font2=F3FFFFFF00000000000000000000000090010000000000000302012243616C69627269000000000000000000000000000000000000000000000000005F
user_font4=F3FFFFFF00000000000000000000000090010000000000000302012243616C696272690030365F3635000000000000000000000000000000000000008F
user_font5=F0FFFFFF00000000000000000000000090010000000000000302012243616C69627269000000000000000000000000000000000000000000000000005C
user_font6=EFFFFFFF00000000000000000000000090010000000000000302012243616C69627269000000000000000000000000000000000000000000000000005B
user_font7=ECFFFFFF00000000000000000000000090010000000000000302012243616C696272690000000000000000000000000000000000000000000000000058
user_font10=EBFFFFFF00000000000000000000000090010000000000000302012243616C6962726900742053616E7320536572696600000000000000000000000099
user_font1=F4FFFFFF00000000000000000000000090010000000000000302012243616C696272690000000000000000000000000000000000000000000000000060
user_font3=F1FFFFFF00000000000000000000000090010000000000000302012243616C69627269004C696768740000000000000000000000000000000000000055
user_font12=E5FFFFFF00000000000000000000000090010000000000000302012243616C6962726900742053616E7320536572696600000000000000000000000093
user_font11=E8FFFFFF00000000000000000000000090010000000000000302012243616C6962726900742053616E7320536572696600000000000000000000000096
user_font8=FBFFFFFF00000000000000000000000090010000000000000302012243616C6962726900742053616E73205365726966000000000000000000000000A9
user_font13=E3FFFFFF00000000000000000000000090010000000000000302012243616C6962726900742053616E7320536572696600000000000000000000000091
How on earth do you change the fonts manually? :¬)

Looks like an encoded pointer to a system font. Shame you can't edit this like CSS with just font names, with backups, i.e.

tl_font: 'Minisystem', 'Fira Sans', 'Helvetica', 'sans-sefif'.
b0se is offline   Reply With Quote
Old 12-20-2019, 05:03 AM   #59
b0se
Human being with feelings
 
b0se's Avatar
 
Join Date: Jan 2019
Location: UK
Posts: 890
Default

Hmmm, it's a Reaper V6 problem. Can't change the timeline text on any theme, even V5.
b0se is offline   Reply With Quote
Old 12-20-2019, 05:33 AM   #60
SmajjL
Human being with feelings
 
SmajjL's Avatar
 
Join Date: Nov 2013
Location: Sweden
Posts: 2,230
Default

The theme development/tweaker (action/toolbar) has a save theme function, when you figure out what does what.
While you await WT for a more Pro-answer.
__________________
:)
SmajjL is offline   Reply With Quote
Old 12-20-2019, 05:37 AM   #61
PhelixK
Human being with feelings
 
PhelixK's Avatar
 
Join Date: Mar 2019
Posts: 237
Default

I just installed Fira Sans, then made copy of the . ReaperTheme file and wiped the font codes in the end.

Then changed Walter font description in rt, line 35-38,
Then used theme tweaker and set specific size for font #11 and #13 and saved the theme.


Then checked using a portable Reaper instance, and the font seems to stick here.

https://i.ibb.co/4p9vgrz/Screenshot-...9-13-36-05.png


– and yes, lets wait for the experts, I'm just playing around here
PhelixK is offline   Reply With Quote
Old 12-20-2019, 05:48 AM   #62
D Rocks
Human being with feelings
 
Join Date: Dec 2017
Location: Quebec, Canada
Posts: 547
Default

Hey this is a good job grats.

It reminds me of the great looking TDR Slick EQ mastering plugin !
__________________
Alex | www.drocksrecords.com | Thanks for REAPER
D Rocks is offline   Reply With Quote
Old 12-20-2019, 05:51 AM   #63
b0se
Human being with feelings
 
b0se's Avatar
 
Join Date: Jan 2019
Location: UK
Posts: 890
Default

Quote:
Originally Posted by SmajjL View Post
The theme development/tweaker (action/toolbar) has a save theme function, when you figure out what does what.
While you await WT for a more Pro-answer.
Tried, it doesn't work (on any theme!). No idea why.

Quote:
Originally Posted by PhelixK View Post
I just installed Fira Sans, then made copy of the . ReaperTheme file and wiped the font codes in the end.

Then changed Walter font description in rt, line 35-38,
Then used theme tweaker and set specific size for font #11 and #13 and saved the theme.


Then checked using a portable Reaper instance, and the font seems to stick here.

https://i.ibb.co/4p9vgrz/Screenshot-...9-13-36-05.png


– and yes, lets wait for the experts, I'm just playing around here
Interesting, wouldn't have dared wipe anything from the *.ReaperTheme. Does it stick when it's not a portable Reaper install?

There update: New monitor icons and closing MCP folder...

b0se is offline   Reply With Quote
Old 12-20-2019, 06:09 AM   #64
PhelixK
Human being with feelings
 
PhelixK's Avatar
 
Join Date: Mar 2019
Posts: 237
Default

Quote:
Originally Posted by b0se View Post
Interesting, wouldn't have dared wipe anything from the *.ReaperTheme. Does it stick when it's not a portable Reaper install?
I only wiped the font codes as a test. The Tweaker/save should overwrite the info, but I wanted to observe if and what lines was changed throughout the entire theme file.
Yes the font is available for custom theme as well, forgot to mention I did a ReaperThemeZip to check with the portable install. Of course all this requires the end-user to install fonts manually.
PhelixK is offline   Reply With Quote
Old 12-20-2019, 06:18 AM   #65
b0se
Human being with feelings
 
b0se's Avatar
 
Join Date: Jan 2019
Location: UK
Posts: 890
Default

Quote:
Originally Posted by PhelixK View Post
I only wiped the font codes as a test. The Tweaker/save should overwrite the info, but I wanted to observe if and what lines was changed throughout the entire theme file.
Yes the font is available for custom theme as well, forgot to mention I did a ReaperThemeZip to check with the portable install. Of course all this requires the end-user to install fonts manually.
Thanks for your help, I'll give this a pop.
b0se is offline   Reply With Quote
Old 12-20-2019, 06:21 AM   #66
PhelixK
Human being with feelings
 
PhelixK's Avatar
 
Join Date: Mar 2019
Posts: 237
Default

Quote:
Originally Posted by b0se View Post
Thanks for your help, I'll give this a pop.
Just a heads up, be careful, make copies of whatever, I'm not sure how this may influence other ini files, hehe.
PhelixK is offline   Reply With Quote
Old 12-20-2019, 06:24 AM   #67
b0se
Human being with feelings
 
b0se's Avatar
 
Join Date: Jan 2019
Location: UK
Posts: 890
Default

Quote:
Originally Posted by PhelixK View Post
Just a heads up, be careful, make copies of whatever, I'm not sure how this may influence other ini files, hehe.
Will do :¬)
b0se is offline   Reply With Quote
Old 12-20-2019, 06:47 AM   #68
b0se
Human being with feelings
 
b0se's Avatar
 
Join Date: Jan 2019
Location: UK
Posts: 890
Default

Quote:
Originally Posted by PhelixK View Post
Just a heads up, be careful, make copies of whatever, I'm not sure how this may influence other ini files, hehe.
Are you Mac or Windows?

Mac here and it didn't work, removing the font listings made the fonts go tiny.
b0se is offline   Reply With Quote
Old 12-20-2019, 08:00 AM   #69
nait
Human being with feelings
 
nait's Avatar
 
Join Date: Jun 2018
Location: Edmonton, AB, Canada
Posts: 711
Default

Quote:
Originally Posted by b0se View Post
Cheers Nait :¬)

1080p (Scale 1x) version - no code changes necessary! It's just a matter of resizing the images by 50%. The only 'tricky' bit is making sure the stretch markers (yellow and fuscia pink 1px lines) are correct, they won't downscale properly.

You may need to adjust layer styles to accommodate, i.e. shadow depth, stroke width etc as they're set for 2x scale. Still, it would be much faster than designing a theme from scratch!
Excellent.. that should all be manageable, thanks!
__________________
My Rig (also serves as my gaming PC): Asus Z270A Prime Mobo, i7-6700k, 32GB RAM, Samsung 960 Evo 500gb NVMe, Crucial 1TB NVMe, NVidia GTX 1070, Focusrite Scarlett 2i2, Nektar Impact LX25+ MIDI Controller Keyboard.
nait is offline   Reply With Quote
Old 12-20-2019, 08:42 AM   #70
b0se
Human being with feelings
 
b0se's Avatar
 
Join Date: Jan 2019
Location: UK
Posts: 890
Default

Got all the fonts changed and aligned, looking much nicer.



Except the damn transport font. It works for the label, but on the actual time/bars...



None of the WALTER fonts in the theme tweaker change it.

@White Tie - any ideas?


Quote:
Originally Posted by nait View Post
Excellent.. that should all be manageable, thanks!
I can help guide you through the changes too (at the start). Since I've finished the bulk of the theme already, I'm happy to send the theme and source files over to whenever you're ready :¬)
b0se is offline   Reply With Quote
Old 12-20-2019, 08:50 AM   #71
nait
Human being with feelings
 
nait's Avatar
 
Join Date: Jun 2018
Location: Edmonton, AB, Canada
Posts: 711
Default

Quote:
Originally Posted by b0se View Post
I can help guide you through the changes too (at the start). Since I've finished the bulk of the theme already, I'm happy to send the theme and source files over to whenever you're ready :¬)
I'll give it a go and let you know if I need any help, but hopefully I can figure that all out on my own. You've definitely done the hardest part!

I sent you an email to the address in your profile. Thanks!
__________________
My Rig (also serves as my gaming PC): Asus Z270A Prime Mobo, i7-6700k, 32GB RAM, Samsung 960 Evo 500gb NVMe, Crucial 1TB NVMe, NVidia GTX 1070, Focusrite Scarlett 2i2, Nektar Impact LX25+ MIDI Controller Keyboard.
nait is offline   Reply With Quote
Old 12-20-2019, 10:16 AM   #72
PhelixK
Human being with feelings
 
PhelixK's Avatar
 
Join Date: Mar 2019
Posts: 237
Default

Quote:
Originally Posted by b0se View Post
Are you Mac or Windows?

Mac here and it didn't work, removing the font listings made the fonts go tiny.
-macOS1015 here, I had to enlarge sizes as well. I haven’t tried tweaking the font used in transport..
PhelixK is offline   Reply With Quote
Old 12-20-2019, 10:34 AM   #73
KuulArt
Human being with feelings
 
Join Date: Apr 2015
Posts: 30
Default

Beautiful work!
Does HiDPi mean it will work well on Retina displays as well?
KuulArt is offline   Reply With Quote
Old 12-20-2019, 01:28 PM   #74
carbon
Human being with feelings
 
carbon's Avatar
 
Join Date: Feb 2008
Location: Eesti
Posts: 2,418
Default

Quote:
Originally Posted by b0se View Post
More FX list tweaks. Looking sweet now!


Indeed!
__________________
KasparTORN
carbon is offline   Reply With Quote
Old 12-20-2019, 03:32 PM   #75
mlprod
Human being with feelings
 
Join Date: Jul 2015
Location: Stockholm, Sweden
Posts: 812
Default

Awesome work!

Will one be able to tint the mixer strips?
__________________
Magnus Lindberg Productions - VRTKL Audio - Redmount Studios
magnuslindberg.com
mlprod is offline   Reply With Quote
Old 12-20-2019, 04:45 PM   #76
Blankfiles
Human being with feelings
 
Blankfiles's Avatar
 
Join Date: Jan 2015
Location: Canada
Posts: 1,116
Default

you say old
but it seems really modern, very pleasant on the eyes, probably the most beautiful model I've seen on reaper,
only small thing seen from here at first glance I find the volume mcp lacked width but just a little bit, but everything else is very good! here's a radical change that I would love to see as theme by default V6
ideas of themes united to bring out an art! Bravo !!
__________________
My Themes :I Logic V2.:I Logic V1.:I Logic NeXt.:Concerto.
Hydra.
Blankfiles is offline   Reply With Quote
Old 12-21-2019, 04:06 AM   #77
b0se
Human being with feelings
 
b0se's Avatar
 
Join Date: Jan 2019
Location: UK
Posts: 890
Default

Quote:
Originally Posted by KuulArt View Post
Beautiful work!
Does HiDPi mean it will work well on Retina displays as well?
Thanks! Yes it's designed for Retina / HiDPI.

Very lucky that Nait has offered to resize everything (smaller) for those with standard resolution.

Quote:
Originally Posted by mlprod View Post
Awesome work!

Will one be able to tint the mixer strips?
Cheers :¬)

I'm not a fan of tinted trips, they're not necessary imo.

Quote:
Originally Posted by Blankfiles View Post
you say old
but it seems really modern, very pleasant on the eyes, probably the most beautiful model I've seen on reaper,
only small thing seen from here at first glance I find the volume mcp lacked width but just a little bit, but everything else is very good! here's a radical change that I would love to see as theme by default V6
ideas of themes united to bring out an art! Bravo !!
Thanks BF! Much appreciated.

Here's a quick theme update showing some TCP UI highlights and interactions:



FX/send list and transport:



MCP:



Still other bits to theme, and there are some UI elements that are still default as I never see them and have no idea where to find them :¬)

I may release an early beta tomorrow so people can get their hands on it and find this stuff for me.

If anyone could help with the transport font bug it would be invaluable. That's a big drawback as the default / fixed font doesn't suit the theme, that LED font would be the finishing touch.

From this:



To this:



Like the Dude's rug, that font really ties the theme together :¬)
b0se is offline   Reply With Quote
Old 12-21-2019, 04:35 AM   #78
PhelixK
Human being with feelings
 
PhelixK's Avatar
 
Join Date: Mar 2019
Posts: 237
Default

Quote:
Originally Posted by b0se View Post
Still other bits to theme, and there are some UI elements that are still default as I never see them and have no idea where to find them :¬)

I may release an early beta tomorrow so people can get their hands on it and find this stuff for me.

If anyone could help with the transport font bug it would be invaluable. That's a big drawback as the default / fixed font doesn't suit the theme, that LED font would be the finishing touch.
I just looked into the transport bar and its dependencies.

I believe you’re getting this error because the Automode (left of Status text) is hard-coded to use a bold font style, that probably isn’t there.

Automode- and Status-text share same font family, and require presence of a regular and bold variant, which your chosen font might not include. I suggest to try use another LCD/dot -font, one that has both weights and defined as -regular/-normal and -bold.

Here's an example using a different font: https://i.ibb.co/FKMw36v/t-bar-12-21.jpg
PhelixK is offline   Reply With Quote
Old 12-21-2019, 04:40 AM   #79
b0se
Human being with feelings
 
b0se's Avatar
 
Join Date: Jan 2019
Location: UK
Posts: 890
Default

Quote:
Originally Posted by PhelixK View Post
I just looked into the transport bar and its dependencies.

I believe you’re getting this error because the Automode (left of Status text) is hard-coded to use a bold font style, that probably isn’t there.

Automode- and Status-text share same font family, and require presence of a regular and bold variant, which your chosen font might not include. I suggest to try use another LCD/dot -font, one that has both weights and defined as -regular/-normal and -bold.

Here's an example using a different font: https://i.ibb.co/FKMw36v/t-bar-12-21.jpg
You're right! Anything with a bold variant works.

***INCOMING INTERNET HUG***

Thanks so much!
b0se is offline   Reply With Quote
Old 12-21-2019, 04:46 AM   #80
vsgrt
Human being with feelings
 
Join Date: May 2017
Posts: 55
Default

Fantastic work b0se! Looks so easy on the eyes.

The only thing i notice is that the selected TCP track looks fairly hard to see and is too subtle (only my opinion though).
vsgrt is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:51 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.