Old 09-19-2019, 08:30 AM   #4801
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 856
Default

Quote:
Originally Posted by Geoff Waddington View Post
Yup, right after Learn Mode 1st draft is operational, that's the most requested feature right now
I agree that it's the most requested feature

But I would question the wisdom of releasing a mechanism capable of generating multiple FX Zones, when the infrastructure needed to support those extra Zones is broken.

As soon as users with a single MCU (or type) get their hands on a fully operational Learn Mode, they'll want to create those extra Zones to make their 8 Rotary/Pushes go farther in FX maps and they're more likely to choose FXMenu/SelectedTrackNavigator over OnFXFocus/FocusedFXNavigator as their solution.

Just sayin'
MixMonkey is offline   Reply With Quote
Old 09-19-2019, 08:42 AM   #4802
poetnprophet
Human being with feelings
 
poetnprophet's Avatar
 
Join Date: Jan 2018
Posts: 982
Default

Quote:
Originally Posted by Geoff Waddington View Post
Yup, right after Learn Mode 1st draft is operational, that's the most requested feature right now
Any chance we could also try to center align the display texts?
__________________
https://www.kdubbproductions.com/
https://www.youtube.com/channel/UCpC...2dGA3qUWBKrXQQ
i7 8700k,4.9Ghz,Win10,Reaper 5,Motu 828es,MJE Hulk 990,GAP Pre73/EQ81
poetnprophet is offline   Reply With Quote
Old 09-19-2019, 08:46 AM   #4803
poetnprophet
Human being with feelings
 
poetnprophet's Avatar
 
Join Date: Jan 2018
Posts: 982
Default

Lately, my setup has been acting WEIRD! Everything is fine, then suddenly I will select a track, or maybe adjust the vol or pan, and everything goes crazy on all surfaces: displays flashing, repeatedly as if the track keeps getting selected over and over, meters and all functions freeze (project will still play), and sometimes faders will even move by themselves...which is the scariest thing ever. I haven't changed a single thing (I don't think?) so this seems to be coming from nowhere.

Anybody experience this or have any insight? This is a new phenomenon for me. I have combed thru my zon files, nothing seems out of place. I'll check again later tonight.
__________________
https://www.kdubbproductions.com/
https://www.youtube.com/channel/UCpC...2dGA3qUWBKrXQQ
i7 8700k,4.9Ghz,Win10,Reaper 5,Motu 828es,MJE Hulk 990,GAP Pre73/EQ81
poetnprophet is offline   Reply With Quote
Old 09-19-2019, 08:49 AM   #4804
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 856
Default

Quote:
Originally Posted by poetnprophet View Post
Lately, my setup has been acting WEIRD! Everything is fine, then suddenly I will select a track, or maybe adjust the vol or pan, and everything goes crazy on all surfaces: displays flashing, repeatedly as if the track keeps getting selected over and over, meters and all functions freeze (project will still play), and sometimes faders will even move by themselves...which is the scariest thing ever. I haven't changed a single thing (I don't think?) so this seems to be coming from nowhere.

Anybody experience this or have any insight? This is a new phenomenon for me. I have combed thru my zon files, nothing seems out of place. I'll check again later tonight.
Your system is possessed by an evil code demon. Call an exorcist immediately!
MixMonkey is offline   Reply With Quote
Old 09-19-2019, 09:05 AM   #4805
poetnprophet
Human being with feelings
 
poetnprophet's Avatar
 
Join Date: Jan 2018
Posts: 982
Default

Quote:
Originally Posted by MixMonkey View Post
Your system is possessed by an evil code demon. Call an exorcist immediately!
Seriously, its beyond strange! All 3 surfaces are affected by it. And, just as suddenly as it starts, it stops
__________________
https://www.kdubbproductions.com/
https://www.youtube.com/channel/UCpC...2dGA3qUWBKrXQQ
i7 8700k,4.9Ghz,Win10,Reaper 5,Motu 828es,MJE Hulk 990,GAP Pre73/EQ81
poetnprophet is offline   Reply With Quote
Old 09-19-2019, 09:05 AM   #4806
Freex
Human being with feelings
 
Freex's Avatar
 
Join Date: Jul 2011
Location: Northern Ireland
Posts: 581
Question

Quote:
Originally Posted by MixMonkey View Post
If you've been switching between old and new versions of CSI, are you sure all the navigator names etc are correct?

No, I'm not switching back and forth, I've the new build on the home pc and an older one in the studio.
But learn mode came along with its fancy ways, big window and promises of sunglass for everyone and stomped all over my hard work

And for by the life of me I can't find the wood for the trees.
Freex is offline   Reply With Quote
Old 09-19-2019, 09:20 AM   #4807
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 856
Default

Quote:
Originally Posted by poetnprophet View Post
Seriously, its beyond strange! All 3 surfaces are affected by it. And, just as suddenly as it starts, it stops
It sounds as if a MIDI buffer somewhere has been filling without emptying properly and then suddenly it does.

Try and think what you were doing in the time leading up to the 'event'. Recording, mixing, programming?
MixMonkey is offline   Reply With Quote
Old 09-19-2019, 09:44 AM   #4808
pepe44
Human being with feelings
 
pepe44's Avatar
 
Join Date: Jul 2013
Location: Portugal
Posts: 730
Default

Quote:
Originally Posted by MixMonkey View Post
No, it's not TrackVolume I don't use the meters myself (I find them kinda annoying) but I think the syntax would be:
Code:
 DisplayLower| VUMeter
As this obviously clashes with the Pan display, I'm hoping it's only active when Reaper is playing.

If this doesn't work, hopefully someone who does use the meters can chime in. Sorry I can't be more help.
Thanks, again.
No it does not work. Maybe someone can give a little help on this one ?

EDIT: My guess that i have to build a dedicated zone for the meter , right ?
__________________
Intel core i7 6700K - socket 1151 LGA - Chipset z170 - 16G DDR4 - Nvidia GTX 1060
pepe44 is online now   Reply With Quote
Old 09-19-2019, 10:06 AM   #4809
poetnprophet
Human being with feelings
 
poetnprophet's Avatar
 
Join Date: Jan 2018
Posts: 982
Default

Quote:
Originally Posted by pepe44 View Post
Thanks, again.
No it does not work. Maybe someone can give a little help on this one ?

EDIT: My guess that i have to build a dedicated zone for the meter , right ?
I'm not able to pull that info from here at work, but when I'm back in the studio tonight I'll pull out my zon and post here.

Actually yes you have to define it in the mst file as well, then it goes in the channel section of the main zon
__________________
https://www.kdubbproductions.com/
https://www.youtube.com/channel/UCpC...2dGA3qUWBKrXQQ
i7 8700k,4.9Ghz,Win10,Reaper 5,Motu 828es,MJE Hulk 990,GAP Pre73/EQ81
poetnprophet is offline   Reply With Quote
Old 09-19-2019, 10:13 AM   #4810
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,745
Default

Quote:
Originally Posted by poetnprophet View Post
Seriously, its beyond strange! All 3 surfaces are affected by it. And, just as suddenly as it starts, it stops
If you never open the Learn Mode Window, does it still do this ?
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-19-2019, 10:14 AM   #4811
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,745
Default

Quote:
Originally Posted by Freex View Post
No, I'm not switching back and forth, I've the new build on the home pc and an older one in the studio.
But learn mode came along with its fancy ways, big window and promises of sunglass for everyone and stomped all over my hard work

And for by the life of me I can't find the wood for the trees.
If you never open the Learn Mode Window, does it still do this ?
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-19-2019, 10:16 AM   #4812
poetnprophet
Human being with feelings
 
poetnprophet's Avatar
 
Join Date: Jan 2018
Posts: 982
Default

Quote:
Originally Posted by MixMonkey View Post
It sounds as if a MIDI buffer somewhere has been filling without emptying properly and then suddenly it does.

Try and think what you were doing in the time leading up to the 'event'. Recording, mixing, programming?
All of the above! Now that I think about it, I did modify a project template's FX and the C4 mapping. Call it Mix Template. But, I mostly work in my Recording Template, which was not modified at all. And, the only thing I changed ZON-wise was an FX zon (for an fx in the Mix template), so its weird that all of the surface would be affected.

When the issue happens, i can be recording, or not. I could be in playback, or not. I could be idle, but [I think] it always happens when I touch a FADER or ROTARY on the ProX/XS. reaper stuff still works (I can save the project when this happens and continue transport actions with keyboard).

It does seem/feel like a midi flood of some sort. When there's a "space", I can select another track from the surface, but the craziness persists. I can even select another Page, and it persists. But, if I try to move a fader or rotary, the value doesn't change until the next "space" in the midi stream and the parameter Jumps.
__________________
https://www.kdubbproductions.com/
https://www.youtube.com/channel/UCpC...2dGA3qUWBKrXQQ
i7 8700k,4.9Ghz,Win10,Reaper 5,Motu 828es,MJE Hulk 990,GAP Pre73/EQ81
poetnprophet is offline   Reply With Quote
Old 09-19-2019, 10:18 AM   #4813
poetnprophet
Human being with feelings
 
poetnprophet's Avatar
 
Join Date: Jan 2018
Posts: 982
Default

Quote:
Originally Posted by Geoff Waddington View Post
If you never open the Learn Mode Window, does it still do this ?
Hi Geoff, I never open the learn window anyway...sorry. At least not in about a week or so.
__________________
https://www.kdubbproductions.com/
https://www.youtube.com/channel/UCpC...2dGA3qUWBKrXQQ
i7 8700k,4.9Ghz,Win10,Reaper 5,Motu 828es,MJE Hulk 990,GAP Pre73/EQ81
poetnprophet is offline   Reply With Quote
Old 09-19-2019, 10:40 AM   #4814
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,745
Default

Quote:
Originally Posted by poetnprophet View Post
All of the above! Now that I think about it, I did modify a project template's FX and the C4 mapping. Call it Mix Template. But, I mostly work in my Recording Template, which was not modified at all. And, the only thing I changed ZON-wise was an FX zon (for an fx in the Mix template), so its weird that all of the surface would be affected.

When the issue happens, i can be recording, or not. I could be in playback, or not. I could be idle, but [I think] it always happens when I touch a FADER or ROTARY on the ProX/XS. reaper stuff still works (I can save the project when this happens and continue transport actions with keyboard).

It does seem/feel like a midi flood of some sort. When there's a "space", I can select another track from the surface, but the craziness persists. I can even select another Page, and it persists. But, if I try to move a fader or rotary, the value doesn't change until the next "space" in the midi stream and the parameter Jumps.
Hmmm...

Wonder if there is some sort of circular Zone definition when certain Zones are activated, causing a sort of Zone Feedback ?

Take a look at your Parent and Included Zones, perhaps there's something there.
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-19-2019, 10:41 AM   #4815
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,745
Default

Quote:
Originally Posted by poetnprophet View Post
Hi Geoff, I never open the learn window anyway...sorry. At least not in about a week or so.
Good news, in a way, Learn Mode doesn't seem to be causing this...
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-19-2019, 01:33 PM   #4816
pepe44
Human being with feelings
 
pepe44's Avatar
 
Join Date: Jul 2013
Location: Portugal
Posts: 730
Default

Quote:
Originally Posted by poetnprophet View Post
I'm not able to pull that info from here at work, but when I'm back in the studio tonight I'll pull out my zon and post here.

Actually yes you have to define it in the mst file as well, then it goes in the channel section of the main zon
But i already have the widgets created by default in the mst file

Widget VUMeter1
FB_MCUVUMeter 0
WidgetEnd

Widget VUMeter2
FB_MCUVUMeter 1
WidgetEnd

Widget VUMeter3
FB_MCUVUMeter 2
WidgetEnd

Widget VUMeter4
FB_MCUVUMeter 3
WidgetEnd

Widget VUMeter5
FB_MCUVUMeter 4
WidgetEnd

Widget VUMeter6
FB_MCUVUMeter 5
WidgetEnd

Widget VUMeter7
FB_MCUVUMeter 6
WidgetEnd

Widget VUMeter8
FB_MCUVUMeter 7
WidgetEnd
__________________
Intel core i7 6700K - socket 1151 LGA - Chipset z170 - 16G DDR4 - Nvidia GTX 1060
pepe44 is online now   Reply With Quote
Old 09-19-2019, 02:09 PM   #4817
pepe44
Human being with feelings
 
pepe44's Avatar
 
Join Date: Jul 2013
Location: Portugal
Posts: 730
Default

VUMeter| TrackOutputMeter 1-8

EDIT: Now that i have meters i noticed that they are not has accurate has the standard MCU. By this i mean, when in reaper the signal goes up to orange (in my case orange is above -12 DBFs) i would like too have visual relation in the XTouch.

How can i change the sensibility of the meters to better relate to the meters on Reaper ?
__________________
Intel core i7 6700K - socket 1151 LGA - Chipset z170 - 16G DDR4 - Nvidia GTX 1060

Last edited by pepe44; 09-19-2019 at 02:17 PM.
pepe44 is online now   Reply With Quote
Old 09-19-2019, 02:20 PM   #4818
poetnprophet
Human being with feelings
 
poetnprophet's Avatar
 
Join Date: Jan 2018
Posts: 982
Default

haha, nevermind. glad you got it working. I will share what I have later, mine are pretty close to where they should be.
__________________
https://www.kdubbproductions.com/
https://www.youtube.com/channel/UCpC...2dGA3qUWBKrXQQ
i7 8700k,4.9Ghz,Win10,Reaper 5,Motu 828es,MJE Hulk 990,GAP Pre73/EQ81
poetnprophet is offline   Reply With Quote
Old 09-19-2019, 02:21 PM   #4819
tomas1808
Human being with feelings
 
Join Date: Aug 2011
Posts: 3
Default

I've been thinking of building my own DIY REAPER control-surface/mixer for a few years now. This is the first time I have enough free time to pursue this goal.

I already have a rough design for the console and aquired some of the most expensive parts (like 28 TKD motorzied faders, want to get to 48 eventually). My vision is an "old" style console with "real" clicky buttons (no tact switches) and keeping button mapping 1:1 as much as possible. I dont like context-dependant buttons/encoders. I'll try to avoid endless rotary encoders in favour of endless rotary switches. I really dislike the lack of mechanical feedback on modern controllers, notably those endless rotary knobs on EQs where you have to look at a display to be able to see what is going on. I'll try to avoid features hidden in menus and things like that. I dont want fader banks and layers. The only modern feature I want is beign able to show sends on the motorized faders. Also want a OLED display for every channel to show some basic stats and a decently sized LED VU meter. I dislike touchscreens and want to keep mouse use to a minimum. I see mice as a necessary evil, some tasks just need it.

Yesterday I started researching how much integration I can expect between REAPER and the control surface. It seems that it's easy to send pretty much any action from a remote device into REAPER but not the other way round (send the state back to the surface). There are too many action/buttons that are not reported back via OSC to the surface. Also I am a bit worried about OSC overload from too many messages when dealing with larger format surfaces. I am sure there are more problems I am not even aware yet.

I would like to contribute and try to expand REAPER's OSC output capabilites to allow tight integration for more advanced control surfaces others might come up with. OSC output seems to be the bigger problem right now. I'll be honest and say that I dont have a clear road to the solution yet. I admit that I am a bit out of the loop and I have not read the 121 pages on this thread so maybe there is a solution to the OSC output problem. Let me know in that case please!

I am aware of the C/Python API so I'll start there.

Last edited by tomas1808; 09-19-2019 at 02:28 PM.
tomas1808 is offline   Reply With Quote
Old 09-19-2019, 03:14 PM   #4820
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 121
Default

Quote:
Originally Posted by Geoff Waddington View Post
I edited the Installation page a bit -- let me know if you approve of the edit content/style/etc., you obviously can do a much better job on the this than I.

If that works, there are a few other spots I wouldn't mind taking a shot at -- mostly nit picky details
Go for it Geoff. So far it's mostly based on what I've gleaned from experiments, the forum and people's answers to my vague questions, so the more brains the better :-)

I'll probably take a crack at writing up something on FX zones this weekend.
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old 09-19-2019, 03:18 PM   #4821
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 121
Default

Quote:
Originally Posted by MixMonkey View Post
What works best for me is to open an FX chain window and navigate up or down the FX slots on a selected track:
Code:
SlotUp Reaper _S&M_SHOWFXCHAINSEL
SlotUp Reaper _S&M_SELFXPREV

SlotDown Reaper _S&M_SHOWFXCHAINSEL
SlotDown Reaper _S&M_SELFXNEXT
Then, to close the FX chain and GoHome:
Code:
Split Reaper _S&M_WNCLS4
Split GoZone Home
SlotUp, SlotDown and Split are buttons on my C4.

Also, this is the only way I've found to reliably focus FX windows on Mac. Just opening a window isn't sufficient to 'focus' it, even if it is in the foreground. Sometimes even clicking away and back to it doesn't work. It can get very frustrating and be even worse if you have no displays on your device to let you know that the map has loaded.

This doesn't happen on Windows, where everything behaves as expected.
Nice. I had the opening of the FX Chain window using standard actions, but stepping through them and closing the window is a definite improvement. Need to spend more time looking through the SWS actions.
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old 09-19-2019, 03:26 PM   #4822
Freex
Human being with feelings
 
Freex's Avatar
 
Join Date: Jul 2011
Location: Northern Ireland
Posts: 581
Default

Quote:
Originally Posted by Geoff Waddington View Post
If you never open the Learn Mode Window, does it still do this ?
No it just seems broken. Did you have the C4emu working at your end?
Freex is offline   Reply With Quote
Old 09-19-2019, 03:37 PM   #4823
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 856
Default

Quote:
Originally Posted by MalcolmG View Post
Nice. I had the opening of the FX Chain window using standard actions, but stepping through them and closing the window is a definite improvement. Need to spend more time looking through the SWS actions.
The SWS actions are gold

Also worth noting in the example, is assigning the close FX chain window and the GoZone Home commands to the same button, so they happen together.
MixMonkey is offline   Reply With Quote
Old 09-19-2019, 04:18 PM   #4824
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,745
Default

Quote:
Originally Posted by MalcolmG View Post
Go for it Geoff. So far it's mostly based on what I've gleaned from experiments, the forum and people's answers to my vague questions, so the more brains the better :-)

I'll probably take a crack at writing up something on FX zones this weekend.
Thanks, will chip away at it
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-19-2019, 04:21 PM   #4825
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,745
Default

Quote:
Originally Posted by Freex View Post
No it just seems broken. Did you have the C4emu working at your end?
Like a champ.

But I might have broken things somehow since then

Press has become important, but you already know that

And you also know Toggle give you Press for free

Other than that I'm still stumped...
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-19-2019, 05:53 PM   #4826
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 121
Default FX Zones and FX Chain Window

I'm noticing some weird behavior using MapFocusedFXToWidgets.

Setup a couple of FX on a track, and make sure the first one is one that has a zone defined for it.

The first time I bring up the FX Chain window (even manually) the first FX maps to it's zone automatically. All good.

Close the window and make sure you're back in your Home zone. Then bring the FX Chain window up again. The first FX will be focused, but it won't map to it's zone. Select the second one and then go back and select the first one and it does map correctly.

To be clear, all this happens the same whether bringing up the FX Chain window using the mouse or a Surface action. Same result. I'm on Windows.
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old 09-19-2019, 06:11 PM   #4827
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 856
Default

Quote:
Originally Posted by MalcolmG View Post
I'm noticing some weird behavior using MapFocusedFXToWidgets.

Setup a couple of FX on a track, and make sure the first one is one that has a zone defined for it.

The first time I bring up the FX Chain window (even manually) the first FX maps to it's zone automatically. All good.

Close the window and make sure you're back in your Home zone. Then bring the FX Chain window up again. The first FX will be focused, but it won't map to it's zone. Select the second one and then go back and select the first one and it does map correctly.

To be clear, all this happens the same whether bringing up the FX Chain window using the mouse or a Surface action. Same result. I'm on Windows.
That's pretty much the deal with the FocusedFXNavigator. The actual 'focusing' of the FX can be a bit vague, although it's much better on Windows than it is on Mac.

You could try:
Code:
_S&M_SHOWFXCHAIN1
That will open the window and select the first FX in the chain. It might force the FX to focus.
MixMonkey is offline   Reply With Quote
Old 09-19-2019, 07:46 PM   #4828
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 121
Default

Quote:
Originally Posted by MixMonkey View Post
You could try:
Code:
_S&M_SHOWFXCHAIN1
That will open the window and select the first FX in the chain. It might force the FX to focus.
Yeah, unfortunately I tried that one, no joy. When I get home I may try ShowFXChain, followed by Next then Prev. Might cause the zones to jump around a bit, but that's what I'm manually doing now anyway.

Cheers
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old 09-19-2019, 08:55 PM   #4829
poetnprophet
Human being with feelings
 
poetnprophet's Avatar
 
Join Date: Jan 2018
Posts: 982
Default

Quote:
Originally Posted by poetnprophet View Post
haha, nevermind. glad you got it working. I will share what I have later, mine are pretty close to where they should be.
Here's what I have in the Zone Channel|1-8 section:

VUMeter| TrackOutputMeterMaxPeakLR
/VUMeter| TrackOutputMeterAverageLR


There are two choices...
__________________
https://www.kdubbproductions.com/
https://www.youtube.com/channel/UCpC...2dGA3qUWBKrXQQ
i7 8700k,4.9Ghz,Win10,Reaper 5,Motu 828es,MJE Hulk 990,GAP Pre73/EQ81
poetnprophet is offline   Reply With Quote
Old 09-19-2019, 08:56 PM   #4830
poetnprophet
Human being with feelings
 
poetnprophet's Avatar
 
Join Date: Jan 2018
Posts: 982
Default

Quote:
Originally Posted by MalcolmG View Post
Yeah, unfortunately I tried that one, no joy. When I get home I may try ShowFXChain, followed by Next then Prev. Might cause the zones to jump around a bit, but that's what I'm manually doing now anyway.

Cheers
Maybe try these:

SlotUp Reaper _S&M_SELFXPREV
SlotDown Reaper _S&M_SELFXNEXT
TrackL Reaper _6db7ce90e786a64d931d2e0a70c134b3
TrackR Reaper _7bd94bde9f6b394d8af68e30b1bdc1b4
__________________
https://www.kdubbproductions.com/
https://www.youtube.com/channel/UCpC...2dGA3qUWBKrXQQ
i7 8700k,4.9Ghz,Win10,Reaper 5,Motu 828es,MJE Hulk 990,GAP Pre73/EQ81
poetnprophet is offline   Reply With Quote
Old 09-19-2019, 09:07 PM   #4831
poetnprophet
Human being with feelings
 
poetnprophet's Avatar
 
Join Date: Jan 2018
Posts: 982
Default

Quote:
Originally Posted by Geoff Waddington View Post
Good news, in a way, Learn Mode doesn't seem to be causing this...
Ok it's definitely something with the fader and/or those kinds of midi messages. if I move the fader, the C4 goes crazy. And if I move a rotary tick by tick, each tick refreshes the C4.

Here's my Channel zone:

Zone Channel|1-8
TrackNavigator
VUMeter| TrackOutputMeterMaxPeakLR
/VUMeter| TrackOutputMeterAverageLR
DisplayUpper| TrackNameDisplay
DisplayLower| TrackPanDisplay
TrackTouch+DisplayLower| TrackVolumeDisplay
RotaryPush| GoZone PanWidth|
Rotary| TrackPan 0
RecordArm| TrackRecordArm
Solo| TrackSolo
Mute| TrackMute
Select| TrackUniqueSelect
Shift+Select| TrackRangeSelect
Control+Select| TrackSelect
Shift+Control+Select| TogglePin
Option+Select| TrackFolderDive
Fader| TrackVolume
TrackTouch+Fader| TrackVolume
FaderTouch| TrackTouch
ZoneEnd

Zone Pan|1-8
TrackNavigator
Rotary| TrackPan 0
RotaryPush| GoZone PanWidth|
ZoneEnd

Zone PanWidth|1-8
TrackNavigator
Rotary| TrackPanWidth 1
RotaryPush| GoZone Pan|
ZoneEnd
__________________
https://www.kdubbproductions.com/
https://www.youtube.com/channel/UCpC...2dGA3qUWBKrXQQ
i7 8700k,4.9Ghz,Win10,Reaper 5,Motu 828es,MJE Hulk 990,GAP Pre73/EQ81
poetnprophet is offline   Reply With Quote
Old 09-20-2019, 01:14 AM   #4832
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,745
Default

Quote:
Originally Posted by poetnprophet View Post
Ok it's definitely something with the fader and/or those kinds of midi messages. if I move the fader, the C4 goes crazy. And if I move a rotary tick by tick, each tick refreshes the C4.
Thanks man, that's good info, will check into it.
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-20-2019, 01:53 AM   #4833
Freex
Human being with feelings
 
Freex's Avatar
 
Join Date: Jul 2011
Location: Northern Ireland
Posts: 581
Default

Quote:
Originally Posted by Geoff Waddington View Post
Like a champ.

But I might have broken things somehow since then

Press has become important, but you already know that

And you also know Toggle give you Press for free

Other than that I'm still stumped...

If you get a chance, could you run the emu and see what you're getting.
I also noticed that in the C4 zone folder there is a rouge C4Osc file.
Freex is offline   Reply With Quote
Old 09-20-2019, 02:32 AM   #4834
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,745
Default

Quote:
Originally Posted by Freex View Post
If you get a chance, could you run the emu and see what you're getting.
I also noticed that in the C4 zone folder there is a rouge C4Osc file.
C4 emu working fine here.

That's not a rogue file, that's the file I was using for testing -- it's also the file you should use.

I had to make changes to the .touchosc, .ost, and .zon files you sent, so you should use the ones supplied, at least for initial testing.

Did not change the FabFilter .zon files, you can use the C4OSC.zon file as an example for making those changes.
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-20-2019, 03:43 AM   #4835
Freex
Human being with feelings
 
Freex's Avatar
 
Join Date: Jul 2011
Location: Northern Ireland
Posts: 581
Default

Quote:
Originally Posted by Geoff Waddington View Post
C4 emu working fine here.

That's not a rogue file, that's the file I was using for testing -- it's also the file you should use.

I had to make changes to the .touchosc, .ost, and .zon files you sent, so you should use the ones supplied, at least for initial testing.

Did not change the FabFilter .zon files, you can use the C4OSC.zon file as an example for making those changes.
I see what's happened now, you put C4OSC in C4 folder, but for me the C4 folder already had C4 (realsurface) in it, hence me having a C4OSC Folder (which you wouldn't have, what with not having a C4 lol).
And as you know we can't have to zones with essentially the same Zone layout in the same Zonefolder.

I guess in the build there should be (as I thought there already was) C4 and C4OSC folders. lol

I'll try this later and see how i get on. Thanks.
Freex is offline   Reply With Quote
Old 09-20-2019, 04:00 AM   #4836
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,745
Default

Quote:
Originally Posted by Freex View Post
I see what's happened now, you put C4OSC in C4 folder, but for me the C4 folder already had C4 (realsurface) in it, hence me having a C4OSC Folder (which you wouldn't have, what with not having a C4 lol).
And as you know we can't have to zones with essentially the same Zone layout in the same Zonefolder.

I guess in the build there should be (as I thought there already was) C4 and C4OSC folders. lol

I'll try this later and see how i get on. Thanks.
I thought the idea was to work on real C4 .zons with the C4 emu, wouldn't you want those results to end up in your regular C4 folder.

I see three options:

1) Use the regular C4.zon file, but you lose the Transport, etc. that you defined for the emu.

2) Use the C4OSC.zon file -- to get the extra features you added for Touch OSC, and you will end up with meaningless C4 definitions when you use the real hardware -- those definitions should be harmless.

3) Swap the C4.zon and C4OSC.zon files in and out of the C4 folder as necessary.

Personally, I'd try option 2 and see if that works for you.
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-20-2019, 04:06 AM   #4837
Freex
Human being with feelings
 
Freex's Avatar
 
Join Date: Jul 2011
Location: Northern Ireland
Posts: 581
Default

Quote:
Originally Posted by Geoff Waddington View Post
I thought the idea was to work on real C4 .zons with the C4 emu, wouldn't you want those results to end up in your regular C4 folder.

I see three options:

1) Use the regular C4.zon file, but you lose the Transport, etc. that you defined for the emu.

2) Use the C4OSC.zon file -- to get the extra features you added for Touch OSC, and you will end up with meaningless C4 definitions when you use the real hardware -- those definitions should be harmless.

3) Swap the C4.zon and C4OSC.zon files in and out of the C4 folder as necessary.

Personally, I'd try option 2 and see if that works for you.
I guess for anyone without a C4 it's no biggie.
I have two systems one with C4 and one without, but having the Fxzones tested and in one place would be alot more streamline.

As you say, I'll try option 2 (which seems have the most to gain from)

Thanks again.

The Devil is truely in the details, as are all the gremlins lol.
Freex is offline   Reply With Quote
Old 09-20-2019, 05:40 AM   #4838
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 121
Default

Quote:
Originally Posted by poetnprophet View Post
Maybe try these:

SlotUp Reaper _S&M_SELFXPREV
SlotDown Reaper _S&M_SELFXNEXT
TrackL Reaper _6db7ce90e786a64d931d2e0a70c134b3
TrackR Reaper _7bd94bde9f6b394d8af68e30b1bdc1b4

Thanks

I'm using those first two assigned to buttons at the moment and doing them manually, which does the trisk. However doing them as part of the same button Press as showing the FXChain window doesn'tseem to work.

What are those last two? Is that moving the track selection left/right? Are they standard actions?
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old 09-20-2019, 08:53 AM   #4839
poetnprophet
Human being with feelings
 
poetnprophet's Avatar
 
Join Date: Jan 2018
Posts: 982
Default

OHh, those are custom actions I think. Moves the track L/R and opens the FX chain. The idea was to use L/R to select track chains and UP/Down to cycle thru the fx on each chain...using FocusedFX. But I don't use focused FX anymore so I forgot they did that.

the custom action for Next fx chain (R) is:

Sws close all floating fx
track go to next track
show fx chain for select tracks
__________________
https://www.kdubbproductions.com/
https://www.youtube.com/channel/UCpC...2dGA3qUWBKrXQQ
i7 8700k,4.9Ghz,Win10,Reaper 5,Motu 828es,MJE Hulk 990,GAP Pre73/EQ81
poetnprophet is offline   Reply With Quote
Old 09-20-2019, 12:36 PM   #4840
Freex
Human being with feelings
 
Freex's Avatar
 
Join Date: Jul 2011
Location: Northern Ireland
Posts: 581
Default

Finally got it to work, aside from the changes to some definition, the big culprit as far as i can see is that the Auto Maps don't seem to work anymore.
I knew sends and FXMenu were broken but i did realise everything was.

I set up the toggles as

Press+EQ ToggleLearnMode
Press+Plugin ToggleMapFocusedFX
Press+Instrument ToggleMapSelectedTrackFXMenu

And got the main FX working, Shift not doing it's thing though

Should the Modifiers be
Shift Shift
or
Press+Shift Shift
or
Toggle+Shift Shift
Freex is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:06 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.