Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Q&A, Tips, Tricks and Howto

Reply
 
Thread Tools Display Modes
Old 05-31-2019, 08:15 AM   #481
flipotto
Human being with feelings
 
flipotto's Avatar
 
Join Date: Feb 2007
Posts: 549
Default Request: show track control knobs - Device

Moss,

I have a request.

I would like to be able to choose which device controls show up for the 8 knobs (banks) on the push 2 screen.
When I select device there are several banks and the controls are NOT in usable order. I would like to be able to modify that order of device parameters.

Not sure how to accomplish this...
One suggestion:If I could map controls to the track control knobs
see pic
then be able show those on the device screen, I could customize my shown parameters.

Thoughts?

Thanks
Attached Images
File Type: png trackknobs.PNG (4.4 KB, 45 views)
__________________
KeyMce/GenMce - pc keyboard/midi to Mackie control emulation (built with ahk). Also - an ahk script to build your own midi programs.
flipotto is offline   Reply With Quote
Old 06-06-2019, 12:01 AM   #482
vibralux
Human being with feelings
 
Join Date: May 2019
Posts: 5
Default

Hello People.

First of all, Moss - thanks for this incredibly useful tool. I really wanted someone to invent this.
And I am almost in heaven. I write "almost" as the whole thing works for me, but just at the beginning.
Afer some time (usually next day) Reaper starts to act strangely - i freezes and quits altogether by
itself. When I remove the scripts it all goes back to normal. I have followed all the isntructions
and I believe I did everything as should as it works after installation. Any ideas what might be
the culprit? I work on Win 10 64bit, newest Reaper.

Cheers
m
vibralux is offline   Reply With Quote
Old 06-09-2019, 12:57 AM   #483
marcusonic
Human being with feelings
 
Join Date: Jun 2019
Posts: 5
Default

Hi!

My first post and already it's a technical question. I have one of them Akai APC Minis, and I'd like to use it with Reaper. But I seem to hit a dead-end, and I don't know what else to do.

Spec:
- Windows 10 1903 Update
- Current Reaper version (5.978 as of this writing)

I installed the extension as instructed and it does show up in the panel, as it should. When I select the entry, I only get this message:



I tried:
- Installing Java JRE and SDK, no avail
- Running via command line to gain debug or verbose info - nothing
- Removed everything I had in the Roaming folder, let Reaper start fresh with only that plugin - nothing
- Complete reinstall of Reaper itself, also not working
- Manually copying over content of entire JRE install into Moss's Java Home - not working
- Tested on a Windows 10, 1809 Update (Previous Windows update) - WORKING

To make sure it's a Windows issue, I installed Reaper on a Manjaro Linux, installed the plugin there, and connected the Akai APC Mini - WORKING!

However, on this Windows 10 install, I can't get it to run. I also don't know how to acquire debug info. Further, apart from the message shown, I do not get any other hints as to what went wrong.

If you have tips, or if Moss reads this, I'd much appreciate suggestions - me switching to Reaper as my prime DAW depends on it.

Cheers guys!

Last edited by marcusonic; 06-09-2019 at 01:58 AM.
marcusonic is offline   Reply With Quote
Old 06-10-2019, 11:40 AM   #484
themixtape
Human being with feelings
 
themixtape's Avatar
 
Join Date: Aug 2009
Posts: 705
Default

No support for Maschine Jam yet? Thanks!
themixtape is offline   Reply With Quote
Old 06-10-2019, 02:16 PM   #485
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 408
Default

Quote:
Originally Posted by flipotto View Post
I would like to be able to choose which device controls show up for the 8 knobs (banks) on the push 2 screen.
When I select device there are several banks and the controls are NOT in usable order. I would like to be able to modify that order of device parameters.

Not sure how to accomplish this...
One suggestion:If I could map controls to the track control knobs
see pic
then be able show those on the device screen, I could customize my shown parameters.
Good point. The correct solution would be to have a paging and mapping mechanism in Reaper itself. Will think about it.
moss is offline   Reply With Quote
Old 06-10-2019, 02:18 PM   #486
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 408
Default

Quote:
Originally Posted by vibralux View Post
First of all, Moss - thanks for this incredibly useful tool. I really wanted someone to invent this.
And I am almost in heaven. I write "almost" as the whole thing works for me, but just at the beginning.
Afer some time (usually next day) Reaper starts to act strangely - i freezes and quits altogether by
itself. When I remove the scripts it all goes back to normal. I have followed all the isntructions
and I believe I did everything as should as it works after installation. Any ideas what might be
the culprit? I work on Win 10 64bit, newest Reaper.
Hi. Are you saying that you leave Reaper running for a day and then it crashes or if you start it the next day it crashes?
moss is offline   Reply With Quote
Old 06-10-2019, 02:20 PM   #487
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 408
Default

Quote:
Originally Posted by marcusonic View Post
Hi!
Spec:
- Windows 10 1903 Update
- Current Reaper version (5.978 as of this writing)

I installed the extension as instructed and it does show up in the panel, as it should. When I select the entry, I only get this message:

- Tested on a Windows 10, 1809 Update (Previous Windows update) - WORKING

To make sure it's a Windows issue, I installed Reaper on a Manjaro Linux, installed the plugin there, and connected the Akai APC Mini - WORKING!
That's bad news and from your tests it seems that there is an issue with 1903. Since the last disaster with 1809, I wanted to stay away from it for a while...
Maybe you can roll back for the time being.
moss is offline   Reply With Quote
Old 06-10-2019, 02:21 PM   #488
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 408
Default

Quote:
Originally Posted by themixtape View Post
No support for Maschine Jam yet? Thanks!
It do not have a Jam, so this will not happen.
moss is offline   Reply With Quote
Old 06-11-2019, 12:43 AM   #489
marcusonic
Human being with feelings
 
Join Date: Jun 2019
Posts: 5
Default

Quote:
Originally Posted by moss View Post
That's bad news and from your tests it seems that there is an issue with 1903. Since the last disaster with 1809, I wanted to stay away from it for a while...
Maybe you can roll back for the time being.
Thanks, I figured as much.

I also want to add that with the Reaper Linux version on Ubuntu 19.04, the Java runtime is being detected... BUT! Then Reaper becomes unresponsive, the "Configure" button seems to be unclickable... although I managed to open the config panel once and managed to light up the lights on the Akai APC mini... Beyond that, Reaper's rendering goes sideways and I am unable to click anything, even closing a window is no longer possible. The only way out is with GNOME's system monitor, and kill Reaper.

Looks like I won't be able to use the Akai APC mini with Reaper - I was really looking forward to it because I liked the flow you showed in the video, especially with regions being sessions and all. Ah well. Can't have everything in life eh?
marcusonic is offline   Reply With Quote
Old 06-12-2019, 05:38 AM   #490
marcusonic
Human being with feelings
 
Join Date: Jun 2019
Posts: 5
Default

So... just to conclude this topic, and this is funniest thing of them all -

I installed the Windows version of Reaper on Ubuntu 19.04 with Wine, and installed the Windows version of the extension..... works.

Bizarre. But interesting.
marcusonic is offline   Reply With Quote
Old 06-13-2019, 05:04 AM   #491
chazroot
Human being with feelings
 
chazroot's Avatar
 
Join Date: Mar 2016
Location: South Wales, NY USA
Posts: 8
Default Icon QCon Pro G2

Hello,

We just purchased an Icon QCon Pro G2 to replace our old Presonus FaderPort Classic that finally died after years of service. We read the sales literature and watched the videos. This unit was advertised to work with all DAWs. Including Reaper.

Well, that's not exactly true. We tested the unit on a brand new, maxed out 2019 iMac with the current versions of OS X, Reaper, and Logic Pro X installed. It does not work out of the box.

We opened a support ticket directly with Icon Pro Audio. We never heard back from them so we reached out to MixWare, their US distributor.

MixWare advised us to install Windows dll files on our Mac to fix the problem. Wait, what? Really? Then they advised us to download the third-party DrivenByMoss scripts, which led us here.

Herr Mo▀graber's "DrivenByMoss4Reaper" appears to be coded for the Icon QCon Pro X, not the Pro G2 that we purchased. We reminded MixWare of this and they said to do it anyway because it will work.

It does not.

This is not a critique of Herr Mo▀graber's very fine work. It is, however, a warning to fellow Reaper users about Icon Pro Audio. Their sales literature and product ads contain false advertising.

They are knowingly selling a product that does not do what they claim. They do not support their products, do not respond to customer support requests, and their US distributor is grasping at straws in the dark.

We would LOVE to have this unit operate properly. The hardware build quality is nice, but the drivers, libraries, and software side are a trainwreck.

We would be interested in knowing if Herr Mo▀graber has any plans to include configurations for the Icon QCon Pro G2 in his software.

Thank you.
__________________
chazroot
Charles H. Root, III
www.electricowlworks.com

Last edited by chazroot; 06-13-2019 at 05:20 AM. Reason: Typo
chazroot is offline   Reply With Quote
Old 06-13-2019, 04:45 PM   #492
poetnprophet
Human being with feelings
 
poetnprophet's Avatar
 
Join Date: Jan 2018
Posts: 982
Default

Well, I will chime in about both this plugin and Icon in general. I have an Icon ProX and XS, and to be fair to Icon and Mixware, I have always gotten through to customer service and gotten some help, even before I bought the product. In fact, I just got an RMA from Mixware today to get something repaired (Yes, the thing broke!). I don't know about the G2, but I have had no major issues with setting up the ProX with 3 different plugins (Stock, CSI, and Klinke....oh, and this one!). You actually didn't even list what kind of issues you're having here, so...

Anyway, onto the feedback for the ProX and the Moss plugin:

First, love the user interface and how easy it is to set everything up. In that regard, it's great!

Meters, the ProX has a meter bridge. The meter levels are low, however. When the level should be 1 light from the top, the meter tops out at 4-5 lights down. There doesn't seem to be a way to calibrate that.

Banking +/- 8 does not work. Single track banking works, but not the buttons for 8.

CPU and lag. This plugin definitely definitely uses more CPU than I would want. An identical project will be much more slow to respond to anything when I enable this versus the other control surface integrators. This is the dealbreaker for me.

Appreciate the work on this, if you ever address those issues i'm happy to try it again.

cheers,
Dave
__________________
https://www.kdubbproductions.com/
https://www.youtube.com/channel/UCpC...2dGA3qUWBKrXQQ
i7 8700k,4.9Ghz,Win10,Reaper 5,Motu 828es,MJE Hulk 990,GAP Pre73/EQ81
poetnprophet is online now   Reply With Quote
Old 06-13-2019, 05:26 PM   #493
chazroot
Human being with feelings
 
chazroot's Avatar
 
Join Date: Mar 2016
Location: South Wales, NY USA
Posts: 8
Default Re:

Greetings Dave!

I didn't post the message regarding the Icon QCon Pro GS with any expectation that someone in the Reaper userbase would be able to assist me. That's why I didn't include specific issues.

I posted the message to alert fellow Reaper users to our disappointing experience with a product, it's manufacturer, and their support team.

When you spend $700 on a product that claims to have a specific feature set you expect it to work.

I'd hate to see other Reaper users lured into purchasing the unit and then going through what we have.

Good luck with your situation!

Best Regards,

chaz
__________________
chazroot
Charles H. Root, III
www.electricowlworks.com
chazroot is offline   Reply With Quote
Old 06-13-2019, 09:07 PM   #494
poetnprophet
Human being with feelings
 
poetnprophet's Avatar
 
Join Date: Jan 2018
Posts: 982
Default

You still haven't said what exactly you problem is but you're quick to say how disappointed you are and how bad the company is, and I just want to both try and help and make sure Icon isn't getting a bad reputation for no real reason.

Here's a very clunky video of me going through the entire setup process and a demo of functions, it's not that hard to setup. https://www.youtube.com/watch?v=b3xUHkhb-XI&t=2s
__________________
https://www.kdubbproductions.com/
https://www.youtube.com/channel/UCpC...2dGA3qUWBKrXQQ
i7 8700k,4.9Ghz,Win10,Reaper 5,Motu 828es,MJE Hulk 990,GAP Pre73/EQ81
poetnprophet is online now   Reply With Quote
Old 06-14-2019, 12:28 AM   #495
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 408
Default

Quote:
Originally Posted by chazroot View Post
Greetings Dave!

I didn't post the message regarding the Icon QCon Pro GS with any expectation that someone in the Reaper userbase would be able to assist me. That's why I didn't include specific issues.

I posted the message to alert fellow Reaper users to our disappointing experience with a product, it's manufacturer, and their support team.

When you spend $700 on a product that claims to have a specific feature set you expect it to work.

I'd hate to see other Reaper users lured into purchasing the unit and then going through what we have.

Good luck with your situation!

Best Regards,

chaz
Hi Chaz,

maybe some clarifictions first: all icon devices use the Mackie MCU protocol, with some additions for the ProX series. Therefore, with any DAW you "simply" need MCU support. That's way beyond perfect since each DAW interprets the protocol different and puts different commands on different buttons.
Anyway, with Reaper you have several options you can install to support MCU. One of them is DrivenByMoss4Reaper.
I have links on the download page to the documentation Wiki and my Youtube channel with installation tutorials. After you have installed the extension add a MCU device. The drop down list, which might have confused you, is only for quick presets. If your device misses in the list, simply dis-/enable the hardware options depending on the capabilities of your device.
If you have any specific questions feel free to ask.

Cheers!
moss is offline   Reply With Quote
Old 06-14-2019, 01:46 AM   #496
chazroot
Human being with feelings
 
chazroot's Avatar
 
Join Date: Mar 2016
Location: South Wales, NY USA
Posts: 8
Default

Moss!

Thank you so much for your message!

I'll look around your wiki, documentation, and attempt to wrap my head around all of this. In a past life, I was a programmer/developer who became a CIO/CTO for some global organizations.

I really do like the Icon hardware and I suppose I have the background to roll up my sleeves and make this unit work properly.

Thank you again.

Best Regards,

Chaz
__________________
chazroot
Charles H. Root, III
www.electricowlworks.com
chazroot is offline   Reply With Quote
Old 06-14-2019, 02:08 AM   #497
chazroot
Human being with feelings
 
chazroot's Avatar
 
Join Date: Mar 2016
Location: South Wales, NY USA
Posts: 8
Default

Quote:
Originally Posted by moss View Post
Hi Chaz,

maybe some clarifictions first: all icon devices use the Mackie MCU protocol, with some additions for the ProX series. Therefore, with any DAW you "simply" need MCU support. That's way beyond perfect since each DAW interprets the protocol different and puts different commands on different buttons.
Anyway, with Reaper you have several options you can install to support MCU. One of them is DrivenByMoss4Reaper.
I have links on the download page to the documentation Wiki and my Youtube channel with installation tutorials. After you have installed the extension add a MCU device. The drop down list, which might have confused you, is only for quick presets. If your device misses in the list, simply dis-/enable the hardware options depending on the capabilities of your device.
If you have any specific questions feel free to ask.

Cheers!
Hey JŘrgen,

I do have a quick question.

Was the DrivenByMoss4Reaper functionality for the Icon QCon Pro X designed to match the functions printed on the hardware unit itself or the functions printed on the Reaper overlay card provided by Icon?

Thanks again!

chaz
__________________
chazroot
Charles H. Root, III
www.electricowlworks.com
chazroot is offline   Reply With Quote
Old 06-14-2019, 04:39 AM   #498
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 408
Default

Quote:
Originally Posted by chazroot View Post
Hey JŘrgen,

I do have a quick question.

Was the DrivenByMoss4Reaper functionality for the Icon QCon Pro X designed to match the functions printed on the hardware unit itself or the functions printed on the Reaper overlay card provided by Icon?

Thanks again!

chaz
Actually the Bitwig one :-) Since DrivenByMoss4Reaper is derived from DrivenByMoss for Bitwig.
moss is offline   Reply With Quote
Old 06-16-2019, 10:10 AM   #499
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 408
Default

Quote:
Originally Posted by marcusonic View Post
Thanks, I figured as much.

I also want to add that with the Reaper Linux version on Ubuntu 19.04, the Java runtime is being detected... BUT! Then Reaper becomes unresponsive, the "Configure" button seems to be unclickable... although I managed to open the config panel once and managed to light up the lights on the Akai APC mini... Beyond that, Reaper's rendering goes sideways and I am unable to click anything, even closing a window is no longer possible. The only way out is with GNOME's system monitor, and kill Reaper.

Looks like I won't be able to use the Akai APC mini with Reaper - I was really looking forward to it because I liked the flow you showed in the video, especially with regions being sessions and all. Ah well. Can't have everything in life eh?
I updated my Linux installation to 19.04. I use Ubuntu Studio which comes with Xfce as desktop manager. On my system everything works fine.
moss is offline   Reply With Quote
Old 06-19-2019, 02:52 PM   #500
southpaw
Human being with feelings
 
Join Date: Jul 2011
Location: Not LA.
Posts: 145
Default

Hey All

I am currently trying to get my NI KK S49 Mk2 running and have installed the library and plugin package, selected MOSS under controllers and added my KK s40 Mk2 in the Moss setup window. The Java library shows correctly and the keyboard shows connected.

The issue I am having is that although the plugin control works, the transport controls etc are not working. Am I missing a step somewhere? I have disabled the KK from the MIDI device section per your suggestion to prevent issues.

Thanks!
__________________
www.johnlongley.com
World Class Mixing & Mastering
southpaw is offline   Reply With Quote
Old 06-19-2019, 03:13 PM   #501
poetnprophet
Human being with feelings
 
poetnprophet's Avatar
 
Join Date: Jan 2018
Posts: 982
Default

Quote:
Originally Posted by poetnprophet View Post

Anyway, onto the feedback for the ProX and the Moss plugin:

First, love the user interface and how easy it is to set everything up. In that regard, it's great!

Meters, the ProX has a meter bridge. The meter levels are low, however. When the level should be 1 light from the top, the meter tops out at 4-5 lights down. There doesn't seem to be a way to calibrate that.

Banking +/- 8 does not work. Single track banking works, but not the buttons for 8.

CPU and lag. This plugin definitely definitely uses more CPU than I would want. An identical project will be much more slow to respond to anything when I enable this versus the other control surface integrators. This is the dealbreaker for me.

Appreciate the work on this, if you ever address those issues i'm happy to try it again.

cheers,
Dave
Hi Moss, just checking if you have any answers to my feedback on the icon ProX issues above? Icon has your controller integration as an option on their website support page, so it would be great to make sure it's all working properly.

Oh, and the master meters do not work, either....I forgot to mention that.
__________________
https://www.kdubbproductions.com/
https://www.youtube.com/channel/UCpC...2dGA3qUWBKrXQQ
i7 8700k,4.9Ghz,Win10,Reaper 5,Motu 828es,MJE Hulk 990,GAP Pre73/EQ81
poetnprophet is online now   Reply With Quote
Old 06-19-2019, 11:33 PM   #502
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 408
Default

Quote:
Originally Posted by southpaw View Post
Hey All

I am currently trying to get my NI KK S49 Mk2 running and have installed the library and plugin package, selected MOSS under controllers and added my KK s40 Mk2 in the Moss setup window. The Java library shows correctly and the keyboard shows connected.

The issue I am having is that although the plugin control works, the transport controls etc are not working. Am I missing a step somewhere? I have disabled the KK from the MIDI device section per your suggestion to prevent issues.

Thanks!
Just answered you on Youtube.
moss is offline   Reply With Quote
Old 06-19-2019, 11:34 PM   #503
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 408
Default

Quote:
Originally Posted by poetnprophet View Post
Hi Moss, just checking if you have any answers to my feedback on the icon ProX issues above? Icon has your controller integration as an option on their website support page, so it would be great to make sure it's all working properly.

Oh, and the master meters do not work, either....I forgot to mention that.
Uh, sorry did not notice questions in your post. SO, to understand you use the QCon ProX? Everything works except the banking buttons and the Stereo meters?
What is the Firmware number you are running? What is your OS?
moss is offline   Reply With Quote
Old 06-20-2019, 02:30 PM   #504
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,745
Default

Quote:
Originally Posted by moss View Post
Uh, sorry did not notice questions in your post. SO, to understand you use the QCon ProX? Everything works except the banking buttons and the Stereo meters?
What is the Firmware number you are running? What is your OS?
The Qcon ProX Master VU requires 0xd1 for the first byte, the standard MCU VU requires 0xd0, I think that's the only difference.
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 06-20-2019, 03:44 PM   #505
poetnprophet
Human being with feelings
 
poetnprophet's Avatar
 
Join Date: Jan 2018
Posts: 982
Default

Quote:
Originally Posted by moss View Post
Uh, sorry did not notice questions in your post. SO, to understand you use the QCon ProX? Everything works except the banking buttons and the Stereo meters?
What is the Firmware number you are running? What is your OS?
Yes the ProX. So far that's what I have discovered, but also the channel meters feedback level is a little low.

Firmware was 1.15 (now it's 2.21) and Windows 10 64bit.

Thank you for checking.
__________________
https://www.kdubbproductions.com/
https://www.youtube.com/channel/UCpC...2dGA3qUWBKrXQQ
i7 8700k,4.9Ghz,Win10,Reaper 5,Motu 828es,MJE Hulk 990,GAP Pre73/EQ81
poetnprophet is online now   Reply With Quote
Old 06-21-2019, 02:20 AM   #506
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 408
Default

Quote:
Originally Posted by poetnprophet View Post
Yes the ProX. So far that's what I have discovered, but also the channel meters feedback level is a little low.

Firmware was 1.15 (now it's 2.21) and Windows 10 64bit.

Thank you for checking.
Works fine here with 1.15. Will try to update and see if there is an issue.
moss is offline   Reply With Quote
Old 06-21-2019, 12:55 PM   #507
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 408
Default

Quote:
Originally Posted by poetnprophet View Post
Yes the ProX. So far that's what I have discovered, but also the channel meters feedback level is a little low.

Firmware was 1.15 (now it's 2.21) and Windows 10 64bit.
I updated the Firmware of my device and it works with that version, too. But I reverted back to 1.15 since I do not like the new layout and you loose some functions. Maybe give that a try, too.
moss is offline   Reply With Quote
Old 06-21-2019, 01:03 PM   #508
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 408
Default

Quote:
Originally Posted by marcusonic View Post
Hi!

My first post and already it's a technical question. I have one of them Akai APC Minis, and I'd like to use it with Reaper. But I seem to hit a dead-end, and I don't know what else to do.

Spec:
- Windows 10 1903 Update
- Current Reaper version (5.978 as of this writing)
I updated now my system to 1903, as well as latest patches. Also I updated to Reaper 5.979.
Works fine for me.
Maybe you can give it another spin.
moss is offline   Reply With Quote
Old 06-23-2019, 01:05 AM   #509
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 408
Default

I just released DrivenByMoss 7.0!
  • New: Added support for Novation SL Mk III
  • Fixed: scrolling of parameter pages by page bank did not work (e.g. Shift + cursor left/right on Push)
  • Ableton Push 2
    • New: Deactivated channels and layers are drawn in dark colors
  • Komplete Kontrol Mk II / A-series / M32
    • New: Light record button as well on clip recording and clip overdub

http://www.mossgrabers.de/Software/Reaper/Reaper.html

Enjoy!
moss is offline   Reply With Quote
Old 06-26-2019, 11:42 AM   #510
juxjux
Human being with feelings
 
Join Date: Jun 2019
Posts: 2
Default

I just got a Komplete Kontrol M32 and while I was able to get transport controls to work in Reaper, when DrivenByMoss4Reaper was configured, the knobs on my keyboard stopped controlling the Kontrol VST knobs and would only control track volumes. I tried looking around for anyone else having this issue but haven't found anything so far, so I'm thinking I must be doing something wrong. I'm pretty new to this, so any help would be much appreciated.
juxjux is offline   Reply With Quote
Old 06-27-2019, 12:45 AM   #511
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 408
Default

Quote:
Originally Posted by juxjux View Post
I just got a Komplete Kontrol M32 and while I was able to get transport controls to work in Reaper, when DrivenByMoss4Reaper was configured, the knobs on my keyboard stopped controlling the Kontrol VST knobs and would only control track volumes. I tried looking around for anyone else having this issue but haven't found anything so far, so I'm thinking I must be doing something wrong. I'm pretty new to this, so any help would be much appreciated.
Did you disable all MIDI in- and output ports of the Komplete M32 in Reaper?
moss is offline   Reply With Quote
Old 06-27-2019, 06:12 PM   #512
juxjux
Human being with feelings
 
Join Date: Jun 2019
Posts: 2
Default

Quote:
Originally Posted by moss View Post
Did you disable all MIDI in- and output ports of the Komplete M32 in Reaper?
I believe I did. I went to Audio > MIDI Devices and Komplete Kontrol is disabled for input and output and it is no longer an option when selecting MIDI input channels for a track.

Edit: I think I figured it out. As I figured, it was user error. Thank you for your help and for creating and supporting such a great tool!

Last edited by juxjux; 06-27-2019 at 06:30 PM.
juxjux is offline   Reply With Quote
Old 06-30-2019, 04:25 AM   #513
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 408
Default

Version 7.01 is online!

Get it from http://www.mossgrabers.de/Software/Reaper/Reaper.html
  • Fixed: Reaper INI was not read on Linux.
  • Arturia Beatstep
    • Fixed: Caught exception when pads are transposed. Now an error is printed to the console.
  • Generic Flexi
    • Fixed: MMC commands with device IDs > 15 did not work.
  • Novation SL Mk III
    • New: Route all 16 MIDI channels to Reaper (not only channel 1)

Enjoy!
moss is offline   Reply With Quote
Old 06-30-2019, 12:11 PM   #514
themixtape
Human being with feelings
 
themixtape's Avatar
 
Join Date: Aug 2009
Posts: 705
Default

Pretty amazing script! I have an SL MKIII and love it. The standard HUI mode is garbage (and it only works in HUI Partial). This is REALLY cool.

Any chance the Bitwig sequencer/session stuff might work with the Reaper Playtime plugin? That would be so cool. I just get so confused with the Grid view, which lights up the pads but basically does nothing... and the Sequencer Resolution mode (right arrow)... again, does nothing (because originally it is a Bitwig extension). Again, thank you for doing this. Really, really cool stuff.

Do you plan on doing a separate Reaper guide/manual or video? Maybe with notes saying what DOESN'T work (Bitwig-only stuff)? Or maybe slightly modifying the script to remove the non-workable stuff for Reaper?

Thanks again, Moss!!! Tremendous work!!!

Last edited by themixtape; 06-30-2019 at 12:21 PM.
themixtape is offline   Reply With Quote
Old 07-02-2019, 02:38 AM   #515
themixtape
Human being with feelings
 
themixtape's Avatar
 
Join Date: Aug 2009
Posts: 705
Default

Hi again, Moss... thank you again for your insanely hard work especially with the Novation SL MKIII. I love this, especially Device control with Reaper plugins (having access to the functions of the Megababy sequencer REALLY open it up a lot)... such as the ability to set pattern length with the encoder, or change pattern, change rate... unreal.

I noticed a little strange behavior with the Transport-- the colors change a lot and never stay green/red for play/record... is this normal?

Also, is there any way at all to make the << and >> buttons jump perfectly to the bar? Such as 1:0:0, 2:0:0, 3:0:0 and in reverse, 2:0:0, then 1:0:0? Is this a simple script change or is it really difficult to implement? I need to jog forward and back by bar, or better yet, make the << and >> buttons "previous marker/project start" or "next marker/project end".

I'm still getting the hang of the buttons, encoders and functions but I LOVE THIS... it really blew the doors wide open, instead of that damn "HUI Partial" mode which SUCKED. This is the way to fly. Makes me love my SL MKIII even more!!!
themixtape is offline   Reply With Quote
Old 07-02-2019, 05:11 AM   #516
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 408
Default

Quote:
Originally Posted by themixtape View Post
Hi again, Moss... thank you again for your insanely hard work especially with the Novation SL MKIII. I love this, especially Device control with Reaper plugins (having access to the functions of the Megababy sequencer REALLY open it up a lot)... such as the ability to set pattern length with the encoder, or change pattern, change rate... unreal.

I noticed a little strange behavior with the Transport-- the colors change a lot and never stay green/red for play/record... is this normal?

Also, is there any way at all to make the << and >> buttons jump perfectly to the bar? Such as 1:0:0, 2:0:0, 3:0:0 and in reverse, 2:0:0, then 1:0:0? Is this a simple script change or is it really difficult to implement? I need to jog forward and back by bar, or better yet, make the << and >> buttons "previous marker/project start" or "next marker/project end".

I'm still getting the hang of the buttons, encoders and functions but I LOVE THIS... it really blew the doors wide open, instead of that damn "HUI Partial" mode which SUCKED. This is the way to fly. Makes me love my SL MKIII even more!!!
Hi, I need to look into the Reaper version more closely. I noticed the flickering too and I suspect it might be the System Exclusive implementation of Java on Windows. On Mac I integrated an alternative implementation which should work better but I need to test that. What platform are you on?
moss is offline   Reply With Quote
Old 07-02-2019, 08:12 AM   #517
studer58
Human being with feelings
 
Join Date: Oct 2008
Posts: 179
Default

Hi Jurgen,

I noticed in your GitHub explanation pages you mentioned that you've tested the Mackie MCU control features with a few hardware controllers, including one that I have: the Zoom R16. Can you comment on how many of the R16's buttons, F1-F5, jog wheel, transport controls etc are enabled in Reaper if I use your Driven by Moss script ?

Thank you for developing it, and for any comments you have specifically about this Zoom controller/recorder/interface...including any frustrations or blocked facilities ? I can use the R16 with both Windows and Mac in Reaper, depending on which you recommend as having the best functionality with this Zoom.
studer58 is offline   Reply With Quote
Old 07-02-2019, 11:50 AM   #518
themixtape
Human being with feelings
 
themixtape's Avatar
 
Join Date: Aug 2009
Posts: 705
Default

Quote:
Originally Posted by moss View Post
Hi, I need to look into the Reaper version more closely. I noticed the flickering too and I suspect it might be the System Exclusive implementation of Java on Windows. On Mac I integrated an alternative implementation which should work better but I need to test that. What platform are you on?
Windows 7 SP1, 64-bit. Thanks, Moss! I also tried my S49/S25 (Mk1) with the script... works beautifully, too. Thank you!
themixtape is offline   Reply With Quote
Old 07-03-2019, 12:44 AM   #519
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 408
Default

Quote:
Originally Posted by studer58 View Post
Hi Jurgen,

I noticed in your GitHub explanation pages you mentioned that you've tested the Mackie MCU control features with a few hardware controllers, including one that I have: the Zoom R16. Can you comment on how many of the R16's buttons, F1-F5, jog wheel, transport controls etc are enabled in Reaper if I use your Driven by Moss script ?

Thank you for developing it, and for any comments you have specifically about this Zoom controller/recorder/interface...including any frustrations or blocked facilities ? I can use the R16 with both Windows and Mac in Reaper, depending on which you recommend as having the best functionality with this Zoom.
Without having the device in front of me: Volume, Transport, Functions keys work fine.
moss is offline   Reply With Quote
Old 07-07-2019, 04:07 PM   #520
leighhunt
Human being with feelings
 
Join Date: Jun 2016
Location: London, UK
Posts: 35
Default vsti renaming oddity

Hi there Jurgen,
I have been scratching my head with a random issue with the Komplete Kontrol s61mk2 setup.
New tracks with Komplete Kontrol instances were refusing to automatically link to the S61 keyboard controls and display.
Eventually I found that the fact that I recently renamed the Komplete Kontrol vsti plugin name in the Reaper FX browser was causing this communication breakdown. All instances created since the renaming the vsti were not inking with the s61.
I reverted the change and now all runs smoothly.
Can you confirm this is the case, and if so, is it possible to tweak your code to allow to find the plugin instance if the name is changed in the fx browser or not?
Not a biggie, but 'KK' is less text congestion in my mixer window than 'Komplete Kontrol'!
Many thanks,
Leigh
leighhunt is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:57 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.