View Single Post
Old 02-16-2020, 03:40 PM   #6628
Human being with feelings
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 575

Originally Posted by Funkybot View Post
A few questions.

1A. For TDR Comp are you 100% sure you're not loading the VST2 version and that's why things aren't working? I've done that. "Plugin isn't working - whoops, it's the wrong plugin format."

1B. If you are loading the VST3 of the comp and it's still not working, did you happen to rename the plugin in Reaper? I renamed my TDR plugins in Reaper, but this will of course break the fx.zon files, which need a 100% on the plugin name.

Now...Rotary clue.

Now, while I don't know why it's not working, this is the process I'd follow to troubleshoot:

1. backup your fx.zon file (call it reacomp.bak or something)
2. Create a new ReaComp.zon file
3. Assign a single Toggle+RotaryPush1 (no Shift yet) to a single toggle ReaComp parameter only (save this and restart Reaper of course)
4. Test that one paramater. Does it work? If yes, then...
5. Introduce Shift. Does Shift+Toggle+RotaryPush1 work? Nothing else in the zone, yet, still doing 1 parameter at a time. If yes, that means it can work, then it's a question of "why isn't this working in my original .zon."

If it's not working, then the questions become:

1. Is the syntax correct? If yes, then...

2. Is there a conflict with something else in my fx.zon? Maybe one of the NoActions is preventing messages from getting through.

3. Maybe there's a bug that got introduced? Especially if it worked in a prior build.
hey thanks man.i just sat down to try to find out whats going on .i will go through your checklist.and its definitly the VST3.whats weird is it works wen i use the mouse on reaper screen in have threshold mapped to fader1 when i move fader1 nothing happens but when i move the threshold on screen with the mouse it works..the fader on my surface moves and the values change on the display.try to move the fader itself and nothing ???
Cragster is offline   Reply With Quote