View Single Post
Old 02-16-2020, 10:32 AM   #6627
Human being with feelings
Join Date: Jul 2007
Posts: 2,011

Originally Posted by Cragster View Post
i dont know i think it maybe something i did.some parameters work some dont .today nothing is working in the first plugin i posted(TDR Comp)

in the Reacomp evrything seems to work but the rotary pushes. they will work but will not once i rotarypush once it doesnt work again after that.i just recently added all the noactions but im sure i tested evrything after i did that. it all workrd fine at one time thats all i know.maybe you can see something that im not seeing.i switched to anearlier build and it was same so its gotta be me.once i have time i will try some even earlier builds to be sure.since there has been a few updates in this last week. thanks all for your help
A few questions.

1A. For TDR Comp are you 100% sure you're not loading the VST2 version and that's why things aren't working? I've done that. "Plugin isn't working - whoops, it's the wrong plugin format."

1B. If you are loading the VST3 of the comp and it's still not working, did you happen to rename the plugin in Reaper? I renamed my TDR plugins in Reaper, but this will of course break the fx.zon files, which need a 100% on the plugin name.

Now...Rotary clue.

Now, while I don't know why it's not working, this is the process I'd follow to troubleshoot:

1. backup your fx.zon file (call it reacomp.bak or something)
2. Create a new ReaComp.zon file
3. Assign a single Toggle+RotaryPush1 (no Shift yet) to a single toggle ReaComp parameter only (save this and restart Reaper of course)
4. Test that one paramater. Does it work? If yes, then...
5. Introduce Shift. Does Shift+Toggle+RotaryPush1 work? Nothing else in the zone, yet, still doing 1 parameter at a time. If yes, that means it can work, then it's a question of "why isn't this working in my original .zon."

If it's not working, then the questions become:

1. Is the syntax correct? If yes, then...

2. Is there a conflict with something else in my fx.zon? Maybe one of the NoActions is preventing messages from getting through.

3. Maybe there's a bug that got introduced? Especially if it worked in a prior build.
Funkybot is offline   Reply With Quote