View Single Post
Old 10-10-2018, 08:41 AM   #9
cfillion
Human being with feelings
 
cfillion's Avatar
 
Join Date: May 2015
Location: Québec, Canada
Posts: 2,241
Default

This has nothing to do with WDL. You are seeing this message because the project was made for VS2013. Do the "Retarget solution" it suggests.

SWS can be made to build fine with VS2017 (that's what I use too) but be aware WDL's JNetLib needs to be patched for it (otherwise the SWS auto-update feature won't work properly): https://github.com/cfillion/WDL/comm...82ad08d2.patch.

Also the sws repository contains pre-built versions of TagLib (a bad idea in my opinion, but I digress...). You'll either need to go through the trouble of rebuilding it with VS2017 or just add NO_TAGLIB to the pre-processor definitions to disable that feature entirely.
cfillion is offline   Reply With Quote