View Single Post
Old 08-20-2017, 05:54 PM   #110
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 536
Default

Quote:
Originally Posted by 4duhwinnn View Post
Using the batch convert fails in pclinuxos distro with wine 2.13
and mentions requiring GLIBCXX_3.4.21

command: strings /usr/lib/libstdc++.so.6 | grep GLIBC

shows the highest installed is GLIBCXX_3.4.20

and a newer lidsttdc++ is not ready for pclinuxos distro.
Doing a compile, the make process has this conclusion:

[me@localhost LinVst-1.2]$ make
g++ -fPIC -O2 -DAMT -DRINGB -c linvst.cpp -o linvst.unix.o
g++ -fPIC -O2 -DAMT -DRINGB -c remotevstclient.cpp -o remotevstclient.unix.o
g++ -fPIC -O2 -DAMT -DRINGB -c remotepluginclient.cpp -o remotepluginclient.unix.o
g++ -fPIC -O2 -DAMT -DRINGB -c paths.cpp -o paths.unix.o
g++ linvst.unix.o remotevstclient.unix.o remotepluginclient.unix.o paths.unix.o -shared -lpthread -ldl -lrt -o linvst.so
wineg++ -m64 -O2 -DAMT -DRINGB -I/usr/include/wine-development/windows -c lin-vst-server.cpp -o lin-vst-server.wine.o
wineg++ -m64 -O2 -DAMT -DRINGB -I/usr/include/wine-development/windows -c remotepluginserver.cpp -o remotepluginserver.wine.o
remotepluginserver.cpp: In member function ‘void RemotePluginServer::dispatchProcess(int)’:
remotepluginserver.cpp:744:13: error: ‘errno’ was not declared in this scope
if (errno == ETIMEDOUT) {
^
remotepluginserver.cpp:744:22: error: ‘ETIMEDOUT’ was not declared in this scope
if (errno == ETIMEDOUT) {
^
remotepluginserver.cpp: In member function ‘void RemotePluginServer::dispatchGetSet(int)’:
remotepluginserver.cpp:835:13: error: ‘errno’ was not declared in this scope
if (errno == ETIMEDOUT) {
^
remotepluginserver.cpp:835:22: error: ‘ETIMEDOUT’ was not declared in this scope
if (errno == ETIMEDOUT) {
^
remotepluginserver.cpp: In member function ‘void RemotePluginServer::rdwr_tryWrite2(int, const void*, size_t, const char*, int)’:
remotepluginserver.cpp:1331:13: error: ‘errno’ was not declared in this scope
if (errno == EPIPE)
^
remotepluginserver.cpp:1331:22: error: ‘EPIPE’ was not declared in this scope
if (errno == EPIPE)
^
remotepluginserver.cpp:1337:10: error: ‘errno’ was not declared in this scope
if (errno != EAGAIN) {
^
remotepluginserver.cpp:1337:19: error: ‘EAGAIN’ was not declared in this scope
if (errno != EAGAIN) {
^
remotepluginserver.cpp: In member function ‘void RemotePluginServer::rdwr_tryRead
(int, void*, size_t, const char*, int)’:
remotepluginserver.cpp:1372:10: error: ‘errno’ was not declared in this scope
if (errno != EAGAIN) {
^
remotepluginserver.cpp:1372:19: error: ‘EAGAIN’ was not declared in this scope
if (errno != EAGAIN) {
^
remotepluginserver.cpp: In member function ‘void RemotePluginServer::rdwr_tryWrit
e(int, const void*, size_t, const char*, int)’:
remotepluginserver.cpp:1397:13: error: ‘errno’ was not declared in this scope
if (errno == EPIPE)
^
remotepluginserver.cpp:1397:22: error: ‘EPIPE’ was not declared in this scope
if (errno == EPIPE)
^
winegcc: g++ failed
Makefile:55: recipe for target 'remotepluginserver.wine.o' failed
make: *** [remotepluginserver.wine.o] Error 2

----------------------------------------
Any suggestions? (the batch convert works fine in mint 18
on the same computer)
Cheers


Seems like it's this https://github.com/osxmidi/LinVst/issues/15

Seems that on some systems #include <errno.h> needs to be added
to remotepluginserver.cpp

I've updated LinVst at Github to include the change.
osxmidi is offline   Reply With Quote