View Single Post
Old 01-01-2020, 05:47 PM   #5774
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,060
Default

Quote:
Originally Posted by Funkybot View Post
Just tried Eucon again...

1. It started on Track 9 this time. I'm assuming because the MFTwister was channels 1-8.

So my side question is this: would it be possible to have both units act independently of each other in the current iteration of CSI? So tracks 1-8 could appear on both surfaces if I wanted and I could bank them independently? If so, how would I set that up?
Not yet, but that feature is planned.

Quote:
Originally Posted by Funkybot View Post
2. As to Eucon itself...only one fader is operational per bank. Example: when I had tracks 9-16 showing, only the fader for the clap track (channel 11) came up. The rest remained at zero. When I removed the MFTwister and tried again, only the Hat channel (#6) in bank 1-8 was operational, and the clap channel (11) in the next track bank.

These were tied to different faders on the Artist Mix so it's not like it was the same fader and the others didn't work at all. Also, if I nudged the track, the working channel fader nudged accordingly.


[EDIT]
I found the problem! If a track in a project has it's faders at unity level, CSI/Eucon isn't moving the fader to the correct position when it initializes the surface. It's treating it like the fader is at minimum level versus 0db/unity. The second I move the faders with my mouse and change their levels, it's fine. This is just a test project I've been using to try CSI stuff out on, so a lot of the tracks are at unity and it was looking like the faders weren't working because they were staying at their minimum value. Hopefully this is an easy fix for Geoff.

3. When you restart Reaper, the surface does become active (i.e. the Pan and channel numbers appear as soon as Reaper opens) so there's some communication happening between Reaper and Eucon. But if I open a project, nothing changes. I even tried "Restart all Eucon applications" to see if that would work, and there was no change. Note: we're not talking about it disconnecting after a long period of inactivity or anything. This was all within a minute.

I can get it to wake up again but I have to 1) open a project first, 2) remove Eucon from the Control Surfaces, then 3) add Eucon again for it to fire back up.
Ah, try this, double click on a project file and start Reaper that way, see what happens.
__________________
CSI - You can donate here: geoffwaddington.ca
Beta software: https://stash.reaper.fm/v/38349/CSI%20beta.zip
installation and documentation here: https://github.com/malcolmgroves/reaper_csi/wiki
Geoff Waddington is offline   Reply With Quote