View Single Post
Old 10-05-2018, 08:27 PM   #577
Human being with feelings
Join Date: Feb 2014
Posts: 583

Originally Posted by somethingtohide View Post
Would you kindly share any more information about this topic? I have Waves Central working a while back, but I wanted to try it out again and I cannot get it to work! For reference, I'm on Arch Linux and Wine Staging 3.17.r39, although I've tried this numerous times since 3.12. I *always* get the unable to detect devices message, where it says there's no USB or network card. I can install plugins, but not activate them. I've always tried with new wineprefixes and with the necessary startup steps listed before, e.g. robotools, mfc42*, regedit.

I've tried rebooting, fresh prefixes, with/without USBs before/after installing the prefix, messing with Drives in winecfg, multiple wine-staging versions, and probably more than that! I need some clues as to what to do here... I'm sure that at some point in my three-year-old setup that I've removed devices without unmounting them, but I doubt that would affect this. A clean reboot, insert USB, clean wineprefix, and install Waves Central does not seem to fix this.

I don't know what/how it's checking, but it fails every time on my machine. The only related thing that I can think of is about the network. I also use QEMU and I have multiple bridges setup with a couple of NICs. That may be different that the average user and causes this issue. What a pain!

Need Wine Staging 3.15 or above.

Need to install robocopy and add a few reg entries (details in the LinVst github readme).

Put a usb stick in and run winecfg and have a look at the drives tab and see if the usb shows up as a windows drive letter.

Waves Central seems to need a usb stick before it will activate licences and the usb stick has to be working with Wine and maybe not all distros are the same when it comes to Wine and usb.

Make sure the usb stick is working with Wine and insert the usb stick before starting Waves Central.

Transferring licenses from usb sticks is probably not going to work because of Wines limitations in that area but transferring licenses to drive_c from the cloud (and vice versa) should work and maybe an actual usb (hard) drive might work (not a usb flash or stick).

Last edited by osxmidi; 10-05-2018 at 10:06 PM.
osxmidi is offline   Reply With Quote