View Single Post
Old 01-17-2019, 03:07 AM   #250
Human being with feelings
Join Date: Jan 2018
Posts: 115

Originally Posted by moss View Post
You did not uninstall Version 2.0 correctly (which used this script). See the Version 3.0 introduction video from minute 2:00 I explain how to uninstall V2.0:
Thanks, that solved that issue.

I am not sure if I followed your explanations above: you are saying it works now on one Mac but not on the other (with the above error)?
So like most of us I have a desktop and laptop, Mac Pro 2009 Macbook Pro 2012.
After that one little thing with the old version the laptop works perfectly. No issues OS Mojave.

I've mostly been working with the Mac Pro, this is the computer that for whatever reason just does not work with your wonderful software... The LED display shows nothing. All the buttons and pads light up but the display screen is blank. I've tried as much as I can think of to get it to work.

I've tried:

Unplugging all USB devices and hubs from the computer, only the Push 2.

Starting Reaper as root, this kills Reapers license every time, and Reaper then refuses to see the REAPER folder and loads ini files into the Application folder next to Reaper.. oh and the display is still blank.

Removing all VSTs.

Uninstalling Reaper, all preferences and dependancies.

Installing High Sierra since I was on Sierra. (the video card doesn't support Mojave)

I loaded all the odd drivers for things like the Slate Raven (V-Control Pro and UPDD software etc.) I had on the desktop on the laptop to see if that caused the laptop to suffer the same problem, but it just worked fine...

The Desktop Mac Pro continues to throw out this warning etc. in the Logging for the controller in Reaper. (the laptop does not)

Loading device INI files from /Users/machines/Library/Application Support/REAPER ...
/Users/machines/Library/Application Support/REAPER/reaper-fxfolders.ini not present, skipped loading.
Starting controller 'Ableton Push 2 - 11.03'
Unable to claim interface.
org.usb4java.LibUsbException: USB error 99: Other error
at de.mossgrabers.reaper.framework.usb.UsbDeviceImpl. getEndpoint(
at de.mossgrabers.controller.push.controller.PushUsbD isplay.<init>(
at de.mossgrabers.controller.push.controller.PushDisp lay.<init>(
at de.mossgrabers.controller.push.PushControllerSetup .createDisplay(
at de.mossgrabers.controller.push.PushControllerSetup .createSurface(
at de.mossgrabers.framework.controller.AbstractContro llerSetup.init(
at de.mossgrabers.reaper.controller.AbstractControlle rInstance.lambda$start$1(AbstractControllerInstanc
at de.mossgrabers.reaper.ui.utils.SafeRunLater.lambda $execute$0(
at java.desktop/java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.desktop/java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.desktop/java.awt.EventQueue$ Source)
at java.desktop/java.awt.EventQueue$ Source)
at java.base/ Method)
at java.base/$JavaSecurityAccessI mpl.doIntersectionPrivilege(Unknown Source)
at java.desktop/java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilter s(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(U nknown Source)
at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarch y(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.desktop/ Source)

machinesworking is offline   Reply With Quote