View Single Post
Old 11-09-2019, 02:38 PM   #8
xpander
Human being with feelings
 
xpander's Avatar
 
Join Date: Jun 2007
Location: Terra incognita
Posts: 5,272
Default

Quote:
Originally Posted by worldwideweary View Post
Let it be known that on default settings, with the addition of making MIDI be of external files and not in-project: merely create a midi clip in Reaper (Ctrl drag) and it won't enter into inline editing by pressing 'E'. You said that it works for you, so I'm not sure if there's another setting I can enable to allow this to work for me. Any extra details so that I can have it work like you said?
So far I've only tested editing of imported MIDI files with the earlier given preferences (.MID files/.MID file reference). Inline editing works for them if the MIDI files are type 1. You added a good point about that working only because type 1 files are automatically converted into in-project items, regardless of import settings...I didn't pay attention to that aspect.

Now, inline editing won't work for newly created MIDI items inside Reaper either (again, with given preferences) and that could be for the same reason it won't work for the imported type 0 files. I use always in-project MIDI items insted of .mid files, so simply don't face these problems. Should I need separate .mid files, I can export them anytime. Imported type 0 files can be glued to become in-project items.

At this stage Im not sure my bug report stands as it is...I would delete it if I could. Ironically it could read just the opposite; type 1 files working in inline editor while they shouldn't. Or more accurately, converting automatically regardless of settings, of course...

Last edited by xpander; 11-09-2019 at 02:52 PM.
xpander is offline   Reply With Quote