View Single Post
Old 06-24-2019, 07:39 PM   #1
Human being with feelings
Join Date: Jun 2019
Posts: 2
Default Reaper/Superior Drummer 2 not recognizing midi drums

So I have my Roland Edrums connected to my liquid saffire 56 midi controller and it's working on my PC with EZdrummer software albeit mapped incorrectly. So I know its working right, but I can't get it to trigger in reaper.
Liquid Saffire controller is enabled+control in preferences. I have set up individual tracks for the kit within the Superior VSTi mapping into reaper that are working with sound when I click inside the plug in.
All tracks are set to default record input (audio or MIDI) have tried Force midi but nothing.
I've tried right clicking the drums + learn to change the midi note its assigned to but it doesn't change (most likely not receiving a signal in the first place).
Set to read all 16 incoming channels. Main track is armed. Tested to see if midi is sounding in reaper, it is.
At a loss as to what to try next, would appreciate some advice as i'm still a complete noob so it could be something simple I haven't done yet.
Hanke is offline   Reply With Quote