View Single Post
Old 04-04-2019, 05:32 AM   #48
mjfe2
Human being with feelings
 
mjfe2's Avatar
 
Join Date: Mar 2011
Posts: 135
Default

Quote:
Originally Posted by FMNY View Post
Thanks to your earlier message I've got source destination editing working again. The problem for me was having to turn off ripple editing in the source. That was an unexpected solution because in the past you could have or maybe even needed to have ripple editing on in both source and destination. Once I turned ripple editing off in the source everything started working properly again.

Regarding the undo window I haven't been experiencing the problem you mention. You probably already know this, but you need to be in the destination window when you press the F10 key in order for the custom action (i.e. the edit) to show up properly in the undo window. This is also new behavior to me, because in the past the custom action went in the undo list regardless of whether you were in the source window or the destination window when you pressed F10

With those two little adjustments I've done hours of hours of source destination editing in reaper over the past weeks without any issues.
Thanks for the quick reply. Ah yes, I always thought the beauty of the action was that it could be executed in either window. But this must be the issue. Is there a workaround the share undo lists across projects?

I've found and fixed what seemed to be another bug which is that if the cursor in the source project is at the end or to the right of the time selection, the copy function doesn't seem to work so the previous edit's selection is pasted into the new destination time selection.

If I move the source cursor to within the time selection or to the left of it, copy seems to work again.

So I added to the S/D edit without crossfades action an extra command to move the cursor to the start of the time selection, which seems to over-ride this funny quirk...
__________________
Eastwood Records
www.eastwoodrecords.co.uk
mjfe2 is offline   Reply With Quote