View Single Post
Old 05-02-2012, 01:32 PM   #144
Human being with feelings
Banned's Avatar
Join Date: Mar 2008
Location: Unwired (probably in the proximity of Amsterdam)
Posts: 4,868

Originally Posted by sws View Post
It works fine, you just need to manually edit/create your reaconsole_customcommands.txt file. It goes in the same place your reaper.ini file lives, which you can go to from the Reaper options menu. I think the standard TextEdit app will work just fine for this purpose; I don't have a mac in front of me to check.
That is *exactly* what I did, but it does not seem to work, or I'm missing something.

On OS X, the reaper.ini file lives in:
~/Library/Application Support/REAPER/reaper.ini
So I created a text file here:
~/Library/Application Support/REAPER/reaconsole_customcommands.txt
It's contents are:
Nevertheless, no new custom actions are showing up. I have also tried saving the text file with CRLF line endings and in ISO-8859-1 (Windows) formats... What am I missing?

[EDIT:] Tried both 32 and 64 versions of the latest versions of REAPER/SWS (4.23pre7/2.2.0 build #2).

[EDIT2:] Ok, finally got it to work as well, following this tip, using TextWrangler (TextEdit and TextMate did not work), setting the encoding to CRLF and Western (Windows Latin 1), saving the file without an extension, then adding the .txt extension in Finder.

It was a little more frustrating than it should have been, so I'd still suggest looking into the way SWS reads configuration files some time.

Btw, this trick totally rocks when used from a control surface. I'd just wish action ID numbers of SWS actions would be more reliable...
˙lɐd 'ʎɐʍ ƃuoɹʍ ǝɥʇ ǝɔıʌǝp ʇɐɥʇ ƃuıploɥ ǝɹ,noʎ

Last edited by Banned; 05-02-2012 at 02:28 PM.
Banned is offline   Reply With Quote