View Single Post
Old 03-16-2021, 10:57 AM   #5
Human being with feelings
Join Date: Aug 2019
Posts: 16

Originally Posted by goldenarpharazon View Post
1) Running the logging script only
This works

Originally Posted by goldenarpharazon View Post
2) Running the MIDIMIX script only
This doesn't work. Except that I see the button addresses in the bottom left corner of oscii-bot window when I do something with midimix .

Originally Posted by goldenarpharazon View Post
3) Running both the logging script and MIDIMIX script together
Same as before - I see the log but midimix does nothing in REAPER (and yes, the device is configured in REAPER).

Originally Posted by goldenarpharazon View Post
For combination 3) both scripts use the same @OUTPUT and @INPUT so there is likely to be some contention so perhaps cause the error messages seen. Using the "OMNI" devices to open in the logging script instead could resolve. [see OSCII-bot documentation for this]
Well, there is no such thing as "@OUTPUT" in logging script, but I noticed that there are differences between how the @INPUT is wrote. In MIDIMix script it looks like "@input in MIDI "Mix" and "@input OSC_IN OSC "localhost:9000" but in logging script it looks like "@input HW_IN MIDI "Mix" and "@input HOST_IN OSC "localhost:9000". I've tried to change "@input OSC_IN OSC" for "@input HOST_IN OSC" in the Midimix script but that doesn't improve anything either. Very, very sad situation.

I still cannot understand what could cause a problem with that device and why it just doesn't want to work properly as it worked before. I haven't change anything in its script before the problem occurred. And I understand that there is something wrong with it because, well, the logging in midimix script doesn't work too. Unfortunately, I don't have much time for studying documentation too so I guess that Ill have to forget about it for some time. This is sad too cause I'd like to use that device since it saves my worktime.

From what I understand, Midimix script still gets midi from midimix itself and sends commands to REAPER, but REAPER does not receive them. I even tried to reset my REAPER config but still no luck.

Last edited by theeighth; 03-16-2021 at 08:46 PM.
theeighth is offline   Reply With Quote