View Single Post
Old 08-21-2018, 09:03 AM   #39
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,804
Default

Quote:
Originally Posted by Glennbo View Post
The reported latency on reainsert is 192 samples, but running the ping test comes back with 206. This was tested while letting QjackCtrl start jack up so that both cards were functioning, which did revert back to the 1.4/2.9ms, which is how it always read in Windows with the M-Audio ASIO drivers.
The reason that it reverted to 192 samples (3x64) is that you didn't add the -S parameter to qjackctl You can do this in settings - advanced - server prefix, just add -S after jackd. Then you ought to get 64/64 just like you had when starting it from reaper or the command line. I take it that the 206 value is what was reported in the additional delay compensation field? Was additional delay compensation selected?

Quote:
The alignment issue isn't due to latency. It's due to the two cards not kicking into record at the exact same precise moment, so there is drift of the start time, but no drift otherwise. Sometimes they will be almost on the money with each other, and other times they will be off a bit from each other.
I won't dispute that this actually happens, I have zero experience with combining cards in this manner. However I don't buy the explanation that the cards kick in to record mode at different times. The cards are inputting audio the entire time you run reaper, be it in record mode or not. Sadly I can't offer an alternative explanation for why this would be

The reason I mentioned latency in this context is because I'm not sure if using zita-a2j adds latency or not, though my guess is that it doesn't. It was one thing I wanted to ascertain as I'm on vacation with my laptop and I have no reliable way to test myself. I.E. I wanted to use you as a guinea pig, I hope you don't mind

Quote:
I didn't have to do anything beyond installing rtirq with Synaptic, and then making the modifications you posted to it's config file.
Thanks, that's useful information for me. Then I know that the next time I can tell ubuntu users to just install rtirq and edit the config file. Adding a kernel boot flag to the boot manager is a lot more complicated to explain

As a matter of interest, what version of ubuntu do you use?
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040, etc. :)
Jack Winter is offline   Reply With Quote