View Single Post
Old 06-19-2019, 06:50 AM   #38
Travesty
Human being with feelings
 
Travesty's Avatar
 
Join Date: Nov 2014
Posts: 514
Default

Quote:
Originally Posted by _Stevie_ View Post
Thanks ED for bringing up this topic. @Justin, there might be a lot of users with the same experience. I'll try to gather them and point them to this thread.
Sorry if I'm adding noise here, but I have had the same experience. i got some reprieve from setting thread behaviour to relaxed, but it's still not perfect.

About tracks being deactivated, we have the option "Muted tracks take no cpu time"
This should mean that if you mute the track it is deactivated, however this doesn't seem to be entirely true.

I decided to run some quick tests

Specs: i7 7700k 32Gb nvidia 970

1st duplicating empty tracks exponentially up to 1024.

Got a crash immediately, repeatedly selecting all tracks and duplicating with shortcuts, not sure if related

Performance is ok here, around 2% cpu usage, but a slightly worrying 10% rt cpu usage
No visible slowdown of ui, but the rt increase will hinder intensive project playback


2nd test duplicating empty tracks to 1024 each loaded with my default chain, all disabled.

Chain is:
pro q 2
soundtoys effect rack
pro c 2
reacomp
pro l

At 1024 tracks the system is using 75% cpu, 41% rt cpu, and once it began to work was largely unresponsive, and certainly not usable. Moving the playhead took on average 10s.

Also, going from 512 to 1024 took around 5 minutes to complete, during which time the program was locked
Deleting the tracks hung the program and I killed it after 5 minutes of waiting.


3rd test, 1024 tracks but with the fx in the chain set to offline

Performance is slightly better here, 60% cpu, 30% rt cpu
Playhead takes around 3s to move after a click, so it's almost usable, not tried any playback though.

4th 1024 tracks fx in the chain offline, tracks muted

Muting the tracks here gives an improvement in cpu to 7%, however rt cpu jumps to 55%, which would kill the playback performance if I were playing anything.

5th 1024 tracks fx in the chain disabled, tracks muted

Here I get 20% cpu, 63% rt cpu


In conclusion, it seems that the problem is not the actual empty tracks which is the problem, but the plugins on them. If you were to create a 5000 track template, you would want there to be plugins on there, or there would be no point in making it. I haven't found a way to do this without incurring some sort of slowdown as a result.
Muting tracks seems to shift the problem into the rt cpu, and setting plugins to offline seems to still have a large impact.

These are not scientific tests, but I hope they can give an indicator of where the problems lie
Travesty is offline   Reply With Quote