View Single Post
Old 01-11-2020, 01:49 PM   #28
ashcat_lt
Human being with feelings
 
Join Date: Dec 2012
Posts: 4,954
Default

So naming JS plugs can be weird, and I’m not sure I completely understand it. All I can do is tell you what I think I know and hope it helps. When you do “Create new JS”, it pops up a window to name the plugin. Whatever you type there becomes the actual file name for the plugin on your drive. This is also what it will display on the track because at this point it has nothing else. The desc: line is what is actually supposed to display both in the FX Finder and in the FX chain, but just changing that won’t change the displayname of any instances that are already in the project. If you changed that line and saved/recompiled and it’s not coming up by the new name in the finder and showing that name for new instances, idk what to tell you.

Somewhat similarly, when you made the new JS, it had a set of sliders already and they were all set to 0. When you paste my code over what was already there and recompile, it doesn’t move those sliders. To get that instance to default settings, you’d just have to double-click each of the sliders. Or delete that instance and add a new one.

AutoGain is experimental, might not be the best way to do it, and probably isn’t great for drums anyway. You might try setting the Time slider as high as it goes and setting Calibration a bit lower to get something a bit more appropriate, but it’d still be kind of hit or miss. The crest factor of a drum track usually is really big because it’s usually a lot of silence (compared to other more sustained instruments) with short sudden bursts of really loud. It averages out to pretty small.

Now it shouldn’t really do anything when AutoGain is actually set to 1. It is calculating, but won’t change gain or anything else as long as that is 1. When you switch it back to 0, it moves the Gain slider to whatever value it decided on and leaves it there. You can adjust that as necessary and if you want to get back to default, double click the slider. The idea you had to have it “undo” AutoGain won’t work without a lot of rethinking because the automatically calculated gain isn’t actually applied until you set it to 0, so you’d pretty much never actually get the automatic gain at all. In which case, you might as well just leave it or even delete that slider altogether.

I think I’m going to look into adding LUFS as an option and also an “infinite time” integrated option. Don’t hold your breath on that, but I’ll let you know when/if I get it done.
ashcat_lt is offline   Reply With Quote