Thread: Noob FAQ
View Single Post
Old 03-04-2012, 05:06 AM   #2
Ollie
Super Moderator (no feelings)
 
Ollie's Avatar
 
Join Date: Dec 2007
Location: On or near a dike
Posts: 9,739
Default

Audio/MIDI Setup:

1.: "I have a delay when I hit a key on my keyboard or when listening to my guitar on headphones."

[Windows (all versions)]:

You are probably using your onboard sound card. It doesn't come with "low latency" (latency=delay) ASIO drivers to make audio processing as fast as possible. Many consumer sound cards and onboard chips run with ASIO4ALL, download it here:

http://www.asio4all.com/

After installing it, open REAPER and go Options->Preferences->Audio->Device to select 1. ASIO as your audio system and 2. ASIO4ALL as the ASIO driver:



Next you need to click the little ASIO4ALL system tray icon...



...and set the "ASIO Buffer size" to a value your system can handle, try 512 first and then reduce that until you get crackling noises etc., then go back a notch or two. Most systems can get 256-512 samples without artifacts, so try that as a starting point



If you are using a dedicated audio interface, you need to select the "native" ASIO driver of your interface instead.

[Windows (Vista and higher)]:

On Vista and Windows 7 you have also the option to use WASAPI instead of the ASIO driver model to achieve low latency.

[OSX]:

OSX allows for low latency with its onboard ("default system device") sound chip without extra drivers. Just go Options->Preferences->Audio->Device in REAPER and request a "Block Size" if you experience latency:





To be continued occasionally...
Attached Images
File Type: png Prefs_Audio_Device_ASIO4ALL.png (12.9 KB, 11110 views)
File Type: png ASIO4ALL_SYSTRAY.png (5.7 KB, 11013 views)
File Type: png ASIO4ALLCP.png (21.4 KB, 10917 views)
File Type: jpg Screen shot 2012-03-04 at 1.02.26 PM.jpg (41.9 KB, 11072 views)

Last edited by Ollie; 03-05-2012 at 02:49 PM.
Ollie is offline