View Single Post
Old 07-16-2018, 07:05 AM   #1
DarkStar
Human being with feelings
 
DarkStar's Avatar
 
Join Date: May 2006
Location: Surrey, UK
Posts: 17,742
Default MidiMixControl.txt - track colours change

[oscii-bot.exe v0.6]

I have been using the AKAI MIDIMIX control surface by
goldenarpharazon, Banned and others. Many thanks to you guys for this so I could get started.

One thing that I saw, when in MIXER Mode, is that the oscii-bot script changes the colour of the tracks when "Bank Left" or "Bank Right" is selected. I wanted to keep the colours so thought that I would flash the Solo buttons momentarily. The code changes below work, but the flash is too quick - I would like it to be, say, 1 second. I tried the JS FX loop syntax but oscii-bot detected a syntax error.

How can I add a timer?

Code:
( midimix_mode == 0 ?
   ( oscsend(OSC_to_REAPER, reaper_action, 40297);         // Unselect all tracks"
     oscsend(OSC_to_REAPER, "t/track/1,2,3,4,5,6,7,8/select/toggle", 1);   
     // select tracks in current bank  
//DarkStar     oscsend(OSC_to_REAPER, reaper_action, 40359);
         // Set to default color
     oscsend(OSC_to_REAPER, device_track_bank_increment, 1);
     oscsend(OSC_to_REAPER, reaper_action, 40297);         // Unselect all tracks"
     oscsend(OSC_to_REAPER, "t/track/1,2,3,4,5,6,7,8/select/toggle", 1);   
     // select all tracks in current bank  
//DarkStar     oscsend(OSC_to_REAPER, reaper_action, 40360);
     // Set to one random color
oscsend(OSC_to_REAPER, reaper_action, 7);
// .... need a 1 second timer here
oscsend(OSC_to_REAPER, reaper_action, 7);
     oscsend(OSC_to_REAPER, reaper_action, 40297);   // Unselect all tracks 
     // (makes sure tracks are unselected before using mixer
     oscsend(OSC_to_REAPER, reaper_action, 41070);               // reset soft takeover
     oscsend(OSC_to_REAPER, reaper_action, 41743);         // refresh all surfaces
     // makes REAPER send back the states of all mutes, solos and recarms for bank
   ):
Two other oscii-bot questions
(a) why does it appear in my Notification Area (Windows 7) for a short time (~40 seconds) then disappear; there is also the usual icon on my Task Bar
(b) if I close the OSCII-bot window using the [x] is the top-right corner, how do I get it back (to stop it properly)? The icon disappears from the Task Bar but the process is still running.
__________________
DarkStar ... interesting, if true. . . . Inspired by ...
DarkStar is offline   Reply With Quote