View Single Post
Old 06-19-2021, 01:00 AM   #2
pljones
Human being with feelings
 
pljones's Avatar
 
Join Date: Aug 2007
Location: London, UK
Posts: 746
Default

MIDI is not audio.

NINJAM transfers audio. If you've not understood what it does already, read this.

If you connect MIDI Out on your piano to your computer's MIDI In, you're receiving MIDI, not audio. So you need to turn the MIDI into audio using piano VST instrument before sending the audio to NINJAM using ReaNINJAM.

- Start Reaper
- Create a new project
- Right-click, Insert virtual instrument on new track
- From the list of instruments, pick the piano sound you want, for example mda Piano
- Check that the channel inputs say "MIDI: All channels" and if you click and hover "Input: MIDI", the next level has "All MIDI Inputs" selected - and that your MIDI input is actually list on that level above the selected item.
- Check that "Record Monitoring" is "On"
- Check that "Record" is "input (audio or MIDI)"
- Leave the "ROUTE" settings alone for now
- Check that "Record Armed" shows

When you play your MIDI keyboard now, you should see the track and master level meters respond. If you can hear audio from the MIDI keyboard itself - disable it! You want to be hearing the audio from your computer. So now check you can hear the piano sounds from your computer.

OK, so that's one piano fed to one track, routed directly to master.

I don't understand what you mean by "one local and one remote MIDI piano". Could you explain?
__________________
Quote:
Originally Posted by Tony Williams
...Playing fast around the drums is one thing. But to play with people for others, to listen to, that's something else. That's a whole other world.
pljones is offline   Reply With Quote