View Single Post
Old 08-20-2018, 10:58 PM   #30
Human being with feelings
Glennbo's Avatar
Join Date: Mar 2008
Location: Planet Earth
Posts: 5,035

Originally Posted by Jack Winter View Post
I wonder if one part of the problem isn't pulseaudio. I assume that your system has that running. As a basic precaution fire up pavucontrol and go to the configuration tab. Set both M-Audio cards to off, as far as I understand that will make sure that PA doesn't try to use them, causing problems with other programs.
Early on I disabled both the M-Audio cards and the nVidia over HDMI audio, so only motherboard audio is accessible by Pulse.

Personally I think reaper's JACK device page could use some more love. I'll think about it and try to see if I could come up with a coherent FR to make it more flexible

I don't know of a way to do more than starting the jackd server itself from there, anything more complex will need some external help. There are probably multiple ways of doing this, but that would get a long post and I'm tired...

Let's start with trying to get it all up and running from qjackctl. In the field you used to start a2jmidid you can chain commands by putting a ';' between commands, so try using "zita-a2j -d hw:3;a2jmidid -e". You can probably also point to a more complex script there, though I've never tried myself. I'm a bit puzzled that you can't use hw:M2496_1, but let's go with hw:3 for the moment.

Then start qjackctl and once it's up and running launch reaper with JACK selected as device, and autostart jack unchecked and the autoconnect options checked.
Turns out I think I have a totally usable solution. I had written a short script to get midi going, bind the second audio card, and fire up REAPER, along with a default patch mapping that gets the second card audio to inputs 3 and 4 in REAPER. That works great and very consistent. I only have to fire up QjackCtrl and everything needed for four channel recording gets enabled, mapped, and REAPER starts.

What I just realized is that I can have my original line that worked so well in REAPER so I can directly launch REAPER still, but it will fire up with only two channel capability, which is fine for everything I do except record acoustic drums. Launching QjackCtrl will still get everything setup, and even though REAPER is set to do it's own start of jack, once it's up, I still have four channel recording capabilities.

So unless I'm recording drums, I can just launch REAPER from the REAPER icon they way I always have, and if I'm going to track drums, launch using QjackCtrl. I did this quick and dirty four channel test to verify that the four drums mics are indeed working.

This surprises me, but we could revisit the issue later. What I meant about using an ALSA device is that there is a way to combine multiple devices into one, and then run JACK on it. This would normally be a bad solution due to drifting clocks, but seeing that you have them externally synced, that ought to be doable. I'll google the details, as I've never used such a device myself. Am the happy owner of a rme hdsp, at least until I'll upgrade my computer and find myself without a PCI slot anymore. But that's a different story

To verify that it works, what is the output of rtirq status? You don't have to paste all of it, but the top couple of lines would be nice to see.
Looks like all the snd guys are high priority now.

420 FF 95 - 135 0.0 S irq/32-snd_hda_
421 FF 95 - 135 0.0 S irq/17-snd_hda_
424 FF 95 - 135 0.2 S irq/16-snd_ice1
467 FF 95 - 135 0.0 S irq/17-snd_ice1
48 FF 50 - 90 0.0 S irq/9-acpi
102 FF 50 - 90 0.0 S irq/16-ehci_hcd
Hear My Music - Click Me!!!
Glennbo is offline   Reply With Quote