View Single Post
Old 08-20-2018, 04:48 PM   #28
Human being with feelings
Glennbo's Avatar
Join Date: Mar 2008
Location: Planet Earth
Posts: 5,035

Originally Posted by Jack Winter View Post
Install zita-ajbridge, and try "zita-a2j -d hw:M2496_1" for inputs and"zita-j2a -d hw:M2496_1" for outputs. As you have the cards externally synced you can also try the alsa_in/out utilities mentioned above.
I tried both the alsa_in that Eric mentioned and the zita-a2j that you mentioned. I was only able to get it to work by NOT having REAPER start Jack for me, and instead doing this set of procedures.

1. Start QjackCtrl
2. Open a terminal and then issue the command, zita-a2j -d hw:3 which hangs the terminal window till that process is stopped.
3. Fire up REAPER, and now I can get to all four inputs.

I'm wondering if it is possible to still have REAPER launch jack for me, and still get all four inputs.

If not, I'm assuming I could write some kind of script that gets launched by QjackCtrl, after it has fired up. I already have it directly issuing the command a2jmidid -e & to make midi work when I don't have REAPER start jack for me.

You might also want to start qjackctl to get a display showing if there are any xruns. Reaper's performance page also has something called RT biggest block. The first value should stay under the second, as if it exceeds it then not all audio got read/written.

It should also be possible to create a combined device using alsa user space, but I have no idea how that works when a system has pulseaudio installed and would have to google how to do that. It would probably be the better long term solution as then you wouldn't have to run the above utilities
I tried setting ALSA in REAPER to 24/44 64 samples latency with 2 buffers and it did not do as well as jack audio. I even set the priority of ALSA in REAPER up to 90%, but still got lots of artifacts in the audio.

Here again it might be advantageous to run qjackctl and check rt cpu and rt biggest block on the reaper's performance page. I think it also has a xrun counter that would be good to enable. An alternative would be to remove the jackd command line from the device config page, and run it in a terminal as it would show the xruns. IIRC there is also an undocumented flag that one can add to reaper.ini that will make the RT longest block sticky, otherwise I think it resets every one in a while. All this to make sure that there aren't xruns that you don't really hear, or don't notice while doing other stuff.
I ran my test song while watching the status page in QjackCtrl, and it showed no xruns. It did have a notice that one happened an hour and a half ago, but I was trying things that were hanging QjackCtrl up around then, so I don't think it's anything to worry about.

What I really want to make happen at this point is to get both my cards available to REAPER without having to go through a bunch of steps or procedures in order to record drums.

Sorry I misled you On ubuntu it's apparently in /etc/default/rtirq, the beauty of many distros changing things around... On my archlinux system it's in /etc/rtiq.conf.:S

If you already rebooted, just run rtirq status and see what it says, you ought to see the soundcards at the top with high priorities. Otherwise you have to add the threadirqs boot flag in your boot managers config file.
I modified the file, commenting out every line it had originally, which appeared to all be for USB audio, which I have none of currently. The only live lines in the file now are the three you posted earlier.
Hear My Music - Click Me!!!
Glennbo is offline   Reply With Quote