View Single Post
Old 04-22-2021, 11:16 AM   #9
Human being with feelings
Join Date: Aug 2019
Posts: 16

Well, today I've finally tried my luck again and it's still not working. I've updated to REAPER 6.25 and thought that maybe it will change something.
At some point I've managed to get messages FROM reaper to oscii-bot logger but lost them when I've replaced Midimix osc config in REAPER's OSC directory with one that is placed in oscii-bot directory. Anyway, I could not control anything in reaper with midimix even when I got those messages from reaper.

I'm also getting some messages from reaper when switching osc mode in settings, something like this:

OSC  from Reaper : /track/1/number/str Value: 1
                   /track/1/select/toggle Value: 0.000000
So OSCII-Bot IS receiving messages, but, somehow, does not send them to REAPER. At least it's how I understand it.
And yes, I've double and triple-checked all ports and IP addresses in MidiMix config file - nothing helps.

Fun fact: Im getting connection errors when I try to set @input OSC_IN OSC to but there are no errors when I use localhost:9000.

And I also receive this message from reaper when I start OSCII-bot:

OSC  from Reaper : /device/track/bank/select Value: 1
                   /action Value: 41743

UPD: Okay, now I'm getting messages like this when I move fader
MIDI from MIDIMix: Control Change: Channel: 01 CC num: 62 Value: 50
OSC  from Reaper : /action/12/cc/soft Value: 0.393700
I guess it's doing something but there are no effects on reaper itself. I'm trying to move master fader but it's not moving in DAW.

Last edited by theeighth; 04-22-2021 at 11:23 AM.
theeighth is offline   Reply With Quote