View Single Post
Old 08-20-2018, 10:24 PM   #29
Jack Winter
Human being with feelings
Jack Winter's Avatar
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,872

Originally Posted by Glennbo View Post
I tried both the alsa_in that Eric mentioned and the zita-a2j that you mentioned. I was only able to get it to work by NOT having REAPER start Jack for me, and instead doing this set of procedures.

1. Start QjackCtrl
2. Open a terminal and then issue the command, zita-a2j -d hw:3 which hangs the terminal window till that process is stopped.
3. Fire up REAPER, and now I can get to all four inputs.

I'm wondering if it is possible to still have REAPER launch jack for me, and still get all four inputs.

If not, I'm assuming I could write some kind of script that gets launched by QjackCtrl, after it has fired up. I already have it directly issuing the command a2jmidid -e & to make midi work when I don't have REAPER start jack for me.
I wonder if one part of the problem isn't pulseaudio. I assume that your system has that running. As a basic precaution fire up pavucontrol and go to the configuration tab. Set both M-Audio cards to off, as far as I understand that will make sure that PA doesn't try to use them, causing problems with other programs.

Personally I think reaper's JACK device page could use some more love. I'll think about it and try to see if I could come up with a coherent FR to make it more flexible

I don't know of a way to do more than starting the jackd server itself from there, anything more complex will need some external help. There are probably multiple ways of doing this, but that would get a long post and I'm tired...

Let's start with trying to get it all up and running from qjackctl. In the field you used to start a2jmidid you can chain commands by putting a ';' between commands, so try using "zita-a2j -d hw:3;a2jmidid -e". You can probably also point to a more complex script there, though I've never tried myself. I'm a bit puzzled that you can't use hw:M2496_1, but let's go with hw:3 for the moment.

Then start qjackctl and once it's up and running launch reaper with JACK selected as device, and autostart jack unchecked and the autoconnect options checked.

I tried setting ALSA in REAPER to 24/44 64 samples latency with 2 buffers and it did not do as well as jack audio. I even set the priority of ALSA in REAPER up to 90%, but still got lots of artifacts in the audio
This surprises me, but we could revisit the issue later. What I meant about using an ALSA device is that there is a way to combine multiple devices into one, and then run JACK on it. This would normally be a bad solution due to drifting clocks, but seeing that you have them externally synced, that ought to be doable. I'll google the details, as I've never used such a device myself. Am the happy owner of a rme hdsp, at least until I'll upgrade my computer and find myself without a PCI slot anymore. But that's a different story

I modified the file, commenting out every line it had originally, which appeared to all be for USB audio, which I have none of currently. The only live lines in the file now are the three you posted earlier.
To verify that it works, what is the output of rtirq status? You don't have to paste all of it, but the top couple of lines would be nice to see.
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040, etc. :)
Jack Winter is offline   Reply With Quote