View Single Post
Old 07-02-2014, 02:40 AM   #100
G-Sun
Human being with feelings
 
G-Sun's Avatar
 
Join Date: May 2010
Location: Norway
Posts: 7,229
Default

Quote:
Originally Posted by benbenben6 View Post
The use-case I had in mind was say you had a song recorded without click fully tempo mapped (both audio and Midi) and then later decide to add a new section to the song right in the middle. When editing tempo markers earlier in the song Midi would fall out of sync past that point.

Switching the timebase to 'beats' seems to be much more reliable with what I've tested so far. Audio and Midi are moving in Sync! I know when you first tempo map a song using SWS, it requests the timebase to be set to 'time'. I hadn't thought of switching it to 'beats' after.

There was one thing that wasn't intuitive when project timebase is set to 'beats'. If you copy a few points on the tempo map and then paste them earlier in the timeline, it will push the Midi after that point out of sync. Using regions to move tempo markers works fine on the other hand. Using a few regions to split the song and insert a new section in the middle seems to work reliably for me.
Ok, seems like you got it working now.
Yes, maybe we should point it out in the manual. Edited:
http://wiki.cockos.com/wiki/index.ph...9_Preparations

Strange with the paste points behaviour. Good that region move works though.
__________________
Reaper x64, win 8.1
G-Sun.no - Music Blog - My music
G-Sun is offline   Reply With Quote