View Single Post
Old 08-21-2018, 12:04 AM   #31
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,802
Default

OK, think I found what we need!

Create a ~/.asoundrc file, and put the following into it:

Code:
pcm.Maudio {
    type multi;
    slaves.a.pcm hw:1
    slaves.a.channels 2;
    slaves.b.pcm hw:3
    slaves.b.channels 2;
    bindings.0.slave a;
    bindings.0.channel 0;
    bindings.1.slave b;
    bindings.1.channel 0;
    bindings.2.slave a;
    bindings.2.channel 1;
    bindings.3.slave b;
    bindings.3.channel 1;
}

ctl.Maudio {
    type hw
    card 1
}
Start JACK with the following command line: /usr/bin/jackd -R -dalsa -dhw:Maudio -r44100 -p128 -n2 -Xseq

Observations:

I've never done this before, just googled and modified slightly for your current setup. We'll probably have to reiterate over it a few times, as I suspect the channels will probably need to be reordered and there might be other unforeseen issues. But as a first try it ought to be good.

For other readers of this thread, this will only work well if you have cards that are externally synced, forget it if you can't sync the cards as drifting clocks will cause problems. In this case using zita-ajbridge would be the prefered solution as detailed earlier in this thread. zita-ajbridge has a nice resampler function to compensate for drifting clocks.

It will probably be seen by PA too, so again start pavucontrol and disable the Maudio device too, you might have to restart the PA server or reboot for this to happen. "pulseaudio -k" ought to restart it.

I would have preferred to use the device names instead of the device index numbers in the above, but since you had problems using hw:M2496_1 I decided to use the indexes instead. This might however have been due to pulseaudio hogging the card even though it's not using it.

Note that it is possible for the index to change at reboot, probably unlikely in your case as you are using PCI devices, but it's a real issue using USB devices. This is the reason that it's always preferable to refer to a device by it's name rather than it's index.

You can configure the system so that each device gets a specific index. I'll leave that for a later post, so that we don't mess anything up while trying this!

Break a leg!
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040, etc. :)
Jack Winter is online now   Reply With Quote