View Single Post
Old 07-15-2020, 12:43 AM   #5
Human being with feelings
Join Date: Jul 2020
Posts: 7

Thanks. Since you're using Xubuntu with Xfce, I wondered if my desktop environment might somehow be to blame, and since I don't much care for the current version of gnome anyway, I thought I'd try Xfce instead. I have to say that I found the default Xfce environment rather a startling experience -- So much blue! with outcrops of Windows95! But in any case, it didn't fix anything and now I've reluctantly climbed back onto the gnome/gdm3 train again.

On a brighter note, I've now got Carla working properly from inside Reaper! Yay! The problem was that I'd followed the link in the 'Reaper for Linux documentation' sticky thread, which took me to the KXstudio Carla page, where I found, downloaded and extracted the Linux64 bit version and ran it. This is the version (2.2.0-beta1 as noted above) that worked great as a standalone, but wouldn't work properly in Reaper. But it turned out I was going about the whole installation process all wrong!

My understanding now is that what I *should* have done is (after a 'sudo apt update') run 'apt search carla' and then run a 'sudo apt install' for each of the packages found by the search. (The youtube video mentioned in my first post talks about installing the packages found by the command 'apt search carla bridge' but this misses carla itself as well as some other presumably important programs.)

NOTE: at some point I also activated the KXstudio repos, as described here on the KXstudio site. This step may or may not be necessary before running the apt search and apt install commands above. I think the repos are important for updates(?) so perhaps they're important for search and install too? I'm afraid I don't know. Anyway, it's probably a good thing to do and doesn't seem to do any harm.

Anyway, yeah, so now I have Carla version 2.2.0-RC1 installed. It shows up in the Ubuntu applications launch screen, and it works just like it's supposed to with Reaper! So problem solved! :-)

But to prevent this from happening again, can the 'Reaper for Linux documentation' sticky be amended with some instructions on how to actually install Carla instead of only providing a link to the KXstudio site where, as far as I can tell, there's presently no documentation on how to do an install, but a big opportunity for beginners like me to go badly astray.

(I'd like to mark this thread as SOLVED, but I don't see how to do that. ETA OK, I figured it out :-) )

Last edited by paulbee; 07-19-2020 at 01:54 AM. Reason: mark thread as solved
paulbee is offline   Reply With Quote