View Single Post
Old 10-05-2018, 10:28 AM   #576
Human being with feelings
Join Date: Oct 2018
Posts: 2

Originally Posted by SuperEB View Post
Tried to install staging 2.21 on AVLinux but was running into some missing dependencies that I couldn't easily resolve.

Installed MX 17.1 and then successfully loaded everything. Waves Central would recognize drive_C but not my flash drive.

I disconnected an external hard drive but had forgotten to dismount it. Now Waves Central gives me the disconnected devices warning. A reboot, re-install of everything except wine did not fix this!

EDIT: EDIT: After re-installing wine, I have confirmed that the removal of a USB drive without first dismounting it will cause WC to not be able to see the network card and drive_c will no longer available. WC was not running when I removed the drive. When the drive is re-installed, WC will recognize drive_c again.

I might be able to work with this but am going to keep trying to get licenses on USB to work.
Would you kindly share any more information about this topic? I have Waves Central working a while back, but I wanted to try it out again and I cannot get it to work! For reference, I'm on Arch Linux and Wine Staging 3.17.r39, although I've tried this numerous times since 3.12. I *always* get the unable to detect devices message, where it says there's no USB or network card. I can install plugins, but not activate them. I've always tried with new wineprefixes and with the necessary startup steps listed before, e.g. robotools, mfc42*, regedit.

I've tried rebooting, fresh prefixes, with/without USBs before/after installing the prefix, messing with Drives in winecfg, multiple wine-staging versions, and probably more than that! I need some clues as to what to do here... I'm sure that at some point in my three-year-old setup that I've removed devices without unmounting them, but I doubt that would affect this. A clean reboot, insert USB, clean wineprefix, and install Waves Central does not seem to fix this.

I don't know what/how it's checking, but it fails every time on my machine. The only related thing that I can think of is about the network. I also use QEMU and I have multiple bridges setup with a couple of NICs. That may be different that the average user and causes this issue. What a pain!
somethingtohide is offline   Reply With Quote