View Single Post
Old 09-17-2018, 12:42 PM   #86
Human being with feelings
Join Date: Feb 2011
Posts: 19
Default MIDI playback stutters on soft synth OR external HW synth

I've been working on setting up Linux Mint 18.3 to do some track editing.

I have Reaper for Linux (64 bit) installed and it works great on audio tracks, and I had one MIDI that plays just fine using FluidSynth (QSynth) with JACK. That MIDI has 8 active channels/tracks.

Then I tried another MIDI file and that one is erratic, with a bunch of stuttering and just not playing smoothly at all. This MIDI has 16 tracks

This happens either with the soft synth OR with an external HW synth through an Alesis IO2 as well as a no-name USB to MIDI interface that I have laying around.

This same MIDI plays smoothly in Ardour 4 with the soft synth. So the issue seems to be isolated to Reaper.

Using the virtual MIDI device in Reaper from a2j Virtual RawMIDI out to a2j FLUID Synth input ports. But I was NOT using a2j in earlier tests and the results were the same. In that earlier test routed from Virtual RawMIDI to FLUID Synth in the JACK ALSA tab.

I tested with Reaper (Windows 64bit) under Wine, and using the Qsynth as set up for my Linux test. In the Windows version running under Wine I have the Synth input port (number:0) and that is what I enabled and mapped to the MIDI tracks. It plays very smoothly just as the same MIDI does on my Windows machine.

Any suggestions on what I should look for to get this working smoothly with Reaper for Linux, or is this possibly a bug in Reaper for Linux?

Update: 9/17/18 Found the problem, or at least a solution.
In some earlier testing I had changed the Audio System from JACK to PulseAudio in Reaper's Preferences and had forgotten about it.
So on a hunch I changed it back to JACK and then changed the JACK MIDI routing to REAPER/MIDID Output 1 connected to a2j/FLUID SYnth input and that got rid of the stuttering. That may still not be the optimal configuration, but for now it is working.


Last edited by burtbick; 09-17-2018 at 01:49 PM. Reason: Found solution to problem.
burtbick is offline   Reply With Quote