Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Open Bug

PDC not reseting when bringing offline plugins back Issue Tools
issueid=1873 01-14-2010 03:07 AM
Human being with feelings
PDC not reseting when bringing offline plugins back
The PDC keeps adding itself

Try this:

- Add one plug with latency. Check in the PMeter. It shows for example 100.
- Put plugin offline. It shows 0.
- Bring it back. It shows 200 instead of 100.
- Put it offline again. It shows 0.
- Back again and it shows 300.


I've also noticed that with some plugs the latency is reported in two numbers. Something like this in the FX Window:
1143/2048 spls (in the PMeter only appears 2048)
This happens with the UAD plugins, for example.
Why is that?
Issue Details
Issue Type Open Bug
Project Deprecated REAPER issue tracker
Category Plugins
Status Confirmed
Priority Unknown
Affected Version 3.2
Fixed Version (none)
Users able to reproduce bug 3
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)

01-14-2010 03:24 AM
Human being with feelings
 
Your're right. It's going out of sync when using the offline function while playback :(


The numbers show "needed latency of the plugin"/"latency used by reaper for the whole fx chain on the selected track - rounded to blocksize or so)" in samples.



Here's a another PDC bug with ReaComp: http://forum.cockos.com/project.php?issueid=889
Reply
01-14-2010 03:43 AM
Super Moderator (no feelings)
 
The first number in the FXchain window is the plugin latency, the second the overall latency of the FX chain (Performance Meter shows only the overall latency). What happens is that bringing a plugin off- and back online erratically adds the latency value of that plugin to the overall latency calculation - until you hit play, then it resets.

In other words, this is a temporary cosmetic glitch happening only when bringing plugins back online and you don't have to worry that this actually affects anything.
Reply
01-14-2010 03:53 AM
Human being with feelings
 
Quote:
Originally Posted by Steindork
In other words, this is a temporary cosmetic glitch happening only when bringing plugins back online and you don't have to worry that this actually affects anything.
It's not a cosmetic glitch. Really affects audio output (tracks not in sync anymore). Shouldn't happen.
Reply
01-14-2010 04:01 AM
Super Moderator (no feelings)
 
It affects audio output when you do that during playback until you hit play again. I assume that PDC is calculated one time at playback start instead of constantly polling for changes.

If you have an idea for what purpose someone would repeatedly cycle a plugin off/online during playback, I'll take the "cosmetic" back. ;)
Reply
01-14-2010 04:15 AM
Human being with feelings
 
"About" page says "Fully automatic plug-in delay compensation (PDC)" so this should work ...
Reply
01-14-2010 04:43 AM
Human being with feelings
 
Quote:
Originally Posted by Dstruct
The numbers show "needed latency of the plugin"/"latency used by reaper for the whole fx chain on the selected track - rounded to blocksize or so)" in samples.
Then... if I add an Oxford Limiter it's adding 1024spls instead of the 104 it has? And if I add two it's adding... 2048!
Reply
01-14-2010 05:00 AM
Human being with feelings
 
1024 = audio driver latency

2048 -> needs improvement, see http://forum.cockos.com/project.php?issueid=968 (please vote)
Reply
01-14-2010 07:33 AM
Human being with feelings
 
Ok, so this is something which needs some optimization. Understood. Thanks Dstruct.
Reply
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 11:56 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.