Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Open Bug

deleting clips results in wrong overlaps Issue Tools
issueid=1636 12-01-2009 09:26 AM
Human being with feelings
deleting clips results in wrong overlaps
With ripple mode enabled, results in different overlaps on different tracks

With ripple mode enabled,
with overlapping fades after split,
time selection selecting area,
then splitting selected area with shift-S,
then deleting those clips,
results in different overlaps on different tracks

ACT 0 0 "bfccd2e2ee681be80c8f38bbc1d5f668" "Custom: knip" 40717 40061 40630 40006 40635 41045 1007
KEY 0 92 _bfccd2e2ee681be80c8f38bbc1d5f668 0
This issue is closed. No more replies may be made.
Issue Details
Issue Type Open Bug
Project Deprecated REAPER issue tracker
Category Editing behavior
Status Confirmed
Priority 4
Affected Version 3.1415
Fixed Version (none)
Users able to reproduce bug 0
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)

12-01-2009 07:38 PM
Administrator
 
Can you post a simple project (with the time selection set) that shows the problem? I don't see anything wrong happening when running your action in a simple test project, so there is some specific state needed.
12-02-2009 04:37 AM
Human being with feelings
 
Quote:
Originally Posted by schwa
Can you post a simple project (with the time selection set) that shows the problem? I don't see anything wrong happening when running your action in a simple test project, so there is some specific state needed.
Bizarre, seems to work correctly, apart from the non-overlapping fades after the deleting.

While trying to reproduce it in a fresh project, i came across something else.
If you cut the time selection with the macro, the 4th track removes the clips incorrectly.
e.g. it removed too much.
empty item issue?

It might be related to incorrect selection over different tracks range.
you can verify by splitting all clips (select all, shift-S) then try to select clips within the time selection and you'll see that some clips outside the area will also be highlighted.
12-02-2009 11:52 AM
Human being with feelings
 
From the 'remove selected items' i expect the clips inside the region to be removed.
I do expect a new overlap from the clips before the region and the clips after the region.

With 'remove time selection' i want the time region to be removed, as it has no meaning anymore after removing the clips.

I noticed one thing with selecting all clips inside a time region.
If a clip within that region has a cross fade with a clip outside that region, it will also include the clips outside the region. This is not what one would expect. The result when deleting all clips within the region is that is will also remove the clips with an overlapping fade.
12-02-2009 12:10 PM
Human being with feelings
 
The picture 'selection-expected' shows the area you would expect to be removed.
But it turns out the overlapping clips on either side are also include in the selection that will be removed.
12-02-2009 01:43 PM
Administrator
 
This is what happens when I step through your custom action. I don't see those little scraps being selected. Perhaps some other setting is affecting the behavior.

http://screencast.com/t/NzZiOTZiMmE
12-02-2009 02:14 PM
Human being with feelings
 
But you can see that in the clips at the right hand side of the selection are missing as well after removing the clips in the time area.
That should not happen.
If you reduce the time area to not include the fades, the neighboring clips will stay.
12-02-2009 06:25 PM
Human being with feelings
 
i noticed that when i removed the track containing the empty items, the removal of the clips within the time region will work correctly.

but then i do get the different fades.
track 1 has no fades.
track 2 + 3 do have fades but no overlapping.

attached some screenshots showing the trace back.
12-02-2009 07:52 PM
Administrator
 
I'm sorry, I simply do not understand the bug report. Please be very specific and describe exactly which item does not end up where you expect. Remember that your action deletes the time selection twice, first when removing the items, then when removing the time selection.
12-02-2009 07:56 PM
Administrator
 
[edit, bad information]
12-02-2009 08:21 PM
Human being with feelings
 
I get the same results doing the instructions manually or using the macro.
I'm using the latest OSX 3.14159 version.
Maybe things are different there.
There is bizarre things happening when selecting and splitting and deleting.
Sorry.
12-02-2009 08:36 PM
Administrator
 
[edit, bad information]
12-02-2009 10:19 PM
Administrator
 
Most of my posts above were incorrect, I've edited out the misleading information.

Resetting to "confirmed" and investigating.
Closed

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 12:11 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.