Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Open Bug

Automation Issue Tools
issueid=5515 02-17-2015 03:43 AM
Human being with feelings
Reaper is sending a constant stream of automation message even when the parameter has not changed.

I am on mac osx 10.7.5 ( lion ) on a macbook air 1.7 ghz intel core i5 ( 4 gb ram ), s-gear v2.5 AU.

The bug occurs without the use of an external interface, so it happens using the mac's default system device.

I have searched the project tools but did not find this issue / bug. I have also checked all previous versions between my 4.71 and current 4.77 for this bug fix and could not find it.

The issue / bug is related to automation of plug-ins and causes the channel to mute. Specifically, I can reproduce the issue using S-gear v2.5 and trying to automate the AMP A/B amp selection either manually or live. Upon playback this mutes the track / channel and the only way to regain signal is to either bypass the automation or remove it.

I can get the amps to change from one to the other no problem via both automation methods.

Both methods mute the track when the automation is enabled and the only way i can find to get sound from the track is to turn off or bypass the Amp A/B automation for it. When i say mute, it does not mute the track visually ( so not muted in the mixer or anywhere else ), just no sound and no signal through s-gear. I know i need automation set to trim/read in order to hear the automation done and this seems to work fine with the other few settings i have automated in s-gear, just not with amp selection.

I contacted Mike Scuffham ( developer of S-gear ) who was very helpful and this is one of his replies ;

"I have looked into this.

It seems that Reaper is sending a constant stream of automation message even when the parameter has not changed. This is a problem for parameters like AMP A/B which are required to mute the S-GEAR input signal during the change. The constant stream of messages results in the plug-in being constantly muted. Iíve not seen this behaviour with for example Appleís Logic DAW.

There is another way you could automate AMP A/B (and other parameters). This is to use the ReaMIDIControl plug-in. This is a plug-in which can be used to send MIDI messages to other plug-ins on the track. It is a very versatile tool, you can use it to send individual MIDI messages or groups of Control Change messages. It can also be automated. Iím afraid you will have to work through the documentation to see how to use it.

Sorry I canít offer a simple solution, but I think the MIDI control is worth investigating.


Mike initially thought it was a problem with s-gear but after looking into it concluded the above.
Because of this, i would greatly appreciate it if you could take a look at this, as i do not think using another plug-in to work around the problem is the best solution as it seems to be a bug within Reaper.

Many thanks and kind regards

Issue Details
Issue Type Open Bug
Project Deprecated REAPER issue tracker
Category Plugins
Status Unconfirmed
Priority 5 - Medium
Affected Version 4.71
Fixed Version (none)
Users able to reproduce bug 3
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)

02-17-2015 10:23 AM
Human being with feelings
This is in fact confirmed for all plugins, though it's a feature I suppose.

For every plugin parameter, Reaper sends the value for every block, i.e. every 256 samples if your CoreAudio or ASIO block size is set to 256 samples.

This produces some problems with some plugins, like DMG Audio Equality and EQuick, until those were fixed.

This might a good one to write a feature request for, since you'd probably want that particular plugin not to be sent automation data at all times, only when things actually change.
02-18-2015 04:35 AM
Human being with feelings
Thanks airon,

I understand what you're saying but the developer has not suggested he can fix it and i can understand that. So if Reaper won't fix it either then i am left with a paid for plug-in in a paid for DAW that does not work properly and no solution. It's a grey area i suppose. I spent a day trying to work out ReaControlMidi to no avail as it does not tell you exactly how to use it in the user guide or the effects guide and no one has been able to help on the repaer forum ( it is a pretty specific problem ).

S-gear has now started to act up with stereo panning on one project as well as having a muted delay in changing AMPS A/B and when sellecting the plugin ( so i can't even use it with a live automation mix ) on all projects . I have not had a single AU plug-in that has worked properly since getting reaper on OSX ( there is a long list of them with problems on the OSX forum ) . I thought i had got away with it with s-gear but alas.....Problem is it is integral to completing all my projects. There is no VST for mac either, only AU and VST3 ( which reaper does not currently support right ? ).

EDIT : I think a feature request is a good idea thanks. Are the two plugins you mention above AU or VST please ?

02-18-2015 04:07 PM
Human being with feelings
I'm referring to the VST2 versions of the plugins. Dave Gamble fixed the plugins but it did take a while.

Perhaps this problem can be worked around with some community help. There should be folks with the same problem you have.
02-19-2015 02:17 AM
Human being with feelings
Thanks Airon,

I have a thread going on on the osx forum and serr is really trying to help but no luck and all out of ideas. Will contact s-gear dev again.

02-21-2015 09:48 AM
Human being with feelings
Hi all,

Just as an update i have been working with S-gear and Ignite Amps developers to find the cause of problems with both AU plugins. From the Ignite Amps crash reports the cause appears ( at least initially ) to be the same as the issue with S-gear namely Reapers midi implementation, except there is also possibly a GUI issue with the ignite amps plugins and it is suspected that this is causing them to crash.

Ignite amps is now working on a fix for the AU.

The problem is that reaper seems to be doing certain things in a different way to other DAW's and this is causing problems with some AU's. It is a shame that these differences are not highlighted / brought to the attention of / more well known to third party plugin designers so they can account for them in their designs.

I think a feature request to be able to mute all midi data to certain ( or all ) third party plugins would be a very good idea.

03-21-2015 09:57 AM
Human being with feelings

Since posting this general bug report i have found other repeatable issues that appear to be related/ specific to osx 10.7.5 like PDC not working at all for any plugin ( including cockos ReaEQ, ReaDelay and ReaVerb ) resulting in not being able to live mix mute/unmute tracks without unacceptable delay and in some cases not being able to use the cockos plugins at all.

I feel it is only fair to call the automation problem a bug after thinking about it as developers use VST / AU and not Reapers proprietary system ( whatever that may be) for developing plugins and this would account for the massive number of OSX plugins that have problems.

I take issue with reaper being called a professional DAW on the home page. On osx 10.7.5 there are bugs that prevent me from using it as advertised and i have no issues with my osx with any other program. I appreciate there is a generous trial for the program but that does not help with genuine repeatable problems that you find out about after the trial period is over and you have paid for it. Not having a properly working ReaInsert by itself foregoes the right to call it a professional DAW in reality. Reaper settings were not correct for standard DAW use on install which then required a huge learning curve in order to over come ( and help from the great and knowledgeable forum members in some cases ). The implementation of 3rd party plugins is not correct either in part due to the fact that some developers do not support Reaper. I now have noticed other important issues using s-gear in Reaper like wrong calibration of input levels that do not occur on other DAW's ( or even garageband ! ).

I have not received any official support for this genuine issue on the forum or via emails that i have sent to customer support. This means i am not willing to spend precious time reporting other bugs ( if they are not going to respond to my first bug ).

I appreciate that the asking price is low for reaper and i like to support digital companies that do not exclude older OS's ( this is why i supported it ) but this is not the issue. There are far too many real bug reports going unanswered here and far too many third party plugin problems on osx. I appreciate time and staff must be limited but a much greater transparency of issues would be very helpful to allow people to make an informed decision on something as important as a new DAW before people spend many months learning a product only to find out that it is not in fact usable on their system.

Its back to other standard VST/AU supported DAW's for me. It is the amount of time wasted on learning a new DAW like Reaper from scratch (as it is very different from other DAW's i am familiar with ) that has hurt me and many others i am sure ( and not the modest asking price ).

I thought i would give this feedback after months and months of frustration with Reaper on a mac ( 10.7.5 ). I know how to use it but it simply does not work as intended.

EDIT : v5 pre-release notes seem to include fixes for ReaInsert and some of the other issues i have. Here's hopingÖ.

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 06:46 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.