Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Closed Issue

Scrubbing Bug Issue Tools
issueid=1101 08-30-2009 10:16 PM
Human being with feelings
Scrubbing Bug
Uncommanded rapid auto-replay during scrubbing

Reaper v3.104
Intel Board
P4, 2.0 ghz
2 gb RAM
Digi001
Total tracks recorded: 9

Recorded several tracks from vinyl and was scrubbing right to set a marker for the next track (#10). As I neared the end of the previous recording track (#9)the complete track began playing back at rapid speed (like a 33rpm played back at 78rpm). The only way I could stop it was to close Reaper without Saving. Of course, re-opening Reaper I had to re-record the track all over again.
I tried this several times, always with the same result. The last time I recorded the track, I Saved and Closed the project before continuing so I had a completed track before opening the project. This seemed to correct the issue, until I repeated the same functions. As long as I Save, Close, then Re-open the same project before proceeding to the next track I have no further problems.
Issue Details
Issue Type Closed Issue
Project Deprecated REAPER issue tracker
Category Editing behavior
Status Fixed
Priority 5 - Medium
Affected Version 3.102
Closed Version 3.2
Yes votes 0
No votes 0
Assigned Users (none)
Tags (none)

08-31-2009 06:09 AM
Administrator
 
This is while the recording was in process? You shouldn't be able to scrub audio while recording, do you mean scrub or just moving the edit cursor ahead to drop a marker? How exactly were you moving the edit cursor?
Reply
08-31-2009 06:57 AM
Human being with feelings
 
Glad you asked for the clarification.
During playback was tapping the Right Arrow key to move the line forward to set another marker.

Thanks!
helo
Reply
08-31-2009 11:37 AM
Administrator
 
Sorry, still not clear: this is while recording or while playing back? (You say "during playback" but then you say you had to re-record the track...) Thanks.


... either way, I can't reproduce it. Could you give a more specific step-by-step of how to reproduce?
Reply
09-02-2009 12:18 AM
Human being with feelings
 
OK, and Apologies for not being clearer.
1. Several separate tracks recorded, a marker for each placed at the beginning of the track. Last recorded track does not have a marker placed yet.
2. While stopped (No Record, No Playback)placed Edit Cursor near the end of the last track, then using the right arrow key slowly moved Edit Cursor to end of previously recorded track, as I wanted the very end of the track to be my starting point for the next recorded track.
3. Just before reaching end of previously recorded track (moving the Edit Cursor to the right)it would start un-commanded high-speed playback of the track.
4. I was only able to stop it by closing and re-opening Reaper. When closing I did not Save due to fears I would be saving a problem.
5. Unless the previously recorded track was saved *prior* to moving the Edit Cursor, the previously recorded track would be lost (See #4, above).

I've repeated this at least 6 times with the same result, but noted that if I use the Right Arrow key *very* slowly, the problem does not occur. by "very slowly, I mean one tap every 1-2 seconds. I used this method to complete the project.

I originally posted this in another forum (because I wasn't sure if it was Operator Error, Machine Issue, or Bug) but was referred to Bug Tracking. It could well be Operator Error, since I'm a fair newb to Reaper, but I won't know without help.

Not sure how much clearer I can be at this point. Should you need any more info please don't hesitate to ask. I really do appreciate the effort put into Reaper and am amazed at the support available! PT never treated me this well!

helo
Reply
09-02-2009 05:25 AM
Administrator
 
That's clear, thanks.

The part that confused me was the "lost recording." If you have a recorded item in a project, that recording is on disk somewhere. If the project is closed without being saved, the project won't contain the recording when it's reopened, but that recording is still on disk next to all the other recordings, you don't need to re-record it.

In any case, we'll do our best to reproduce.
Reply
09-02-2009 05:33 AM
Administrator
 
Would you mind emailing the project (in the state where scrubbing forward will cause playback to start) to support at cockos dot com?
Reply
09-03-2009 11:53 AM
Human being with feelings
 
Sorry.
A day late on that one. Once I finally completed it and burned to CD, I trashed the project, emptied Recycle, and Defragged the disk. Never thought you might want it.

After listening to same project in my vehicle I noted "burps" in one of the tracks. Looks like I'll be re-creating the project anyway, so if the problem re-occurs, I'll forward to you.

If it does *not* re-occur, I'll assume it was operator error of some sort and relieve you of any further time possibly wasted on this.
Reply
09-06-2009 08:24 PM
Human being with feelings
 
Schwa,

Labor Day Weekend. Given the day off. :-) Here's what I'm experiencing today while re-creating the project.

Project: Record Vinyl album "McGuinn, Clark, & Hillman" to CD

Setup: - Four Tracks recorded, Markers already set for #1 thru #4. - Setting up marker for track #5 prior to recording said track. - Currently in STOP mode.

Symptom(s): If cursor is set inside of track #4 near end (Approx. timeline 13:53:500), then scrolled Right using Right arrow key, uncommanded high-speed playback of track #4 occurs.

NEW: Clicking the Transport STOP button stops high-speed playback (This is good, as it didn't before). This behavior also occurs when identical steps are repeated in any other tracks.
NEW: Noted that once the uncommanded high-speed playback is stopped with the Transport, the problem does not occur again on previously recorded tracks.
NEW: When moving the cursor with the arrow keys prior to setting the Marker, as long as I scroll *first* with the LEFT key, *then* use the right key, the problem never occurs in the first place.
NEW: As long as I place my cursor *after* the end of the last recorded track, then move it with the LEFT arrow key only, the problem does not occur.

Do you need the project (.rpp) file and supporting .wav files (there are eight files)?
Reply
09-06-2009 08:44 PM
Human being with feelings
 
Here is the zipped project.

Upload failed. Trying again.

No go. Got this message:

vBulletin Message

Your submission could not be processed because a security token was missing.

If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error.
Reply
09-07-2009 05:33 PM
Super Moderator (no feelings)
 
Reply
09-07-2009 09:58 PM
Administrator
 
If it's too big or troublesome to upload, you can email the proj to support at cockos dot com (please note that it's about http://forum.cockos.com/project.php?issueid=1101).
Reply
09-13-2009 09:57 AM
Human being with feelings
 
.zip file sent via e-mail.

Thanks for looking into this.
Reply
09-13-2009 10:09 AM
Human being with feelings
 
Also uploaded to stashbox:

http://stashbox.org/630116/Bug_ID_1101.zip

Tracks shortened considerably to allow for e-mail and upload. Problem still occurs.

If no one else can duplicate this, I can only assume I'm:
a)crazy (we often have repetitive hallucinations),
b)stoned (left-over tracers from the good ol' days), or
c)stupid (need to go back and read the.pdf).

I'll accept the majority vote. ;-)
Reply
09-13-2009 12:05 PM
-blšnk-
 
Could you please post a screenshot of the Preference's "Playback" page and also which OS you're running?
I can't reproduce yet on XP32bit but don't want to hit the "cannot reproduce" button this early. Does this happen at any zoom? (the scrubbing speed is zoom dependant, why I ask)
Reply
09-13-2009 08:35 PM
Human being with feelings
 
XP-32
Screenie of Preferences>Playback and Project window at my working zoom level.
Reply
01-10-2010 12:29 PM
Administrator
 
Reproduced and confirmed!
Reply
01-10-2010 08:27 PM
Human being with feelings
 
Thanks for sticking with it, bro's! :-)

( Edit )

Just Dl'd the latest (v3.22)and all is well! Thanks again!

So nice to know we can count on the continued support! :-)
Reply
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 12:51 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.