Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Open Bug

Time selection auto punch bug Issue Tools
issueid=1313 10-08-2009 09:22 AM
Human being with feelings
Time selection auto punch bug
When recording midi track in time selection auto punch mode, the previous midi item notes will hang on

When recording midi track in time selection auto punch mode (which I do all the time), the previous midi item notes will hang on when recording starts. This is true when recording starts right after a midi item (without a gap).

This worked ok with Reaper 2.58
Issue Details
Issue Type Open Bug
Project Deprecated REAPER issue tracker
Category MIDI recording and playback
Status Confirmed
Priority 3
Affected Version 3.12
Fixed Version (none)
Users able to reproduce bug 1
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)

10-08-2009 11:36 AM
Super Moderator (no feelings)
 
Do you have an example project that demonstrates the bug for us by chance? I can't reproduce.
Reply
10-09-2009 05:31 AM
Human being with feelings
 
Yeah, the example project is in attachment.

Did you start playback (recording) exactly at the start of previous item? That is the only way it works. Try starting before or after and you should be able to reproduce.
Reply
10-09-2009 06:09 AM
Administrator
 
You are saying that when recording starts at 0:06, the notes from the item that ends at 0.06 will hang? That's not happening here, so it may depend on buffer size or some other variable. Would you mind posting your REAPER.ini file and telling us your audio buffer size as well?
Reply
10-09-2009 06:57 AM
Human being with feelings
 
Quote:
Originally Posted by schwa
You are saying that when recording starts at 0:06, the notes from the item that ends at 0.06 will hang? That's not happening here, so it may depend on buffer size or some other variable. Would you mind posting your REAPER.ini file and telling us your audio buffer size as well?
Yes, this is the problem exactly.
I can only say this does not happen with 2.58

Buffer size/sample rate doesn't have any effect.

I have attached the Reaper ini

Thanks
Reply
10-09-2009 07:07 AM
Administrator
 
Can you say what buffer size and sample rate you are using, even if it doesnt seem to help when you change it?
Reply
10-09-2009 07:31 AM
Administrator
 
OK, I can reproduce with buffer size at 256, not at lower buffer sizes though. Bug confirmed.
Reply
10-09-2009 08:27 AM
Administrator
 
... as a workaround until this is fixed, if your recording style allows you to enable "monitor track media when recording", that will probably stop the hanging notes.
Reply
01-15-2010 07:15 AM
Human being with feelings
 
Confirmed here!

(Only happens in "Record:input" and "Record: MIDI replace in existing items" modes)
Reply
02-11-2010 01:34 AM
Human being with feelings
 
"right after Midi item", "happens with 256+ buffer size", etc. hmm... sounds a lot like my favorite bug:

http://forum.cockos.com/showthread.php?t=48109

Check out my last post there: I found out a there's a relationship with FX inserts too.

I've been thinking about a bad mix of uninitialized buffers and wrong timing (rounding?)
Reply
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 10:55 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.