Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Closed Issue

Zoom in MIDI editor still not working very well :( Issue Tools
issueid=1359 10-17-2009 08:13 AM
Human being with feelings
Zoom in MIDI editor still not working very well :(

This is what I get when I load a MIDI item, load my Addictive Drums drum map, set view mode to Hide unnamed and unused, the note names now fill the whole MIDI editor screen. When I click once on vertical scrollbar, I get graphical error like this, which disappears if I move the mouse cursor away from the scrollbar:



Then, if I zoom in vertically, then zoom out again - I can't get back to the same zoom level as it was before! Even if I click on - button under vertical scrollbar, it doesn't move to smaller zoom level! This is serious, guys!



Why are we STILL able to do this?




Please fix this soon!
Issue Details
Issue Type Closed Issue
Project Deprecated REAPER issue tracker
Category Editing behavior
Status Fixed
Priority 1 - Highest
Affected Version 3.12
Closed Version 4.76
Yes votes 13
No votes 2
Assigned Users (none)
Tags (none)

10-23-2009 08:26 AM
NAS NAS is offline
Human being with feelings
 
VIDEO

Little video of the issues im having that relate to this
I have the issues ED is having but also as you can see i have the timeline disappearing when opening the MIDI editor

NAS
Reply
11-11-2009 03:01 AM
Human being with feelings
 
NAS, your link is inacessible :( Can you please re-host it?


Also, regarding this issue: image 1 - NOT FIXED, image 2 (zoom level fluidity) - NOT QUITE FIXED, image 3 - WILL IT EVER BE FIXED!? Death to empty space, it should NEVER show up!!
Reply
11-11-2009 03:08 AM
Human being with feelings
 
To elaborate on image 2:

Load my AD drum map (I hope any named notes file will do well, too). REMEMBER the zoom level you're at. Now mousescroll vertically up to the max (where you get BIG note lanes). Now mousescroll vertically down to the smallest. You will get ultra tiny letters now. Now just vertically mousescroll up ONE NOTCH. See the inconsistency? Why such big jump in zoom level? THIS SHOULD BE FLUID AT ALL TIMES, ALL ZOOM LEVELS MUST ALWAYS BE SWEPT!


And what makes all this worse: the mousescrolling DOES NOT work the same as clicking on +/- zoom buttons below the scrollbar!!!
Reply
01-03-2015 12:30 AM
Human being with feelings
 
Cannot confirm in 4.76 - may have been fixed - EvilDragon are you still encountering the bug in the exact same set up circumstances?
Reply
01-03-2015 01:31 AM
Human being with feelings
 
No, since multiple MIDI items display was introduced, I couldn't repro this either. Should be marked as fixed, I think.
Reply
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 01:58 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.