Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Closed Issue

Preserve PDC doesnt work properly. Issue Tools
issueid=842 08-05-2009 01:13 AM
Human being with feelings
Preserve PDC doesnt work properly.
Doesnt fully compenste latency.

Im calling this a bug because 'preserve pdc...' doesnt preserve the same amount of latency as record : output(not latency compensated) and for the feature to work as described, it should.


Have a look...

[IMG]http://img35.**************/img35/9389/pdcqrs.png[/IMG]



The change log claims that this feaure is intended to have synths sound the same when played live vs played back....


+ "Preserve PDC delayed monitoring" accounts for recording latency as well as PDC (so soft synths sound the same when played live vs played back, etc)


...but they dont because the latency isnt fully preserved as it is when using record : output. Its the same situation when recording monitored audio as midi.


A repro is provided here...


http://forum.cockos.com/showpost.php...6&postcount=13


edit:

MIDI is fixed now but audio recording is still wrong using this.

Also, the other problem with this setting is that the item is shifted on the timeline instead of the audio being shifted in the item. The problem with this is that the item will lose its preserved latency if copied to another location and snapped to a bar. It also cant easily be used in a loop either then.

Record: output has the item starting from where recording started and the audio/midi in the correct place, this setting should do the same IMO.

See here also...http://forum.cockos.com/showthread.php?p=343187
Issue Details
Issue Type Closed Issue
Project Deprecated REAPER issue tracker
Category Audio recording and playback
Status Fixed
Priority 1 - Highest
Affected Version 3.07
Closed Version (none)
Yes votes 9
No votes 0
Assigned Users (none)
Tags (none)

08-07-2009 06:49 PM
Human being with feelings
 
As two people have reproduced this, can its status be changed to confirmed please.
Reply
08-11-2009 10:27 AM
Administrator
 
Some aspects of this will be fixed soon.. Others might not ;)

FWIW, "'preserve pdc...' doesnt preserve the same amount of latency as record : output(not latency compensated)" this may not necessarily be a bug.. anyhoo.
Reply
08-11-2009 05:52 PM
Human being with feelings
 
OK, well thanks for checking it out. :)

So, could you explain the advantage of 'preserve PDC...' not preserving the same amount as record: output(nlc) please? I dont mind being wrong, just would like to understand why.

...or could we get an option so that it does?
Reply
08-13-2009 12:00 PM
Human being with feelings
 
I've also done tests (again w3.07pre8) recording the click and monitored softsynth together through the air.

It looks to me that if you want to:

record midi while playing a softsynth

and

have it sound the same upon playback as it did while recording, relative to the rest of the project

then the correct setting is "record output - midi"

- and all other settings will not work (they will all put the midi earlier than desired by varying amounts)

is that right? and if so then when would someone use "preserve pdc ..."?

this is super important for folks who want to use performances of sofsynths that are not quantized.
Reply
08-13-2009 05:59 PM
Human being with feelings
 
Thanks for the support semiquaver. :)

Im also struggling to understand why theyve implemented it like they have.


Take a look at the new behaviour in 3.07p8.

The record: output track is still the one that lines up with the 'loopback(what you hear)' track.

The 'preserve PDC' track is always early by the ASIO buffer size. So, why doesnt 'preserve PDC' preserve this latency as well?

[img]http://img188.**************/img188/4622/fxmaster.png[/img]
Reply
08-13-2009 06:51 PM
Human being with feelings
 
Reply
08-16-2009 01:25 AM
Human being with feelings
 
Just tested 3.102.

MIDI is spot on(with ticks per quater note set to 30000), yay.

...but when recording audio, the item is 36 samples early. Thats with or without fx on the master.

Tried switching buffer size from 256 to 512 but theres no difference, still 36 samples early.

Theres a test project in the BR thread over here...

http://forum.cockos.com/showpost.php...59&postcount=3


Also, is the item start thing probably not getting fixed?
Reply
08-18-2009 09:56 AM
Human being with feelings
 
confirmed midi is right at last - thankyouthankyouthankyou
and thanks Billoon for the BR

re: item start as a workaround I suppose you could make a 'stop recording' macro:

move to item start
move right to next grid division
Xenakios: trim left edge to edit cursor
Reply
08-18-2009 09:53 PM
Human being with feelings
 
Yeah a fix would be nice, but we can probably work around that for now.

This is so close to being fixed then, only 36 samples to go. :)
Reply
09-17-2009 01:12 AM
Human being with feelings
 
Just tried the latest pre, this still isnt fixed.

Hope it hasnt been forgotten. :)
Reply
10-25-2009 11:01 PM
Human being with feelings
 
Sorry for the bump, but is it just me thats getting this 35 sample offset when using this setting?

Strange that it only happens when recording audio and not midi too.
Reply
11-12-2009 10:44 PM
Human being with feelings
 
No-one?
Reply
12-14-2009 11:54 PM
Human being with feelings
 
I just noticed that this ticket has had it status changed from 'fix coming soon' to 'confirmed'.

Does this mean there are no plans to finish fixing this (the 35 sample offset) or something else?
Reply
05-17-2013 09:17 AM
Human being with feelings
 
Fixed. v4.41pre5 - May 17 2013
Reply
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 11:45 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.