Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Closed Issue

Ghost meter level for a multi-out VSTi Issue Tools
issueid=310 06-24-2009 04:49 AM
Human being with feelings
Ghost meter level for a multi-out VSTi
-- audio level is registered wrongly on the VSTi track

Here's something that's bugged me for a while.

Steps:
-- Insert a multi-output VSTi (track 2 in the screenshots),
-- and generate its audio output tracks,
-- route some of its sounds to different outputs,
-- trigger a sound that goes to the first output,
-- trigger a sound that goes to another output (third output pair in the screenshots).

Results:
-- any sound that goes to the first output (track 3) is also metered on the VSTi track (track 2) but no audio is on that track,
-- even if the level on track 3 is dropped the audio is still metered on track 2,
-- so "what you see is not what you get" :)
-- any sound that goes to any other output is only metered and sounds on its own track (track 5 in the third screenshot).

Expected Results:
-- the meter on the VSTi track does not register any audio.

Screenshots:
-- a sound sent to the first output,
-- a sound sent to the first output with its track volume dropped,
-- a sound sent to the third output.

[img]http://img13.**************/img13/209/r304dsmultiout01.th.png[/img]

[img]http://img13.**************/img13/2396/r304dsmultiout02.th.png[/img]

[img]http://img13.**************/img13/5193/r304dsmultiout03.th.png[/img]
Issue Details
Issue Type Closed Issue
Project Deprecated REAPER issue tracker
Category Audio recording and playback
Status Not a Reaper Bug
Priority 10 - Lowest
Affected Version 3.04
Closed Version (none)
Yes votes 3
No votes 0
Assigned Users (none)
Tags Multi-Out, VSTi

06-24-2009 07:47 AM
Human being with feelings
 
I totally agree. Isn't what the meters (the MCP peak meters) are doing what the MIDI output activity or velocity meters are for?
Reply
06-24-2009 07:53 AM
Moderator
 
I think this is not a bug but more a FR to set a track to 0 channels because your main track, which contains the VSTi, always output the audio it receives from the main stereo thru 1/2. If we were able to set a track to 0 channels this wouldn't happen.
Reply
06-24-2009 08:16 AM
Human being with feelings
 
Quote:
Originally Posted by Mercado_Negro
I think this is not a bug but more a FR to set a track to 0 channels because your main track, which contains the VSTi, always output the audio it receives from the main stereo thru 1/2. If we were able to set a track to 0 channels this wouldn't happen.
Sorry, M-N, the VSTi track does not output any hearable audio (as the Master/Parent Send is unchecked automatically for this track) - but the audio still registers on the VSTi track's meters. If I enable Master/Parent Send then I get the audio twice: on the VSTi track and on the first generated track - that cannot be right, can it?

IMO. the current implementation is inconsistent.

Given that output tracks are automatically generated for all the VSTi outputs and the VSTi outputs are routed to those tracks, the VSTi track really should not have any audio on it.
Reply
06-24-2009 08:23 AM
Moderator
 
DarkStar I think you misunderstood me here. I know "Master/Parent Send" is disabled in your example. The reason for that behaviour lies in the fact that the track where the VSTi is inserted is outputting audio through its main outputs because it can't be set to 0 channels.
Reply
06-24-2009 08:31 AM
Human being with feelings
 
Ok, I understand what you were saying now !

All we need is for that metering to be turned off, one way or another :)
Reply
06-24-2009 08:38 AM
Moderator
 
Exactly :D go for a FR now mate! I'd like to switch it off too :)
Reply
06-24-2009 09:26 AM
Human being with feelings
 
Priority 10 and "Not a Bug" ?

I disagree.
-----
But I'm am happy to move this to the FR Issue Tracker forum and reprioritise it.
Reply
06-24-2009 09:28 AM
Human being with feelings
 
This seems weird...it's also strange to me that you can bypass the master/parent and have all sends to Pre-Fader(Post-Fx) and you still see the meter move. This is with audio and MIDI.

Also, you will need at least 1 channel to route anything.
Reply
06-24-2009 09:50 AM
Moderator
 
"Set channels to 0" was only a way to put it so he could understand me labyrinth ;)
Reply
06-24-2009 10:59 AM
Administrator
 
Agreed with "not a bug." The first two channels of vsti output are the track output, regardless of whether they are routed anywhere.

You wouldn't want to be able to set the track channels to zero to handle this though, the track is processing the real vsti audio output on its channels (which are all sent elsewhere). The real FR is to be able to turn off a track's VU meter.
Reply
06-24-2009 12:03 PM
Human being with feelings
 
Exactly. If no audio is sent to any of that track's channels (or to the fader really) then the meter should be blank.
Reply
06-24-2009 01:40 PM
Human being with feelings
 
Quote:
Originally Posted by schwa
Agreed with "not a bug." The first two channels of vsti output are the track output, regardless of whether they are routed anywhere.
So the first two channels of the VSTi are always routed to the track itself. It is only the fact that "Master/Parent Send" is turned off that prevents the sound being audible. It shows on the meter but is not output.

And the function "Build multichannel output for selected FX" also routes the first two channels of the VSTi to the first generated output track.

Quote:
Originally Posted by schwa
The real FR is to be able to turn off a track's VU meter.
OK, I'll raise this as an FR.

Phew!

-----------------------------------
EDIT:
link to the FR: http://forum.cockos.com/project.php?issueid=322
Reply
06-24-2009 02:03 PM
Human being with feelings
 
Here is my beef....

When you do "create multi-channel setup" for the select VSTi... it creates a track for the 1+2 outputs of the VSTi also ... it is not necessary if the VSTi track also handles those outputs.

I think Reaper should EITHER... just create new tracks for outputs 3+4 and so on.... and keep the VSTi track as the master outputs. Or, it should automatically mute the VSTi tracks VU meter as Darkstar is suggesting.

It is really annoying to have two tracks doing the same thing, imo.
Reply
06-25-2009 06:47 AM
Human being with feelings
 
It is also a bit confusing, especially to newer users.
Reply
07-06-2009 01:21 AM
Human being with feelings
 
The way I go around it, for now, is to lower the volume of the track that holds only MIDI, all the way. It's not influencing MIDI output volume anyways. But yeah, a way to turn off VU-meter if it's not sending any audio data to certain outputs is surely welcome.
Reply
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 01:45 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.