Go Back   Cockos Incorporated Forums > Projects > Deprecated REAPER issue tracker > Closed Issue

small bug when moving clips down Issue Tools
issueid=1047 08-23-2009 11:34 AM
Human being with feelings
small bug when moving clips down

1. draw midi item - show its mute off icon
2. move that midi item one track down.
now the new track isn't selected yet.
3. click on the mute icon of the midi item.

result -> nothing, just the new track selected, as if you clicked on the contents of the clip.

expected -> the mute should be on, (and maybe the track selected, don't know).

this bug happens only when moving clips down track, not up track.
Issue Details
Issue Type Closed Issue
Project Deprecated REAPER issue tracker
Category Editing behavior
Status Fixed
Priority 10 - Lowest
Affected Version 3.102
Closed Version (none)
Yes votes 1
No votes 2
Assigned Users (none)
Tags (none)

08-23-2009 11:38 AM
Administrator
 
Can't reproduce...
Reply
08-23-2009 11:58 AM
Super Moderator (no feelings)
 
Are you using a non-default theme? (Can't repro either.)
Reply
08-23-2009 12:38 PM
Human being with feelings
 
Quote:
Originally Posted by Steindork
Are you using a non-default theme? (Can't repro either.)
yes, but after i saw swcha post i tried with classic theme
and it still happens
i made a video but i have problem with converting
it's on the way.

edit: i found that's it's something with my reaper.ini file
i will check that and let you know. (not so soon)
Reply
08-23-2009 12:58 PM
Human being with feelings
 
All works Ok here.

There is the Preference "Mouse clicks/edits in track view change track selection". It's off here.
Reply
08-23-2009 01:01 PM
Human being with feelings
 
Quote:
Originally Posted by DarkStar
All works Ok here.

There is the Preference "Mouse clicks/edits in track view change track selection". It's off here.
exactly, that what cause the problem
Reply
08-23-2009 01:15 PM
Super Moderator (no feelings)
 
It's on here by default.
Reply
08-23-2009 02:47 PM
Human being with feelings
 
Quote:
Originally Posted by Steindork
It's on here by default.
yes you right i rememberd something about that.

i almost lost my soul, but i could found what cause the problem.

the default settings - recording - auto arm new created tracks. cause that.

and also another bug with it:
1. if you change that settings (ticked/unticked).
2. when you drag item down - new track created.

but not always according to the default settings.

only after selecting a track (i think) it start respond to the default settings.
Reply
08-23-2009 04:18 PM
Super Moderator (no feelings)
 
Sorry, tried my best with auto-rec-arm on and off etc. and the same once again with XP, no dice. Item lock buttons do always respond, dragging the item down always creates a new track (if not already there).
Reply
08-23-2009 04:53 PM
Human being with feelings
 
it's very easy
i've just easily managed to reproduce that
on XP virtual machine

0. exit reaper.
1. backup your ini file.
2. erase it.
3. start reaper - the audio device setting opened.
4. appearance - media - tick mute off icon
5. default - recording - auto arm on new track.
6. ok.
7. create new track - draw midi item.
8. drag it down.
9. click its mute off icon.

result -> track selected, but mute - nothing.
expected -> mute - on (track selected - maybe).
Reply
08-23-2009 07:47 PM
Administrator
 
Still can't reproduce...
Reply
08-24-2009 08:11 AM
Human being with feelings
 
Quote:
Originally Posted by schwa
Still can't reproduce...
very strange

as i said i could easly reproduce it
on a new virtual machine
completely new installation

so i try to upload a video.
Reply
08-27-2009 04:11 PM
Human being with feelings
 
here is a Video showing how to reproduce.
Reply
08-28-2009 12:00 AM
-blšnk-
 
Aaah haaa!, I could finally reproduce.
It only seems to happen with WaveOut as Audio system.

Never used that setting, (what's it good for anyway?) that's why nobody else could see that behaviour :)
Reply
08-28-2009 12:38 AM
Human being with feelings
 
Quote:
Originally Posted by gofer
Aaah haaa!, I could finally reproduce.
It only seems to happen with WaveOut as Audio system.

Never used that setting, (what's it good for anyway?) that's why nobody else could see that behaviour :)
1. asio don't work for my laptop.

2. don't know why nobody couldn't, i explained it in detail
Reply
08-28-2009 12:55 AM
-blšnk-
 
Quote:
Originally Posted by whatsup
1. asio don't work for my laptop.

2. don't know why nobody couldn't, i explained it in detail
1. did you try WDM? (EDIT: Or ASIO4ALL. Anything should be superiour to the microsoft WaveOut device driver.)

2. I only just saw the WaveOut setting in that video, I can well imagine how to miss that spot.
Reply
08-31-2009 03:35 PM
Human being with feelings
 
i posted video
and someone can reproduce.

this should return to the open bugs.
Reply
08-31-2009 06:57 PM
Administrator
 
OK, a real bug. The problem is combination of preferences for automatic recarm and always showing VU meters for recarmed tracks.
Reply
Reply

Issue Tools
Subscribe to this issue

All times are GMT -7. The time now is 02:47 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.